Wifi Keeps Turning Itself OnSupport


Last Updated:

  1. English

    English Member This Topic's Starter

    Joined:
    Sep 8, 2010
    Messages:
    6
    Likes Received:
    2
    Hi all,
    new member to the forum, and new to the Android world.
    I have a new Samsung Captivate, and I can't keep the wifi off. No matter how many times I go to settings (or use the pull-down curtain), and switch off the wifi, within a minute or so, the wifi comes on again. It also turns itself off again periodically when this happens.

    I don't have any after market power manager installed. I suspect this may be down to an app, but have no idea where to start looking for the solution.
     

    Advertisement
  2. getDange

    getDange Well-Known Member

    Joined:
    Jul 15, 2010
    Messages:
    252
    Likes Received:
    29
    Never heard of it. Yes I would guess the same, you installed some app that manages your network settings. If you do not know what it is, you can try going to Settings, Applications, and then click through every app you recently installed and review their permissions setting. When you see an app that has access to "System Tools", specifically "Change WiFi State", it is suspect.
     
  3. bmoliver

    bmoliver Well-Known Member

    Joined:
    Jul 25, 2010
    Messages:
    156
    Likes Received:
    12
    Check the advanced WiFi settings to see if the WiFi is set to always be on - Options are Turn off when sleeping, always on during charging, and always on.
     
  4. sremick

    sremick Well-Known Member

    Joined:
    Jun 18, 2010
    Messages:
    2,521
    Likes Received:
    356
    I know Y-5 will do this, probably others as well. Do you have Y5 installed by chance?
     
  5. English

    English Member This Topic's Starter

    Joined:
    Sep 8, 2010
    Messages:
    6
    Likes Received:
    2
    Sorry for the huge delay in getting back to this. No, I don't have Y-5 installed. It is still dong it. Basically, I can turn wi-fi off, but whenever the phone gets within range of a wi-fi connection, it switches on again (if, indeed it ever properly went off), and connects to that network. I have tried all the different settings for the wi-fi sleep policy, and it's still the same.

    When I first switch the wi-fi off, the wi-fi icon disappears, but within a minute (if I'm near a wi-fi connection), it reappears. :-(
     
  6. cadvean

    cadvean New Member

    Joined:
    Oct 28, 2010
    Messages:
    2
    Likes Received:
    0
    Please let me know if you use Locale or Latitude, as it will help with troubleshooting.

    I have the same problem and am just starting to troubleshoot. I suspect either a location service or sync service is the cause. I use both Locale (for location based settings) and Latitude (shares your location with friends). In Locale, I use location as a queue for settings, but knowLocale is smart enough to use cell, wifi, or gps to set my location. Even so, I am disabling my location based conditions in Locale as step 2. (Step 1 was the basic Andorid native settings).

     
  7. cadvean

    cadvean New Member

    Joined:
    Oct 28, 2010
    Messages:
    2
    Likes Received:
    0
    From the devleoper of Locale (Locale Support):

    Why does Wi-Fi keep turning on and off?

    If you have configured any Location conditions smaller than 2,000 meters, Locale will periodically perform brief Wi-Fi scans (even if Wi-Fi is turned off) to help determine your location. Periodic Wi-Fi scans are implicitly configurable, by making all locations 2,000 meters or larger in radius. These periodic Wi-Fi scans consume very little battery power, typically 2% or less.
    _______

    A quick test indicates that either configuring Locale to not use the location condition (which would be a bummer) or by using a free 3rd party location plugin prevents wifi from coming on periodically for location checks. However, the 3rd party plugin also won't be able to use wi-fi to get your location unless you turn it on. What I don't know is how the native Locale location service really affects battery (i haven't tested the developer's claim). If you want the free 3rd party app, search the market for "Location (energy saving)."

    So far, I'm happier with the performance of the native app. The only benefit of the 3rd party app is that is won't turn on your wifi for brief intervals; so it could save you just a little battery life.


     
  8. English

    English Member This Topic's Starter

    Joined:
    Sep 8, 2010
    Messages:
    6
    Likes Received:
    2
    Hi Cadvean,
    unfortunately, I can't tell you the exact problem that was causing it, but you're on the right track.
    My phone developed a whole host of other problems - including the random shutdowns, so I'm now working on a replacement (unrooted) phone.

    However, I do remember that it was a google service that was causing the Wi-Fi to switch on. Possibly, it was lattitude. I can't remember if I had locale running, but lattitude was.
    In the process of troubleshooting, I managed to completely brick my phone and took a couple of days to recover.

    Right before I bricked the phone, I had noticed that every time the wifi turned on, a google service showed briefly in the services section - and then disappeared again.

    Hope this helps some, and good luck! I will be interested to hear how it works out.
     
  9. English

    English Member This Topic's Starter

    Joined:
    Sep 8, 2010
    Messages:
    6
    Likes Received:
    2
    Ah, we cross posted. That's interesting. The trouble with the wi-fi turning itself on periodically like that was that if you're near a wi-fi connection, and don't want to use it, any apps you're using at the time get very confused as they don't know whether to use Edge/3G, or the wifi to get their data connection.
    This was the problem that I was having, and it was making things very difficult.

    Still, at least you have some kind of answer that didn't involve you bricking the phone like yours truly. :eek:
     
  10. 58russ

    58russ New Member

    Joined:
    Dec 29, 2010
    Messages:
    3
    Likes Received:
    1
    App Y5 Battery Saver appears to have been what kept turning my wifi back on immediately after I turned it off. Once I uninstalled it, my wifi stayed off. Y5 turns on the wifi if a remembered wireless connection is found.
     
  11. Rose4uKy

    Rose4uKy Well-Known Member

    Joined:
    May 6, 2010
    Messages:
    1,230
    Likes Received:
    221
    My wifi started doing this once before and then stopped. Now all of a sudden it wont stop coming back on everytime I turn it off. I was going nuts and if wifi was on but not connected 3G stuff like foursquare wouldn't connect. But I googled my problem came here and found out it's Y5 battery saver. So glad I found that out. I have the app cause I read it weas good and people said it helped save there battery. Honestly I don't use it or know how to set it up right. But I disabled it and now I am good to go my wifi stays off. Yeah! :) \

    I have an EVO BTW. But Google has helped me out with other problems too like why my phone quit syncing cause I was low on disk space. Sprint nor HTC new that one they said I had to hard reset my phone and take it into a store and gave me a ticket number. These forums are great!



     
  12. Created in USA

    Created in USA New Member

    Joined:
    Nov 18, 2011
    Messages:
    1
    Likes Received:
    0
    I had the same problem - unable to turn Wifi off permanently. It would restart in about 20 seconds when any wifi signal was detected, then off for a moment, then mostly on. It was caused by the "My Location" setting in WeatherBug Elite, in Preferences. Unchecked "Follow-Me" to stop this problem. Problem Resolved. Have a great day.
     

    Attached Files:

  13. JadedKitty

    JadedKitty New Member

    Joined:
    Jan 3, 2012
    Messages:
    4
    Likes Received:
    1
    I was having the same problem as well with my samsung captivate...
    My problem/solution turned out to be the app Green Power Premium... All of the sudden (I've had this app & phone for months now) it decided the wifi needed to stay on.. So I selected "stop managing wifi" and it turned off and stayed off...

    Now I'm off to figure out why I suddenly stopped receiving incoming text messages
     

Share This Page

Loading...