Wifi Keeps Turning OnSupport


  1. ndh777

    ndh777 Well-Known Member

    I keep shutting off wifi and it keeps turning itself back on. I can't find anything in the settings that would allow it to turn on by itself. Anyone got any ideas?

    Advertisement
    :
  2. SUroot

    SUroot Well-Known Member Developer

    There's not a setting on mine. When did it start? Install any apps?
  3. ndh777

    ndh777 Well-Known Member

    It seems to have stopped. I'm thinking that it could've been one of two things:
    -I was trying to download an app on Amazon app store and it needed a wifi connection. Eventually it said that it failed to download.
    -I was plugged into my car's charger so there may be a setting that has my phone automatically connect to wifi.

    After I unplugged and the download failed, my phone seems to have stopped turning on wifi. I'm surprised if it was Amazon's doing as I don't think that that app has those kinds of permissions. And the charger setting in the wifi settings isn't checked.

    Perhaps I should check the Amazon's app permissions.

    Do you think that it could be either or perhaps another issue?
  4. ndh777

    ndh777 Well-Known Member

    Interesting. That Amazon appstkre app has the permission simply view wifi state but doesn't specify whether it can change it or not.
  5. toastman91

    toastman91 New Member

    Settings->(Wireless and Networks) More Settings-> Mobile Networks -> Automatic Connections -> Click "Sprint Automatic connection"

    When this is checked the wifi will turn on automatically, leave it unchecked to maintain control over your wifi settings
    ndh777 likes this.
  6. ndh777

    ndh777 Well-Known Member

    Wow. I had no idea such a setting even existed. This seems to explain it all. Its unchecked now. If anything happens again, I'll post here. Thank you for your answers!
  7. toastman91

    toastman91 New Member

    No problem, had the same issue when I first got the phone lol
    ndh777 likes this.
  8. ndh777

    ndh777 Well-Known Member

    After setting that up, I haven't had it turn on except once today. I pulled down the bar and it said the wifi was on, but that was the only time. I turned it off, and it hasn't come back on. It was really strange. My other settings about wifi are still the same, everything off and such. But thanks again.
  9. erioni

    erioni New Member

    The Wi-Fi will automatically turn on if the Sprint Connections Optimizer is turned on.

    "to enhance your data experience the Sprint Connections Optimizer will automatically connect you to Wi-Fi networks on your devices remembered list... this is done to facilitate quality assurance and enable feature enhancements, battery level, etc..."

    If you don't want this feature, simply go to Settings > Wireless and network > (more settings) > Mobile network > Automatic Connections and uncheck the Sprint automatic connection option.
  10. nerys

    nerys Well-Known Member

    its kind of a pity as I actually LIKE this feature. but alas at work the wifi is so weak its useless (enough to get a ssid not enough to actually use it) so turning on wifi essentially kills data. if I could tweak it so that wifi below a certain strength threshold would be ignored (by the automatic portion) I would keep it on.

    thanks you for telling how to stop this it was getting annoying it turning itself on like that :)
  11. otacon239

    otacon239 Well-Known Member

    Actually, you can. If you go into Settings -> Wifi and then press the menu button and press Advanced, there's an option to avoid poor connections. Enjoy!
Loading...

Share This Page