WIFI Kills push Gmail?Support


Last Updated:

  1. brownricetofu

    brownricetofu Member This Topic's Starter

    Joined:
    May 11, 2010
    Messages:
    5
    Likes Received:
    0
    Hi everyone- first post here. Been loving my DI but have noticed that when I turn wifi on, gmail is not being pushed to my phone. Then when I turn wifi off, it still doesn't push. I have to turn the phone on and off to get it to resume pushing...

    Anybody else have this problem??? Seems like the WIFI and 3G don't like to play nice...
     

    Advertisement
  2. howarmat

    howarmat Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    1,580
    Likes Received:
    229
    do you have the "always on mobile data" turned off to save battery?
     
  3. JulieJHawk

    JulieJHawk Active Member

    Joined:
    Apr 22, 2010
    Messages:
    38
    Likes Received:
    5
    i have this problem, too! glad to know i'm not the only one!! :)
     
  4. Todd M

    Todd M Well-Known Member

    Joined:
    Apr 7, 2010
    Messages:
    271
    Likes Received:
    39
    My Gmail works fine with me on WiFi at home. No issues either when switching back and forth from 3G. Must be a setting thing, such as what howarmat alluded to in his post...
     
  5. brownricetofu

    brownricetofu Member This Topic's Starter

    Joined:
    May 11, 2010
    Messages:
    5
    Likes Received:
    0
    Hi Matt- thanks for your response- I DO have always on mobile data turned on, so I don't know what is going on. It reminds me of how Skype Mobile dies when I turn WIFI on...
     
  6. howarmat

    howarmat Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    1,580
    Likes Received:
    229
    i dont have any issues with mail coming thru with WIFI or 3G or switching between them. Are you using the gmail app or HTC email app?
     
  7. brownricetofu

    brownricetofu Member This Topic's Starter

    Joined:
    May 11, 2010
    Messages:
    5
    Likes Received:
    0
    I am using the gmail app....
     
  8. phositadc

    phositadc Well-Known Member

    Joined:
    Mar 18, 2010
    Messages:
    200
    Likes Received:
    42
    What is your wifi sleep policy set to?

    menu -> settings -> wireless & networks -> wifi settings -> menu -> advanced -> wifi sleep policy.

    Try setting to "never" and see if that fixes it.
     
    JohnKuczek and brownricetofu like this.
  9. brownricetofu

    brownricetofu Member This Topic's Starter

    Joined:
    May 11, 2010
    Messages:
    5
    Likes Received:
    0
    Thanks man- I think this might have solved it. Just did what you instructed and sent an email to myself and it came through no problem... Do you think this will hurt battery life though?
     
  10. brownricetofu

    brownricetofu Member This Topic's Starter

    Joined:
    May 11, 2010
    Messages:
    5
    Likes Received:
    0
    whoops spoke too soon. i was getting push gmail when wifi was on with this little trick, but when i turned it off and sent myself another message- push never resumed... I have to shut down and restart to get this functionality back... what a drag- this is a bad bug as it makes me never want to use wifi...
     
  11. ncwildcat

    ncwildcat Well-Known Member

    Joined:
    Jun 1, 2010
    Messages:
    87
    Likes Received:
    8
    I have had this issue with WiFi since getting my INC. Don't remember having it on my droid (got my INC in May), but doing lots of research lets me know that this is indeed an unsolved issue. I have my WiFi sleep policy on NEVER, but push does not work on WiFi. It works fine on 3g, but that sucks because our signal strength in the building I work in is not good. Keeping WiFi on helps my battery a lot, as the 3g is not dropping out. I also tried on my home wireless network, same results. I have tried lots of different fixes, none work. This is a big drag. Seems to happen once you turn off the screen.

    Here is an official Google thread detailing the same problem.

    WiFi constantly drops, won't stay connected when in sleep (option to never sleep IS selected) and won't reconnect - Android Help
     

Share This Page

Loading...