Wifi messes with GPS, won't turn off


Last Updated:

  1. IN51P1D

    IN51P1D New Member This Topic's Starter

    Joined:
    Jun 14, 2010
    Messages:
    1
    Likes Received:
    0
    Hi! I've searched high and low for answers, but I can't seem to find anyone who's having the problems I'm having, which concerns me..

    I have a Fresh/Gumbo rooted Hero, but these problems were going on before I rooted my phone and still persist. (The phone is a lot faster, though, so that's nice.)

    Here's the issue: if I set my phone to use Wifi to help determine my location (under Settings > Location), I get an extremely inaccurate result. Like, the phone thinks I'm standing in the middle of a body of water miles away from my actual location.

    That's just problem #1. When I try to turn off Wifi (using a radio button widget or Settings > Wireless Controls), it hangs! It says "Turning off...", but it stays that way forever, the widget is unresponsive, and I can't do anything about it but reboot the phone.

    Quite frankly I'd be happy to just turn off Wifi and never turn it on again. Unfortunately, for whatever reason, Locale insists on turning it back on occasionally to help determine my location -- even though I leave GPS on all the time and it's much more accurate. WTF.

    This is driving me crazy. I feel like if I could resolve this one last issue, then I wouldn't regret getting the Hero instead of a certain other, more mass-appealing smartphone that will remain nameless. Can anyone help?

    Thanks!
     

    Advertisement

Share This Page

Loading...