Wifi not turning off 3g?

Last Updated:

  1. speedfreak32

    speedfreak32 Well-Known Member This Topic's Starter

    Jul 16, 2010
    Likes Received:
    This is strange...

    Last night my wife was trying to update her cached stations on slacker radio and although connected to wifi slacker gave a notification that the data would be downloaded over 3g and an unlimited plan was recomended.

    The strange thing is I had full strength connection to wifi but the 3g icon was still there and and the red and green arrows were showing data transfer over 3g. When connected to wifi on my captivate the 3g icon disappears. A simple power down fixed the problem and wifi was present and no 3g icon in the status bar.

    Any thoughts?

  2. ardyer

    ardyer Well-Known Member

    Jun 12, 2010
    Likes Received:
    I've had the same thing (albeit with different apps) happen a couple of times. I think the system, like any computer, is occasionally getting confused.
  3. MeVirtually

    MeVirtually Active Member

    Jul 19, 2010
    Likes Received:
    I think it has to do with existing connections to 3G. The APN Droid app I downloaded a couple weeks ago (which disables the 3G) warned me when I first used it that it could not stop existing connections to 3G, only prevent new ones, e.g. Apps multitasking in the background that don't or won't switch to Wi-Fi will keep using 3G. Some apps may connect to 3G briefly, I believe I've seen Google's Maps do that infrequently, possibly to determine location?

    Bottom line, your 3G symbol should go away when on Wi-Fi. Or mine does, at least. If it doesn't, try rebooting the phone, and then make sure it has connected to Wi-Fi by showing the symbol when it starts up again (mine didn't show it was on Wi-Fi at boot up once, and the 3G symbol stayed on for a while before I rebooted again to terminate whatever lingering connection had brought it there). I also use the app Timerriffic to turn off the ring volume overnight, and I have it disable 3G on the same schedule, just to be safe, and enable the ring and 3G in the morning (which I think requires that APN Droid be installed).

    I personally haven't used Slacker, so I'm not sure, this is only based on my experience.

Share This Page