Wifi not working when I have mobile networks on (Resolution: replaced device)Support


  1. Chancho1978

    Chancho1978 Member

    I am still kind of new to this whole android thing, but I have been reading and appreciate all the good tips and advice of this site.

    Just the last few days my phone has been doing something strange. When I am at home and try to connect to wifi I get a "unable to scan for networks" popup and it won't connect. When I turn off my mobile network, I have no problem connecting to wifi. This only happens when I try to have both on (wifi and mobile networks). I have had my phone since launch day, and have no problems what-so-ever. I have tried the things recommended by all of you for some other problems( battery pull, restart multiple times, reset to factory settings, update prl, and update my profile) none of which helped. I have not done attempted any root or done anything unusual to my phone. Is this problem normal? Do I maybe have a bad radio? please help. Thanks in advance.

    Advertisement
    :
  2. jerofld

    jerofld Fixing stuff is not easy VIP Member

    That is just really weird and you probably should call Sprint (preferably with a different phone) and see if they can do anything over the phone. If not, you may have to take it in to a store to get it checked out.
    marctronixx likes this.
  3. CarrieK

    CarrieK Well-Known Member

    Please forgive my ignorance. I have a question. I thought that mobile network is 3G (or 4G if you have it) and that you can't have that and wifi on at the same time. You still get calls and texts with mobile network off but for internet access you either have mobile networks or wifi on. I have always done it that way. Is this wrong? Thanks!
  4. EarlyMon

    EarlyMon The PearlyMon Moderator

    You can leave 3G and wifi on at the same time, no problem.

    When it finds a wifi signal, it turn off the 3G radio, and when it loses wifi, it will turn 3G back on. I set mine both on and don't sweat it, but some find it can help battery to turn them on/off individually - that's true, depending on signal coverage area especially and how much you care about data.

    I'd advise against leaving 4G on of the time because it's a battery hog.

    To the OP - I'd really try a pulling out your battery for 60 seconds, then powering back up. That can unstick any confused logic on your phone.
    marctronixx and CarrieK like this.
  5. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Small correction: If you disable "Mobile Networks" it does not disable 4G. Mobile Networks controls 3G and 1X.
    CarrieK and EarlyMon like this.
  6. Chancho1978

    Chancho1978 Member

    So i did the 60 second battery pull, and it worked momentarily (for about 10 mins). The wifi then went off and i tried to reconnect, but I got the same message again.
    EarlyMon likes this.
  7. EarlyMon

    EarlyMon The PearlyMon Moderator

    Have you reset your home router? Sometimes, it's on the router side - I've seen that happen when all the other devices in the house seem normal - so, go figure, it's one of those deals. Please try that.

    If that still doesn't get it, your next bet is to try a factory data reset (under Settings, SD & phone storage (do not format your SD card)) - you will have to reconfigure and restore stuff when it's done, but that will assure that it's software.

    If not - as jerofld said - sounds like hardware, you'll have to take it in (where they're liable to factory reset it anyway as their first step to be sure - hence my advice above).
  8. Chancho1978

    Chancho1978 Member

    just a follow up from my original post. i finally got around to taking it in to the sprint store to get it checked out. they played around with it for an hour, but could not figure out why it was doing that. in the end they are sending me a new phone. all is fair in love.....and these darn mechanical devices.
    jerofld and marctronixx like this.
Loading...

Share This Page