WiFi Problem - But this one is different.General


Last Updated:

  1. OCTAN30L1V3R1

    OCTAN30L1V3R1 New Member

    Hey guys,

    Well, here's my problem. Ever since I had my Galaxy S3, I've had problems with it. Which is extremely disappointing considering I waited 6 months after my upgrade to upgrade to the thing :eek:.

    My main problem with it though, is insanely aggravating. What happens is when I try to connect to my internet connection in my house, for some bizarre reason, it thinks I have no security on my Hub!

    I'll tell you exactly the series of events; I go onto my phone settings, and see my router on there. I click on it, then click 'Connect', at the top of the page, it has the loading icon and it says Connecting, but then after about a couple of seconds, it just goes back to 'Scanning'!

    I've gone into my router settings and tried to make sure the IPs are all correct, I've tried adding the network manually, but all of it hasn't worked. About one in 40 times of trying to connect to my WiFi, does it come up with the correct SSID with the Password and everything, and it connects, but when it does actually connect, the internet connection is extremely slow and it drops out after about a minute or so, as the device suddenly decides to connect to the BT Open Zone in the next door neighbour's house!

    This problem is extremely irritating, as it renders this device almost useless for watching YouTube and surfing the web etc. at my home, due to the fact that I only have a 500MB data limit, and that will be gone in no time if I start watching YouTube videos.

    Please guys tell me anything you know that might help.

    Many thanks,

    Octan3.

    P.S. I have tried going into *#0011# and turning off the WiFi power saving mode.

    My router: BTHub3 (It is a very new one due to my old hub having connection issues)

    Also, it is not the Router itself, as there are about 7 devices on it, one being what I'm writing this on right now.

    Advertisement
  2. jerofld

    jerofld Fixing stuff is not easy VIP Member

    While it may not be the router's fault, as it has many devices connected to it, try changing the channel. That has fixed SSID errors in the past with the GS3. It's odd, but it has helped a few out.
    OCTAN30L1V3R1 likes this.
  3. OCTAN30L1V3R1

    OCTAN30L1V3R1 New Member

    Thank you for your very quick reply! Sorry to ask, but how do I change the channel?
  4. justaneonlol

    justaneonlol Well-Known Member

    It's in the router internals when you log into it. It's the broadcast channel. There are 11, so try some different ones.
  5. OCTAN30L1V3R1

    OCTAN30L1V3R1 New Member

    If I change my router channel, does that mean that all devices on the network must reconnect to it?
  6. Ches111

    Ches111 Well-Known Member

    You may also want to forget that connection within Wifi settings. Go into settings->Wifi

    Then long press your home network SSID (Name of your home network) then sekect "Forget Network"

    Then connect to your network again and enter your security info.
  7. Musky

    Musky Well-Known Member

    You may need to reboot each device on the network after changing the channel, but they will still connect automatically if they are set up that way. No biggie!
  8. fx7

    fx7 New Member

    Before you change the wifi channel, you may want to go into the App wifi analyzer to see what channels your neighbors are using. this solved the problem for me. also, the app works for me even when I wasn't connected to wifi. and if you're not using the same wifi channel as your neighbor, then you'll also get better connection speed. I'm not thrilled with the solution, as all my other wifi devices connect without any kind of adjustments.

Share This Page