wifi problem: fail to obtain IP addressSupport


Last Updated:

  1. toto

    toto Member This Topic's Starter

    Joined:
    Oct 7, 2010
    Messages:
    6
    Likes Received:
    0
    Hi, I am new to Android and this forum.
    I hope someone could advise me on my wifi issue with X10 mini pro.

    It has been about 1 month since I started to use X10 mini pro, and it worked so far so good including the wifi connection at home and other free wifi spots.
    Since yesterday, this X10 mini pro has been failing to obtain Ip address.
    It tries to obtain an IP address, but after a while, it says "unsuccessful".

    Wifi network scanning looks fine, coz it detect a lot of wifi connections around my house.

    Anyone has advice? Thank you very much!
     

    Advertisement
  2. Roxoff

    Roxoff Member

    Joined:
    Aug 10, 2010
    Messages:
    23
    Likes Received:
    2
    It used to connect to your home wifi but now doesn't? It's probably more likely to be a problem with the wifi than with your phone. Can you connect to other wireless networks?

    Is your wifi router unsecured? Has someone logged onto it and changed any of your settings? Could you have done this accidentally?

    Log on to your router and check that your DHCP service is turned on and that your phone is allowed to connect through any of the security settings you've applied.
     
    toto likes this.
  3. toto

    toto Member This Topic's Starter

    Joined:
    Oct 7, 2010
    Messages:
    6
    Likes Received:
    0
    Thank you for the advice, Roxoff.
    My husband restarted our home router finally. Usually he uses the wireless LAN 24h continually for his job. So I couldn't have chance to restart it even while we are sleeping.

    Then, right after restarting the router, my X10 mini pro could obtain an IP address. The signal indicator was on the screen and the browser/gmail worked fine.

    But still sometimes it can't obtain IP address often.
    I guess the problem is on the router side, as you suggested.
    I will keep watching the status.

    Unfortunately, I don't have chance to get connected to other wifi since then. I should have a test, too.

    Thank you very much.
     
  4. sathy

    sathy New Member

    Joined:
    Nov 11, 2010
    Messages:
    2
    Likes Received:
    0
    Hi..

    Sometimes it happens that Wifi router automatically resets all of its settings. I had faced this issue with the router provided by my ISP.

    You can try connecting with free hot spots and check for stability.
    :cool:

    Thanks.
     
  5. sniperdude

    sniperdude Well-Known Member

    Joined:
    Oct 14, 2010
    Messages:
    48
    Likes Received:
    1
    my x10 mini pro had a problem obtaining IP when i was using the following encryption

    WPA +TKIP

    I changed the router to also include AES so having the following


    WPA + TKIP + AES works for me


    if your router don't support using both TKIP and AES at the same time just use AES
     
  6. whitebloodcell

    whitebloodcell New Member

    Joined:
    Nov 8, 2010
    Messages:
    4
    Likes Received:
    0
    I have this issue as well, renewing the leases on DHCP assigned IP addresses from the router fixes it. For whatever reason once all the addresses from 192.168.1.2 - 192.168.1.9 have been assigned during a period of uninterrupted uptime of the router, android can't connect. Reset and allow the router to assign a single digit IP address and everything works.
     
  7. Roxoff

    Roxoff Member

    Joined:
    Aug 10, 2010
    Messages:
    23
    Likes Received:
    2
    This doesn't make any sense. If the IP address were stored as some kind of text string, then you may have a point, but really IP addresses are stored as a string of binary digits, usually represented as an octet/byte of 8 bits. A single digit would be either 1 or 0, or it'd be 1-16.

    Are you sure something else isn't going on here, and it just looks a bit like what you describe?

    My DHCP server at home never hands out IP addresses in the range you're describing, it's configured to use 192.168.250.200 down to 192.168.250.100 and my x10mp connects to that correctly. I don't use it for long periods, though, and I have noted on occasions that the wireless connection can go down and take some time to recover. I've never really monitored it because if I have to do something that requires use of my wireless LAN, I'll use my netbook.

    It's more likely that your router is bouncing further connections because its resources are tied up maintaining and expecting use of the earlier connections that are effectively 'live', even though they've all been replaced with a new connection.

    There is something you could try here, if you're comfortable with editing your router configuration. The built-in DHCP service on your router should allow you to make 'static' assignments - that is an IP address that is always handed out to the same MAC address, which is the ID number burned into your networking hardware (your phone has one of these). You could try configuring a static IP assignment for your x10mp - that way the DHCP server will always try to give your phone the same IP address when it connects - which should preserve resources on both your phone and (most importantly) your router.

    You can find your phone's MAC address in Settings->About Phone->Status, it's about 3rd from the bottom.
     
  8. whitebloodcell

    whitebloodcell New Member

    Joined:
    Nov 8, 2010
    Messages:
    4
    Likes Received:
    0
    Logically my answer doesn't make sense as you say, it is just what I have observed and is likely a coincidence. I am actually on a Galaxy S but since operating system was the same I didn't see any harm with chiming in. I set up the router to assign the same IP address each time now and it seems to be working out.
     

Share This Page

Loading...