1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

WiFi Problem Galaxy SSupport


  1. Crackity Jones

    Crackity Jones New Member

    Hi there.

    I have a recurring problem connecting my Galaxy S to my home WiFi.

    It was working fine until a week ago. Then it tried to connect. It could see my WiFi and said the signal was strong but when I tried to connect it came up with the obtaining IP address message. After a while it just stopped and I'm left with the message 'Disabled, Secured with WPA/WPA2 PSK'

    I tried a factory reset which seemed to solve the problem but was a pain because I lose all my settings and apps.

    Now after a week of working fine, I have the same problem all over again. Do I really have to do a factory reset every time?

    I've tried forgetting the address and refinding it. But only the reset seems to work, for a while.....

    Advertisement
  2. Sdi1000

    Sdi1000 Member

    I have the very same problem with mine, and as i can see on the internet, it is lots of us with this problem. I have done a factory reset twice, and it have been working fine on wifi for a week and now it wont connect again. It is obtaining IP, and then says my network is disabled. I have tried to change my router security from wep to WPA/WPA2 PSK, tried reseting router and change channel, nothing works and all 3 laptops at home work just fine on the wifi. This started after updating to froyo 2.2, and i
  3. Padzer

    Padzer New Member

    Hi All,

    I too have problems with my home WiFi but, before reading this, was blaming it on my home Wifi Router.
    Out of curiosity, what is the make and model of your home WiFi routers?
    Mine is a Belkin G+ MIMO (F5D9230uk4 Version: v3000)

    Thanks..P
  4. lathiwala_99

    lathiwala_99 Member

    hi there....froyo has this problem with dynamic IP addresses...so please change ur settings and put ur ip address, dns, default gateway and netmask manually...the problem would be solved..i was facing the same problem and this solution worked perfectly for me...
    ksaichandra likes this.
  5. Padzer

    Padzer New Member

    Hi All, I went out and bought a new WiFi router yesterday. Froyo is now happy to connect and stay connected using dynamic set up. As far as I'm concerned the problem lay with the old WiFi router I was using.
  6. Sdi1000

    Sdi1000 Member

    Hope you are just as happy in a week or two.. :rolleyes: What router btw ?
  7. Sdi1000

    Sdi1000 Member

    Belkin Wireless G Router 2.4 GHZ (F5D7230-4 Version: 6000ea)
  8. Padzer

    Padzer New Member

    Hi,

    I bought a Edimax BR-6226N Wireless nLite Router (150Mbps).
    Why do you think it will stop working in a few weeks?
    Spent a few hours surfing and stuff yesterday evening and not a blip.
    From what I'm hearing Belkin network products do have a bit of a (not so good) reputation....
  9. princetonbc

    princetonbc Active Member


    how do you do that?
  10. Sdi1000

    Sdi1000 Member

    I dont know, i did a 3 button reset 2-3 days ago. (reset nr 3 by btw) Wifi was working good again. Had wifi on when i got to bed last night. Battery was at 90%. When i woke up today, phone had turned it self of with a completly drained battery !!????? So i hooked up the charger and was back to not able to connect to wifi. Obtaining IP adress....disabled !! FFS !!!! :mad::mad:
  11. Nperkal

    Nperkal New Member

    There is a simple solution for the wifi problem that Zaba22 has found! Go to the Allshare App on the Galaxy S and connect to wifi thru there! For some reason it's a stronger App and it works!! I couldn't believe it! Try yourself and post your experience. Hope this helps everyone. I was overjoyed when I read it and now I'm passing it on!
    vastidlg and Joe in OKC like this.
  12. gmbakes

    gmbakes New Member

    Thank you thank you thank you!

    AJAY1235 and ImplyDods like this.
  13. blessonje

    blessonje New Member

    I am also having the very same probs after the froyo update..Have to reset my phone once every day..its really irritating ::mad:(
  14. jbcosta

    jbcosta New Member

    I have the same problem. The Allshare solve it. I recommend!
    At home connect with Allshare :)
  15. ImplyDods

    ImplyDods New Member

    Allshare solution works like a dream.. Thank you
  16. mrbonelly

    mrbonelly Active Member

    Hello everyone!
    I have this issue as well, but am aware that this is an issue with my Linksys WiFi router(about 1yr old) from previous experience with my xbox 360 wifi hook up. My xbox kept getting dropped/disconnected and was told it was the security settings on the router. It does the same thing with my Vibrant. Same strong reception/acknowledgement but can't really connect as the OP. I have to restart the phone.

    I'll try Allshare when i get home tonight and see how it works.
  17. Catfish

    Catfish Well-Known Member

    I've had this problem since day one, I knew it was the phone because nothing else on my network _ever_ fails to connect to my router.

    my router is a billion bipac 7402 vgo.

    I'm trying to get a netgear wgt634u with openwrt going on my network to see if that works better but I'll try this all share trick too and see if that helps.
  18. prashant:@

    prashant:@ New Member

    i dont hav allshare in LG optimus ! what do i do ! i dont have Gprs facility on my phone and want to sort this WiFi thing out first before starting working on Gprs. as i will not bother myself to again look fr a solution when i hav an alternative ! i have the wifi symbol in the upper right hand corner of my screen -AND- in my settings/wifi and networks it shows connected to ...."your network name"). but browser doesnt open anything from the first day ! android 2.1. PLZ HELP !
  19. ksaichandra

    ksaichandra New Member

    I had the exact problem as that of yours. I upgraded by galaxy S from eclair (2.1) to Froyo (2.2). My Wifi was never connecting and even though it did, it was not recieving any data from the web. This may be the case for many others too. If you/ users with same prob haven't yet gotten through with this, then there is a simple solution. Follow these steps:
    1.Apps>Settings>Wireless and network>Wi-Fi settings
    2. Press the menu key on that page (left most bottom hap key)>advanced
    3. Select Static IP
    4. Now enter the IP address, gateway, Netmask, DNS1 and DNS 2. You can find these numbers on your computer by typing cmd (dos command prompt) in the Run and then check youre IP settings. Type ipconfig in the cmd prompt. It will tell you the exact IP address. Make sure the last digit in the IP address is different from that of your PC. Else it will result in a conflict. Typically, the Static IP data on your Galaxy S will have to be like IP Address: 192.168.3.8 (the last digit will be taht of your PC/ devices that you are using. It has to be diff for your smartphone)
    Gateway: 192.168.3.1
    Netmask: 255.255.255.0
    DNS1: 192.168.3.1
    DNS2: 192.168.3.2

    Try!! Good luck!
    It worked for me though...!
  20. Fi_Stanley

    Fi_Stanley New Member

    Hi there,

    I hae had my Samsung galaxy s for 6 months and use my wifi to connect to my internet, my partners and my parents without any problem until 2 days ago. when i had to re connect to it and it did then in disconnected on it own. i today hae switched wifi back on and none of my remembered networks are coming up, infact none at all. a message keeps popping up saying unable to scan for networks say's that twice then automatically switches wifi off.
    Seems like a similar problem to you.
    I will be going into car phone warehouse at weekend to speak to them. if then can help i will get back to you if they come up witha solution.

    regards

    fi
  21. ashokeseth

    ashokeseth New Member


    thanks. this worked for me. but one has to input ALL the fields mentioned.
  22. varunperumal

    varunperumal Member

    Hi all,

    I have just got my galaxy s 2 yesterday (i live in india). It is an awesome phone but i am having issues with the wifi siliar to the ones mentioned on these threads .

    http://androidforums.com/samsung-galaxy-s/231194-wifi-problem-galaxy-s.html

    http://androidforums.com/samsung-galaxy-s/231194-wifi-problem-galaxy-s.html

    Initially it said "Obtaining ip address..." and it never connected. After thati have gone through the formus and tried out suggestion like connecting through all share and using static ip settings.

    With the static ip settings the device got connected. But the browser or any internet app does not work.

    Here are the settings i have used (same as those on my laptop, except ip) :( :(
    ip:192.168.0.11
    gateway:192.168.0.1
    netmask:255.255.255.0
    dns1:192.168.0.1
    dns2:192.168.1.1

    The router i use is d link wi-524 wireless g router.

    PLease help, i am going crazy.....

    Thanks in advance,

    -cpv
  23. NightAngel79

    NightAngel79 Bounty Hunter Administrator Moderator

    moving to linked galaxy S thread ;)
  24. anoyss

    anoyss New Member

    hello every body,
    I had the same anoying problem, and thanks God i have found a solution.
    Its very simple, just make sure that your hex password is in capital letters(if you are using one: i am using WEP) and it will work for you.

Share This Page