wifi problem on my xperia x8Support


  1. idfinder

    idfinder Member

    Hello i have a big problem .. three days ago i changed my wifi password so i was the only one to know ... after that i managed to connect all my devices ( 2 pc, ipod touch, ps3) on the internet, but ever since whenever i try to connect my xperia x8 router (siemens) turns off and restarts. why is this happening? before password change everything was ok i could connect with any difficulties

    Ps my first post hello

    Advertisement
    :
  2. idfinder

    idfinder Member

    anyone?????
  3. rosaplektrum

    rosaplektrum New Member

    i dont have the answer on your question. but i can tell you that i have the same problem.
    i updated to 2.1 today and when i connect to my wifi connection i get connected. but after 2 minutes i get disconnected. then it connects again. then it disconnects again. and it does this all the time. I ****ING HATE THIS.
  4. coman_nick

    coman_nick Well-Known Member

    I read on a forum that some guys in russia just changed the channel of the router (1-10), and some other guy changed the wifi network name. They both had similar problems. I myself had a problem with the wifi but just reentered the setting for wifi in my phone and it worked.
  5. Charmed

    Charmed Well-Known Member

    I'm having problem with the wifi too. Icon is there, but connection is lost. I have to refresh the page multiple times before wifi starts to work again. I configured my wifi setting to never...It's making me mad because I didn't have this problem on 1.6...
  6. mps83

    mps83 Well-Known Member

    same problem here since upgrading to 2.1, wifi is enabled but not connected sometimes, strange
  7. Charmed

    Charmed Well-Known Member

    I hope that there will soon release some kind of update or fix for this bug...
  8. tomukas27

    tomukas27 Member

    I have mentioned some wifi conectivity problems, sometimed it doesn't want to conect, problem appeared after 2.1 update
  9. grinchul

    grinchul New Member

    I had almost the same problem, except i haven't changed the password or something else on my wireless network. My X8 couldn't see the wireless network with both versions 1.6 and 2.1. So after I've updated to 2.1 i changed the wireless network channel from 12, how it was in the first time, to any channel from 1 to 9 and it works great on all those channels. Also I've changed the name of the network in something simpler, the old name had a lot of alphanumerical characters and the channel I've let it between 10 and 13 and ... it didn't work; so i putted back the old name (xXX-XXx_xx xX, something like this) and changed the channel form 1-9 and ... it works :D
    So i think in this case the problem seems to be the length of the channel, it has to have only 1 digit. Hope it helps.
  10. mihait85

    mihait85 New Member

    Hi all

    I cannot connect to the home wifi on my x8. It connects to the network, but the browser does not open any page. Just like it wasn't connected to any network. The wifi is ok, because it works on my laptop, and also on another phone (nokia e63), and also it is opened (no password).
    I have to say that i just updated to android 2.1 using sony-ericsson's PC Companion

    Any suggestions?

    Thx
  11. coman_nick

    coman_nick Well-Known Member

    Mihai, first try another wifi, then a different browser. If still nothing, take it to service.
  12. vickykoy

    vickykoy New Member

    it simple ..i think u may just need to delete the wireless profiles from phone and reconnect again will do
  13. shelly1

    shelly1 New Member

    Hi there, I'm experiencing the same issue: After updating to the (official) Android 2.1, my home WiFi is connected and remains connected (WiFi icon in the status bar still on), but the network is no more accessible after ~1 minute. The network access is restored after disconnecting and reconnecting.
    At first, some replies:
    - Some have mentioned that they have made some changes to the router settings. I did not.
    - Switching the router channel to any 1-digit channel: My router uses channel 6, so that doesn't help.
    - Deleting the connection settings did not help, even with 3rd party application.

    But finally, I've found a little workaround. The device seems to no longer support AES encryption after the update. When I set TKIP encryption (with WPA-Personal or WPA-Auto-Personal) on my router, the network connection on the device works fine and stable. Not really glad about this fix, because WPA TKIP is weaker than WPA2 AES, but at least, it works. (WPA-Auto-Personal with TKIP+AES encryption is not working too. It seems that both encryption methods have to be supported, not that each device in the network "chooses what it is capable of", as I thought.)
  14. lukmannet

    lukmannet New Member

    I've googled through the same issue, still can't find the solution. SO, I tried myself by reconfiguring hotspot settings and managed to connect satisfactorily.
    Try this:
    Enter your hotspot settings wizard and check/tick the "AP" setting, that's all.;)
  15. racingnerd

    racingnerd New Member

    may i know how to set that hotspot setting? cannot find it in the phone?
  16. gabeyong

    gabeyong Well-Known Member

    Hi,

    I had the same problems with my router.
    I had to check each setting to configure my MacBook Pro, Dell Inspiron, IBM R61, iPhone 3G, Iphone 4, Xperia X8, HTC Incredible and Archos 10.1 [:( pain in the neck]

    Xperia X8 Specs as follows:

    Wifi - 802.11g is prioritized over 802.11b [newer routers are 802.11n but are backward compatible - its will scans for 802.11b/g device hookups so dropped signals occur]
    You have to set b/g compatibility mode [do not set to auto or n only mode]

    Security - Open, Open WEP, Shared WEP & WPA Personal [new routers have compatibility to Open, Open WEP, Shared WEP & WPA Personal, WPA2 Personal, WEP2, WEPplus and Dynamic WEP - do not set to WPA2 Personal/WEP2/WEPplus/Dynamic WEP or your Xperia X8 will not be able to "see & hookup" to your wifi router]

    Encryption - TKIP and AES [TKIP is a 128-bit per-packet key - 128-bit = WEP protocol not WEP2]

    Channel: any channel between 1-10 [newer routers have up to 16 channels and change channels when they reset or when the router is set on auto and scan for interference (newer routers have channel set on auto)

    Just an update regarding router channels: 18 March 2011

    You can use Wifi Analyzer to check which channels overlap and therefore are causing interference to your wifi connection. For example if channel 6 is the most common in your area then there will be a lot of overlaps. You may want to change a less "busy" channel.

    Check it out: Wifi Analyzer v2.5.6 <-- here

    <install><launch> check your channel, overlaps & interference
    <change> your router channel to one that has less interference (overlaps).

    cheers!
  17. puyuh89

    puyuh89 New Member

    my xperia x8 not working please help me..
  18. johnboy58

    johnboy58 New Member

    i connect to wifi and the internet on my xperia x8, goes downhill from there ! very annoying i have browsed the net 2 weeks straight trying to sort the problem then took my xperia back to carphon warehous swapped it for a brand new one ive got the exact same problem! disconnect reconnect disconnect reconnect disconnect reconnect disconnect reconnect disconnect reconnect disconnect reconnect disconnect reconnect disconnect reconnect disconnect reconnect disconnect reconnect
  19. Dexter_prog

    Dexter_prog Member

    has anyone been able to solve this? I'm not sure if this a problem with the phone or with the router config. My router has the option to autosearch for the best (and most free) channel, so that is not a problem
  20. shelly1

    shelly1 New Member

    @Dexter_prog Yes - I upgraded to Android 2.3.5 (GingerDX) from xda-dev and everything works fine now. Finally I could return to WPA2+AES in my router config :)
  21. suchuaato

    suchuaato New Member

    turn your wifi off, let it establish a 3g connection
    then either use via 3g or turn wifi back on again
  22. RPM

    RPM Member

    I installed a new ROM today because I had wi-fi problem too (was stack on 'connecting'). With new ROM still nothing changed until I did factory reset from x recovery. It's a pain, i hate it but it solved my problem...for now at least.
    So whoever hasn't tried that, I suggest you do.
  23. Scue

    Scue Member

    [&#27491;&#35299;]&#36825;&#20010;&#27809;&#26377;&#20160;&#20040;&#65292;&#20320;&#25226;&#32593;&#32476;&#20462;&#25913;&#25104;WPA&#23601;&#21487;&#20197;&#20102;&#65292;&#20320;&#21487;&#20197;&#32771;&#34385;&#20351;&#29992;Connectify3.0:D
  24. yonglipkent

    yonglipkent New Member

    Hi Guys ,Xperia X8 User here and First Time use Android Forum .... i have problem also .....

    When i open my WiFi , he didnt show out any line that i can Connect it .....
    i tot was my modem problem , i have alot time restart phone and still cant search any line....

    my other phone ( also under android ) Easily connect WiFi ,so that i noe is my phone have problem already ... any1 can help me pls .... T-T
  25. massao

    massao New Member

    I had a little different problem, but may be my solution can help you as well. My phone could no longer detect the WIFI connections automatically, and tried to enter the WIFI connection information manually, it still would not work. I installed the software from the sony erikcon website to my computer, and then followed the process for updating the phone software. That did not work, since I had the latest software already. So then, I tried to REPAIR my phone software, and after that was done, my phone was functional again, and the wifi works without any problems.
    Requirements:
    * A PC connected to the Internet (preferably broadband)
    * USB phone-to-PC connection. Please see the accessories compatibility list for your phone.

    1. Here is the website to download the Update Service software fromhttp://www.sonyericsson.com/cws/support/softwaredownloads/detailed/updateservice?cc=au&lc=en
    and install it on your PC.

    2. Run the software on the computer after it is installed.
    3. Follow the procedure for UPDATE or REPAIR (if you already have the latest version).
Loading...

Share This Page