wifi problems in defySupport


Last Updated:

  1. adard

    adard New Member

    hey, i searched the forum a bit but didn't find anything similar:
    i have a 2.1 version (i think), and lately it started acting wierd (i havent done anything i can recall to change the settings etc.):
    my wifi is working properly, apparentley, but when i try to connect to certain networks it just refuses to connect. it happens in both secured and non secured networks.
    example: when i go to the network manager and ask for a password, i can enter it but nothing happens(more specificaly, the "connect" button remains grey and un responsive). other phones\ laptops in the area are connected with the password without any problem.
    non secured networks, i click connect, but the connection fails everytime.
    this apllies also for networks that i could connect to in the past.
    other networks can be connected as always.


    please help!

    Advertisement
  2. scrannel

    scrannel Well-Known Member

    What market are you in? Is this a t-mo branded phone with wifi-calling? Go into "About phone" and see if you are on 2.1 or 2.2. Generally speaking...

    You can try clearing the wifi list in Manage network options.

    You can clear the system cache.

    You can go a factory reset. (But if you are using 2.2 the reset listed on the phone is not the correct procedure for 2.2). Remember this will return your phone to "as new" state wiping out all your apps and info.

    Most info on how to do these things can be found here:

    T-Mobile Support Community: Topic: Motorola DEFY with MOTOBLUR


    IF you do have wifi-calling there are a couple of additional things to try. Let us know.
    adard likes this.
  3. adard

    adard New Member

    I have a 2.2. silly me!

    I clear the wifi list all the time.

    My phone dosn't have wifi calling as far as i know. anyway, its impossible to do it on a network i can't connect to in the first place* (is it? i never tried it before).

    I prefer not reset my phone, if there are other options i rather try them first. i'll try it eventually i suppose...

    The problem might be limited to networks secured with WPA/WPA 2 or WEP. when i tap "add wifi network" and choose this types of security, i have the same problem, which is weird since my phone never had problems with this kinds of networks before.

    *pardon my ignorance
  4. scrannel

    scrannel Well-Known Member

    If your phone is not a t-mo branded USA phone you probably do not have wifi-calling. If you do have wifi-calling it can mess with wifi connections whether you are trying to use it or not. Where are you? (if you DO have a US phone there is something else we can check).

    So you CAN connect to some networks?

    You might try clearing the system cache. (check the t-mo link above on how to do this). It will not wipe out your apps and data.
  5. HalfAnAndroid

    HalfAnAndroid Well-Known Member


    Flash an sbf. This happened to me once. I think it is a driver problem.
  6. Styrisvps

    Styrisvps Well-Known Member

    Dame problem with my Defy. I've solved changing mi router ti wifi g only
  7. scrannel

    scrannel Well-Known Member

    Have seen this as a solution. Mine works fine on 'N', so it may vary router to router.

Share This Page