WiFi problems on my Desire


Last Updated: 2010-09-11 20:51:49
  1. haddock

    haddock Well-Known Member

    Hi all.

    Hope someone can help with this one.

    When I am at home and want to connect to the net using wifi, my Desire connects to the network immediately and has excellent reception. But it can't go online with ANY of my programs, whether to check mail, download updates on the market or just surf. None of the other devices I use at home have any trouble getting online, so it isn't my router or connection (I think).

    And when I got to my office today, my phone instantly recognized the network here and can go online with no problems.

    I have had the phone for about two months now, and this problem is only a few days old. Before that I had no issues with this.

    Hope someone out here on the interweb has the solution for this!

    Thanks,

    Carsten

    Advertisement
  2. kilroy

    kilroy Well-Known Member

    I'd check the router to make sure it isn't set to MAC filtering. I'd try deleting the home connection and re-entering it from scratch to see if that helps.
    haddock likes this.
  3. haddock

    haddock Well-Known Member

    Hi Kilroy,

    The router is set to MAC filtering, but my phones MAC address is entered, which I double checked yesterday. And like I said, the phone is connected, there's just no access to the internet. But when I get home later today I'll try deleting and re-entering as you suggested.

    Thanks! Hope that does it...
  4. adrayton

    adrayton Well-Known Member

  5. Kryten2k35

    Kryten2k35 Well-Known Member

    Are you with Orange UK? They restrict WiFi on their ROM.
  6. haddock

    haddock Well-Known Member

  7. haddock

    haddock Well-Known Member

    No, I'm with Telia in Denmark, and even if they had restricted wifi, that would mean that I wouldn't have been able to connect for the first two months to my home network, and still can connect to all other wireless networks that I have tried, at least I would think.
    Frustrating!
  8. Kryten2k35

    Kryten2k35 Well-Known Member

    Ahhh, yes that's very true.
  9. nacatomi

    nacatomi Well-Known Member

    Just a suggestion.... Have you tried going into settings --> Wireless & Networks --> WiFi Settings. Then long pressing on your problem network and choosing to forget it. Then you could try joining again from the start. Had to do that a time or 2 on my TouchHD
  10. DCFC79

    DCFC79 Well-Known Member

    maybe its a silly question but what do you mean by this
    nerdofprey likes this.
  11. haddock

    haddock Well-Known Member

    Nope. Haven't tried that yet, but will do when I get home. I'll update if it works.
  12. johnintheuk

    johnintheuk New Member

    Sounds like the problem I have with my home network (it effects both my Desire and iPod Touch). For some odd reason, the router doesn't assign an IP address but if I connect using a static IP then I can get online no problem.

    If you do need to setup a static connection, I'd highly recommend installing Wifi Static on your Desire, that way you don't have to keep switching between static and dynamic when moving between networks at home and work for example.
  13. nacatomi

    nacatomi Well-Known Member

    That sounds like a DHCP problem on your router. If its your own router (i.e. not locked down by an ISP) You should log into the web management interface and check your DHCP server settings. Some either don't have it switched on by default or some only allow a set number to connect via DHCP and you will have staring and ending addresses like 192.168.0.10 - 192.168.0.15 allowing 6 devices to be assigned an IP by the router. Any on top of the 6 currently connected would be unable to get an IP.
  14. haddock

    haddock Well-Known Member

    Well, I have tried a few things now:

    I made the phone forget my home network, then reinstalled. It worked for a few minutes, then back to the same.

    I installed WiFiStatic, no help.

    I restarted my router (simple restart - power off/power on)

    I tried allowing DHCP on my router with up to 50 connections, no help.

    My final attempt was to yell at the phone in a very determined and strict voice. No help.

    I tested the phone on two different preferred networks today, and there were no problems whatsoever.

    Any more ideas?
  15. nacatomi

    nacatomi Well-Known Member

    :D Made me laugh!!!

    restart\battery pull??
  16. haddock

    haddock Well-Known Member

    Did that, no help. Am currently on hold with HTC support, and they seem as clueless as me. She's trying to blame it on my Linksys router, and said that they have had quite a few problems with compatability with Linksys. But why the heck would it have worked for two months?

    Update: Just got done with the girl from HTC, and she had no solution. Excellent.
  17. nacatomi

    nacatomi Well-Known Member

    I'm out of ideas then sorry. I use netgear routers both at home and in the office and haven't had any problems at all really.
  18. haddock

    haddock Well-Known Member

    New update, in case anyone else out there has the same issue...

    I can now go online at home again (relief!), but only after I changed WiFi settings to use static IP AND changed my routers DHCP settings to ON and to include IP addresses in my range.

    What effect this will have on my phone when I try to log on other places I will have to wait and see.

    I also tried to do this with WiFi Static, but that didn't work, so I had to do it manually in WiFi Settings.

    Hope this is the end of this!
  19. nacatomi

    nacatomi Well-Known Member

    I thought it would be something similar. Good to hear you got it sorted
  20. haddock

    haddock Well-Known Member

    Now I'm back to square one, where even a static IP doesn't help:mad:

    Anyone else on here have problems going online with a Linksys router?
  21. nx1977

    nx1977 Well-Known Member

    Install WiFi analyzer and you'll almost certainly find channel congestion
  22. haddock

    haddock Well-Known Member

    Back to working again with WiFi Static after changing DNS 1 and 2 to DNS1: 208.67.222.222 DNS2: 208.67.220.220.

    I have no idea how or why this works, but it does.
  23. jred7469

    jred7469 Well-Known Member

    If it stops again why not try hard resetting the router and starting again? you said you turned it off and on but did you stick a pen in the reset button so the router factory resets? Might be worth a try if you haven't already
  24. RedBob62

    RedBob62 Well-Known Member

    Don't no if this will help but I will throw it in to the pot anyway. I was having real problems last week with getting streaming to work on my desire via Wifi (router is Dratek 2600). Eventually tried the nuclear option from a security point of view which was to set up my phone in a DMZ. Since then have had no problems with wifi or streaming.

    Send my regards to Denmark by the way, I used to live in Ballerup outside Kobenhavn.
  25. haddock

    haddock Well-Known Member

    Yeah, that's my next option. I hope it won't come to that though. So far it's still working, so my fingers are crossed.

Share This Page