wifi randomly switches onSupport


Last Updated:

  1. edsol

    edsol Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    6
    Likes Received:
    0
    i know this has been asked but so far i haven't found any satisfactory answer or solution. i have been having a battery drain simply because my wifi would just turn on by itself for no apparent reason. There is definitely something causing this but it seems nobody has any good explanation.

    Well this time, i'm hoping that somebody can. Thanks
     

    Advertisement
  2. cleanermonkey

    cleanermonkey Well-Known Member

    Joined:
    Aug 21, 2010
    Messages:
    70
    Likes Received:
    12
    Hey Edsol
    Have you by any chance installed an app that manages your WIFI? It might be that your wifi logs on to (or tries to) known networks (my old n900 did that out-of-the-box but I'm not sure SGS can do that)
     
  3. jollygoon

    jollygoon Well-Known Member

    Joined:
    Aug 10, 2010
    Messages:
    69
    Likes Received:
    17
    AFAIK the galaxy s always searches for a better signal if you're using data. For example if you're on the browser and the phone senses that your connection isn't as strong as it could be it automatically turns on the wifi to search and log onto known networks (maybe unknown networks as well?). I guess it also works the other way around, i.e. if your wifi connection isn't great it'll check to see if your 3G or HSDPA service is better.

    I've been looking into this as well but it seems as though it's one of those things that a 'smartphone' is supposed to help you with.

    I have been playing around with tasker trying to find a way to make the wifi turn on only when I want it to but as yet no luck.:confused:
     
  4. stylelite

    stylelite Well-Known Member

    Joined:
    Apr 29, 2010
    Messages:
    191
    Likes Received:
    33
    I to had this problem, and spoke to Samsung about it, they told me the WiFi shouldn't be just randomly turning itself on and there was a fault with the handset, and to return it to them for a service repair which I was going to do until I managed to connect the phone to kies and it offered an update to JM1, so I thought I would do the update and see what happened.
    Since the update WiFi has NOT randomly turned itself on so all good at the moment
     
  5. edsol

    edsol Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    6
    Likes Received:
    0
    so updating to JM1 solves the wifi issue? i was able to find a temporary solution to this and that is, i went to settings and to location and security and then i unchecked the "use wireless networks" to disallow google's location service to use wifi.

    So far i don't have the wifi randomly turning itself on but at the same time my phone also can't use the location service... well, at least this will not drain my battery.

    I will try to update my phone also to JM1
     
  6. stylelite

    stylelite Well-Known Member

    Joined:
    Apr 29, 2010
    Messages:
    191
    Likes Received:
    33
    Before you do the update check to see what firmware the phone is on and also make sure your using the latest version of kies, this is important.
    The update is not so straight forward so if you do decide to do it PM me and I will try and help you.

    Check the posts in the link below, you will see some people have had problems with the update but is possible to do it.
    http://androidforums.com/samsung-galaxy-s/150891-help-cannot-update-firmware-via-kies.html
     

Share This Page

Loading...