WiFi sleeps when device is locked!Support


Last Updated:

  1. resplendent2209

    resplendent2209 New Member This Topic's Starter

    Joined:
    Jun 7, 2010
    Messages:
    4
    Likes Received:
    0
    As the title says,


    I want you guys to test the new email notifications when the device is connected through WiFi.

    For this you've to set the WiFi sleep policy to never and the Background and Auto sync option needs to be checked.

    Well, I don't get any notifications. I went an extra mile ahead and pinged the IP address and found that I get "request timed out" error when device is locked and when it is unlocked, the packets are received properly.

    Waiting for you guys response.

    Thanks and Regards,
    resplendent2209
     

    Advertisement
  2. solarisin

    solarisin Member

    Joined:
    Jun 7, 2010
    Messages:
    8
    Likes Received:
    0
    I have had a similar problem, but with audio streaming through wifi. When the phone locks, the wifi disconnects even if the setting is to never disconnect on sleep, which makes my audio stream fail. This doesn't happen on apparently like Pandora that have an option in their settings to keep the phone from sleeping.

    I have not been able to find a solution to this.

    At&t nexus one.
     
  3. resplendent2209

    resplendent2209 New Member This Topic's Starter

    Joined:
    Jun 7, 2010
    Messages:
    4
    Likes Received:
    0
    I used Pandora and to my surprise it didnt put my wifi into sleep mode when screen went off. Strange this is regardless of whether auto lock option under Pandora is set to.

    On the other hand, I never received an email during the time screen was off but the audio was streaming. Looks to me that the built in apps doesn't follow the wifi sleep policy.
     
  4. resplendent2209

    resplendent2209 New Member This Topic's Starter

    Joined:
    Jun 7, 2010
    Messages:
    4
    Likes Received:
    0
    Actually when I paused the song it started looking for data connection so I don't know how pandora behaves.
     

Share This Page

Loading...