Wifi Solved!Tips


Last Updated:

  1. flenn

    flenn Member This Topic's Starter

    Joined:
    Jul 10, 2010
    Messages:
    15
    Likes Received:
    5
    I've been having wifi issues since I got my Dx but because the 3G speeds are so good, I haven't really been up to the challenge of dealing with it. I've been keeping track of some of the related posts and had tried a few things. The problem was that the Dx could easily connect to my home router but within 5 minutes or so (sometimes less than a minute), upload/download activity would just stop. Both the router and the Dx continued to show a connection, but no data would transfer. Actually, in a way, the problem was pretty easy to troubleshoot because it was so repeatable.

    To make things as easy as possible, I located the Dx in the same room as the router and turned off all security settings on the router. I started with the Dx and tried every option in the wifi settings menu with no luck. The connection would always halt. I tried changing channels, transmission rates, channel width and more. The problem continued. The mode was set to "mixed g and n" which I couldn't imagine would be an issue. After all, the Dx supports n speeds but for kicks, I changed the router to "g only". The Dx has now been up for 3 hours on wifi with no problems. I even left my house briefly and the Dx had no problem switching back and forth automatically from wifi to 3G and back to wifi. Speedtest shows faster speeds than when the router was on "mixed g and n" so I'm not giving up anything there.

    This solution may only work for me, but it's worth a try for others that are experiencing the same issues (I know there are more than a few). For what it's worth, I have a Trendnet 633GR router with the latest firmware. In my case, I only have one other device in the house that can take advantage of 802.11n speeds and it's rarely used. Everything else uses g. I have no problem leaving the router on "g only" until I either replace it or another firmware update comes out from Trendnet/Motorola. Good luck and post back your results.
     

    Advertisement
    AMDXP likes this.
  2. darksoul

    darksoul Active Member

    Joined:
    Jul 19, 2010
    Messages:
    33
    Likes Received:
    2
    I'm going to check mine when I get home. like you, I have the same issues, but 3g speeds are so good, i didn't even bother to troubleshoot.. Thanks
     
  3. dookie1

    dookie1 Well-Known Member

    Joined:
    Jun 25, 2010
    Messages:
    236
    Likes Received:
    9
    .11n issues have been widely reported...welcome to the club.

    i figure .11g is good enough...you're not gonna saturate 40mbit (yes, yes, 54mbit nominal...reality check it) streaming/surfing/downloading tiny apps.
     
  4. AFAngryWarrior

    AFAngryWarrior Well-Known Member

    Joined:
    Nov 10, 2009
    Messages:
    255
    Likes Received:
    40
    I have mine set to N only and it works fine as long as I leave the network open without WEP/WPA encryption. So to combat freeloaders I setup MAC Authentication so only the MAC ID's of my devices can access the network. Works for me this way I keep the N speeds.
     
  5. thenew3

    thenew3 Well-Known Member

    Joined:
    Apr 12, 2010
    Messages:
    344
    Likes Received:
    78
    I've tried N only, G only, B only, NG mixed, GB mixed, NGB mixed. and they all have the same issue. connection constantly drops or speeds gets into the single digit kb range.

    Finally changed the SSID to a different one and the encryption key to a different key and that seems to have made it better. (Still using the same WPA2-PSK encryption, and AES/TKIP mixed)

    It is still slower than my D1 on the same wifi network. Speedtest.net benchs from my PC shows about 21mb down 5mb up, on the D1 it shows 14mb down 3mb up, and on the DX it shows 9mb down 1mb up. but it is much better than the single digit kb speeds and constant drops. it has been connected for the past 8 hours now without dropping.
     
  6. flenn

    flenn Member This Topic's Starter

    Joined:
    Jul 10, 2010
    Messages:
    15
    Likes Received:
    5
    It makes sense that my solution wouldn't work for you. There've been a variety of wifi issues and your symptoms were definitively different from mine. In your case, you would experience drops and slowdowns. I never experienced a drop. The connection was always maintained (verifiable at both the Dx and router) but the data flow would simply stop. Also, I had full speed whenever the connection allowed data flow, never any slowdowns. It was all or nothing. Hopefully your solution will help others with similar symptoms.
     
  7. c4v3man

    c4v3man Well-Known Member

    Joined:
    Jul 22, 2010
    Messages:
    204
    Likes Received:
    23
    One thing to note is that the Speedtest app and Speedtest.net use different methods to pick a server. Make sure you're connecting to the same server if you're comparing devices. The speedtest.net website seems to ping a few servers and pick the best one, wheras the speedtest app just picks the closest server based on GPS position. Big difference when I switched to the fastest server that I usually test with.
     
  8. thefuzz

    thefuzz New Member

    Joined:
    Jul 16, 2010
    Messages:
    4
    Likes Received:
    3
    Posted this somewhere else (I belong to so many forums, can't keep track) and so far it seems to be working fine. Go into settings, Wireless & Network settings, Wi-Fi settings, menu-Advanced, Wi-Fi sleep policy and choose never. Since I did this, I no longer lose connection and it does not freeze up.
     
    nbailz and bbuck002 like this.
  9. mahers

    mahers Well-Known Member

    Joined:
    Apr 2, 2010
    Messages:
    1,320
    Likes Received:
    164
    So why would I use WiFi at home? Is it faster than 3G? And how does it affect the battery? I set up my X on my router when I got it, but I was curious why people use it if they have a good 3g signal at home (or wherever they use it). And I know some apps (e.g. Blockbuster) need to use it, but other than that.

    Thanks in advace!
     
  10. Ravenbrook

    Ravenbrook Well-Known Member

    Joined:
    Jul 14, 2010
    Messages:
    81
    Likes Received:
    3
    I used to have connection issues with my iphone 3G. I then had router issues one day and was talking to linksys and they advised me to use WPA encryption instead of WEP that I was using. Never had an issue after than.
     
  11. theineffablebob

    theineffablebob Well-Known Member

    Joined:
    Mar 24, 2010
    Messages:
    359
    Likes Received:
    51
    Depends on your connection speed. For me, at home, wifi is around... 30 times faster than 3G (1mbps vs 30mbps).
     
    mahers likes this.
  12. SFWB

    SFWB Well-Known Member

    Joined:
    Jul 13, 2010
    Messages:
    427
    Likes Received:
    27
    Wifi is also easier on your battery than 3G.
     
  13. FeTTo

    FeTTo Member

    Joined:
    Jul 18, 2010
    Messages:
    15
    Likes Received:
    2
    Turn the wi-fi sleep off in the wi-fi settings of the phone. Then you must change your security from WEP to WPA2-PSK (AES) This will allow Wi-Fi devices to connect as well without issues, change to channel 11, and modes b & g only. Now reboot your pc, modem and router. That fixed ALLLLLL my issues, before i was auto mps instead of b & g, and i was WEP security for my laptop. By changing to WPA2-PSK i have dropped all myinternet freezing issues on my laptop as well, along with random network drops and seems to make things faster by a few seconds. Now my droid x is almost faster then my pos dell laptop hahah
     
    AMDXP likes this.
  14. Magic Angle

    Magic Angle Active Member

    Joined:
    Apr 3, 2010
    Messages:
    27
    Likes Received:
    3
    I was having problems with my X as well connecting to my n router. I just changed the router to b and g only, and magically all my problems are gone. X stays connected and loads web pages fast. granted its only been 2 hours since i made the changes.
     
  15. AMDXP

    AMDXP Well-Known Member

    Joined:
    Jul 15, 2010
    Messages:
    97
    Likes Received:
    11
    This is some useful information you guy's are posting. However, with that said.

    Hopefully Motorola will fix these issues so that we wont' have to goto all this trouble just to get a good and stable wifi connection.
     
  16. Martimus

    Martimus One bite at a time... Moderator

    Joined:
    Jul 9, 2010
    Messages:
    19,535
    Likes Received:
    4,045
    The use of channel 11 may not work for everyone. The problem is that most consumer grade AP's don't have a way of detecting channel number conflicts. If all of your neighbors have channel 11 set in their AP's then channel 11 becomes a very conjested channel. And that conjestion becomes a potential impediment to connecting successfully to WiFi.

    Many consumer grade access points default to channel 6. I'd say avoid channel 6 if possible. There are also lots of home electronics that broadcast in the 2.4ghz band like cordless phones, microwave ovens, garage door openers, and baby monitors. For this reason it's usually best to try different channels till you find one that seems to be the most stable. That said there's no guarantee that you won't have to survey wireless channels 6 months down the road. Electronics change... as do neighbors... so periodically checking is likely a good idea.
     
  17. dookie1

    dookie1 Well-Known Member

    Joined:
    Jun 25, 2010
    Messages:
    236
    Likes Received:
    9
    get a wifi scanner app and see what's around you. then use the least utilized channel. 1/6/11 are the only non-overlapping channels. pick one. without a scanner, there is no reliable way to say 'use this one'...it's just a guess.

    also, wep vs wpa shouldn't have anything to do with stability of the connection, just security (wpa is better, wpa2 better still)...assuming properly implemented wifi software. which it seems pretty clear the X does not yet have.
     
  18. Piiman

    Piiman Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    2,333
    Likes Received:
    153
    I had to switch to wep to get mine to work. Odd
     

Share This Page

Loading...