wifi stays connected but loses data?General


  1. jimmypop13

    jimmypop13 Well-Known Member

    I can't get my wifi to stay connected over an extended period of time. This has been going on basically for as long as I can remember. Like for example, I was gone for an hour yesterday and when I turned my screen back on, the wifi bars were all still there, but they were grey and I couldn't connect to any websites or get data. I have to toggle wifi off and back on and then it works fine. I don't have this issue with my laptop or iPad2 so I'm not sure what's going on. I got my phone, rooted and rom'd, and a new wireless gateway from AT&T all at the same time so I don't even know where to start. Unless the wifi policy is worded backwards, it's checked to "always on." Maybe I should change it to "never(uses more data)" just to see. I'm gonna feel dumb if that's the issue!

    Advertisement
  2. kkl1993

    kkl1993 Well-Known Member

    what ROM r u using?

    u could try Settings> WiFi> Advanced> Keep WiFi on during sleep> Always
  3. jimmypop13

    jimmypop13 Well-Known Member

    That is what I have it set to. That's why I'm so confused why it shows the bars like it's connected but I can't receive any data until I toggle wifi.

    I'm using AOKP MS3 and lean kernel 1.9.0 stable with hotplug or interactiveX governor. I've been using AOKP with lean kernel since I rooted so it's persisted since somewhere a little before MS2 and lean kernel 1.2.0. I can't remember if it did it stock or not
  4. jkc120

    jkc120 Well-Known Member

    Next time it happens, run android terminal emulator and run:

    /system/xbin/ifconfig

    And see if there is still an IP address attached to the wifi device.

    Or there is probably a simple app on the market that will show your IP address(es).

    Perhaps it's a DHCP problem or your router. Does it do it on other wifi networks, too?
  5. jimmypop13

    jimmypop13 Well-Known Member

    No clue about other networks. I'm gonna let it sit for an hour and then run ifconfig
    Thanks

    EDIT: shoot, it's been an hour and it's still connected this time. Well I'll post up when it does it again
  6. jimmypop13

    jimmypop13 Well-Known Member

    It just did it. I guess its more odd than I thought bc I only had my phone screen off for a minute before I turned it back on and it was doing the above. Another weird thing is the time. Yesterday when I noticed it, it was about 6:04. Just a few minutes ago when I turned the screen on and it had done it, it was around the same exact time.

    I ran ifconfig but I have no clue what to look for when reading it and I'm not sure if its safe to post or not
  7. jkc120

    jkc120 Well-Known Member

    You can mask out the MAC addresses (6 2-digit hex numbers separated by colon), the last octet of the ipv4 IP address (e.g. 11.22.33.x) and the ipv6 IP address(es).

    The rest should be safe to share.
  8. jimmypop13

    jimmypop13 Well-Known Member

    There are some built in tests on the at&t gateway. I ran them and everything passed except for one of the IP tests called "Continuity check to 6rd BR." No clue what that is though.
  9. jkc120

    jkc120 Well-Known Member

    6rd is a type of IPv6 tunnel deployment. Nothing to worry about.

    RFC 5569 - IPv6 Rapid Deployment on IPv4 Infrastructures (6rd)

    So you are unable to browse when this happens and have no data, or are you just worried about the color of the icons not being blue?
  10. jimmypop13

    jimmypop13 Well-Known Member

    Yeah I'm unable to browse. I try to go to websites and it says webpage not available. And I notice only the up arrow comes on in the wifi bar when I try to go to a webpage. No down arrow.

    Here is the ifconfig, hope I edited it right!
    Thanks for all your help

    app_84@android:/ $ export PATH=/data/local/bin:$PATH
    app_84@android:/ $ /system/xbin/ifconfig
    cdma_rmnet0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
    UP POINTOPOINT RUNNING NOARP SLAVE MULTICAST MTU:1428 Metric:1
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:3363 (3.2 KiB) TX bytes:2840 (2.7 KiB)
    lo Link encap:Local Loopback
    inet addr:127.0.0.x Mask:255.0.0.0
    inet6 addr: ::1/xxx Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:419 errors:0 dropped:0 overruns:0 frame:0
    TX packets:419 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:32848 (32.0 KiB) TX bytes:32848 (32.0 KiB)
    rmnet0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
    inet6 addr: xxxxxxxxxxx Scope:Global
    inet6 addr: xxxxxxxxxxx Scope:Link
    UP BROADCAST RUNNING NOARP MULTICAST MTU:1428 Metric:1
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:5000
    RX bytes:3363 (3.2 KiB) TX bytes:2840 (2.7 KiB)
    wlan0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
    inet addr:192.168.1.xxx Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: xxxxxxxx Scope:Global
    inet6 addr:xxxxxxxxx Scope:Link
    inet6 addr: xxxxxxxx Scope:Global
    inet6 addr: xxxxxxxx Scope:Global
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:2905 errors:0 dropped:97 overruns:0 frame:0
    TX packets:3389 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1562215 (1.4 MiB) TX bytes:737065 (719.7 KiB)
    app_84@android:/ $
  11. syntrix

    syntrix Well-Known Member

    That's not native, but is this what VZW is using in some markets?

    I'm deploying v6 transport/services for my company starting NOW. Time is right, so why not.
  12. jkc120

    jkc120 Well-Known Member

    Ok, it still has an IP. Next time it happens, you can try pinging the IP of your router (probably 192.168.1.254 or 192.168.1.1). From a window in android terminal emulator:

    Code:
    ping -c 4 192.168.1.1
    
    If that works, you could also try pinging Google (well, for some reason the dns resolution doesn't work with my busybox, so use the IP):

    Code:
    ping -c 4 74.125.224.82
  13. syntrix

    syntrix Well-Known Member

    kernel is dual stack, that's why you see the ipv6 addresses.
  14. callmeox

    callmeox Well-Known Member

    The problem isn't your phone, its most likely the 2Wire residential gateway from ATT.

    Check out the Uverse Talk forums...there's no solution yet.

    I would recommend getting another wireless router and connecting it to the 2wire in DMZPlus mode while shuttng off wireless on the 2wire.

    I have the same issue but infrequently. Rebooting the gateway restores service for me but is a PITA.

Share This Page