Wifi stuck on "obtaining IP address"Support

Last Updated:

  1. red518irish

    red518irish Member

    I am new here and this is my first post. I have searched the site before posting but didn't find an answer.
    I am having a wifi issue. I have tried several networks, both secure and non secure, however I get the same results. It just says, "obtaining IP address" the phone will not go any further.
    Has anyone seen this or have any suggestions. Thanks in advance.

  2. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums!

    On your home network - please try a router reset.
    marctronixx likes this.
  3. Did you open the browser if required and accept the policy agreement for the Wifi you are using? And are you selecting a WiFi source from the settings menu for Wireless Networks?
  4. red518irish

    red518irish Member

    EarlyMon - I just moved and don't have my home network set up yet. I have tried to connect to wifi at work, church, and at local restaurants and what not, no matter where I am I get the same problem.

    Panthro - I am selecting my wifi source from the settings menu in Wireless Networks. I tried like you said to open the browser, but without connecting to wifi obviously that won't work, I did open the browser with the 3G connection while trying to connect with wifi and there is no agreement to accept that I can find.
  5. marctronixx

    marctronixx Moderator Moderator

    if this happens to any network you try to sniff out you may have borked up something.

    have you done anything to troubleshoot?

    battery pull?

    soft reset form power down screen?

    finally a hard reset?

    what networks are you connecting to? b/g/n? a? 2.4 ghz? 5 ghz?

    what channels are you trying to connect to on these networks?
    EarlyMon likes this.
  6. EarlyMon

    EarlyMon The PearlyMon Moderator

    Yeah, the browser authentication thing only works once connected - and often the HTC browser won't work for that, but Firefox will.

    Ok - settings, Wireless & networks, Wi-Fi settings, Menu button, Advanced, click on Best Wi-Fi performance - scroll to bottom, uncheck DLNA auto-IP if on.
  7. red518irish

    red518irish Member

    I very well may have borked up something, I am def known for that lol.
    I have done a battery pull, soft reset and hard reset. I believe that most of the networks are b/g, not sure of the ghz.
    It looks like to me the phone is trying to connect to channel 6.
  8. red518irish

    red518irish Member

    I checked the Best wifi performance box, and the DLNA box was already unchecked.
    This did nothting, same results.

    I appreciate everyone's help. Please keep the ideas coming. I don't know what is going on, I am not totally helpless, but this one seems to have me stumped.

    Thanks in advance.
  9. EarlyMon

    EarlyMon The PearlyMon Moderator

    You didn't go and set physical IP addresses did you?
  10. marctronixx

    marctronixx Moderator Moderator

    if you have done a hard/factory reset and the handset and have not installed or amde any changes to the handset, then its possible there is an issue beyond your ability to fix and you should take it into a corp. repair store and have them smoke it over. they can test it to see if all systems pass.
    EarlyMon likes this.
  11. red518irish

    red518irish Member

    I just tried checking the box for the DLNA and now I connected to the network at my office.
    Not sure what this means or does, but it worked.
  12. red518irish

    red518irish Member

    I did not change this
  13. EarlyMon

    EarlyMon The PearlyMon Moderator

    Well - that's odd. Not necessarily bad - but really odd.

    Wait - when you go to Wi-Fi settings - and click on the name of the network you're now on - is your IP address a dotted quad (read: xxx.xxx.xxx.xxx) - and please, what is it saying under security?
    marctronixx likes this.
  14. red518irish

    red518irish Member

    Ok, after some research and testing, it seems that everything works fine on the 3G it is just the wifi that is causing issues. I was able to find a network that I could connect to without the DLNA checkbox checked and now Talk works both on and off of wifi.
    So it seems that my work and church networks are both ad hoc (I'm not sure what that means) but I am happy to have it all figured out.

    Thanks to everyone for your insight, patience and help. It is much appreciated.
    EarlyMon and marctronixx like this.
  15. EarlyMon

    EarlyMon The PearlyMon Moderator

    Ad-hoc is nothing bad, it's supported by Linux and Windows (for example) but Android is late to the party.

    It's simply a network sharing situation where standardized routing and addressing rules are in a way, kinda relaxed. Many network admins hate them because they lead to hidden problems like this, while others like it because it's easy to configure things to work quickly, on the fly, so to speak.

    Pretty glad you brought this up - now we know people with ad-hoc network access only can finally use their 3vos to get on those net - and we also now know the limitations involved.

    Cool!! :) :) :D
  16. mricketts

    mricketts Member

    FYI: I have the same problem with wifi......it couldn't obtain the IP address. I have not yet attempted any troubleshooting methods.
  17. jcunwired

    jcunwired Well-Known Member

    I have no issues with wifi or 3G; the gmail sync issues I was seeing were tested with both, the same experience.

    One thing I forgot to mention in the original post - the gmail web app was also not syncing before I enabled it again on the Evo 4G.

    I did update the original post, gtalk is now working now that everything is correctly syncing.
  18. thelber

    thelber Active Member

    I have the Evo 3D and have had no problems with Wi-Fi until today. I've had my Evo 3D since launch day and today for some reason I can no longer connect to Wi-Fi.

    I saw another Wi-Fi problem post here but their phone couldn't scan for Wi-Fi. Mine scans fine....it just can't connect. So I figure it's a different problem thus the new thread.

    I have Wi-Fi turned on and the Evo finds and sees the network and says "Obtaining IP address". After a minute or so it say "Disconnected" under Wi-Fi. After a few seconds the whole process starts over.

    My battery which by mid afternoon is at around 65% today is reading 10%.

    I've tried restarting the router (which I've made no changes to) three times by unplugging it and waiting a few minutes and then plugging it back in. I've tried restarting the Evo twice and I've also pulled the battery and waited about 2 minutes. Still no change.

    Keep in mind everything has worked perfectly since launch day with my current setup. No changes to my router settings. I haven't installed any new apps in the past several days and I was using Wi-Fi yesterday so I don't think it could be that. I don't know if maybe there was an update to the phone's firmware or something like that.

    Any Ideas? Thanks in advance!
  19. marctronixx

    marctronixx Moderator Moderator

    there are no firmware updates but there has been some maintenance updates which, since you have had the phone since launch day, you may already have installed. nothing new since those htc watch and sync updates...

    did you remove the network from your handset and then rescan for it and attempting to connect?

    what are you connecting to? 2.4 b,g, or N?

    do you have security? if so did you disable security to make sure a security key is not the issue?

    Merged your thread here as you and the original OP seem to have had the same issue based on your initial post.
    EarlyMon likes this.
  20. parishmc

    parishmc Well-Known Member

    having exact same problem here, tried hard reset and no luck.
    will be taking to corp repair store tomorrow. WTF ?

  21. parishmc

    parishmc Well-Known Member

    turned out to be a problem with my wireless router,
    i unplugged it for 5 minutes and now the Evo connects

    EarlyMon and marctronixx like this.
  22. thelber

    thelber Active Member

    Thanks for the help. Turns out I just re-did the setup on the router and it started working. Go figure. Thanks again!

    EarlyMon likes this.
  23. oOMavrikOo

    oOMavrikOo Well-Known Member

    So last night my phone just randomly disconnected from my home Wifi. I didn't think too much of it and it and ignored it. Well i tried to connect to my work Wifi and it was a no go, same thing when I got home. It just keeps saying it can't connect. Any ideas?
  24. marctronixx

    marctronixx Moderator Moderator


    what did you do to troubleshoot?

    are you rooted?

    do a battery pull?

    do a soft reset from the shutdown screen?

    does is say "obtaining IP address"?
  25. oOMavrikOo

    oOMavrikOo Well-Known Member

    I've rebooted, battery pull, and yes, it says obtaining IP address but then just disconnects. I've even restarted my router and modem. It says unable to scan for networks. I keep turning the Wifi off and back on. Nothing's working.

Share This Page