wifi takes a while to connect in sleep mode?Support


Last Updated:

  1. jaliy

    jaliy Well-Known Member This Topic's Starter

    Joined:
    Aug 7, 2011
    Messages:
    895
    Likes Received:
    19
    if i go to within range of my home wifi i get connected right away if i'm using the phone. but if my phone is in sleep mode it takes a while to get connected. anyone know why?
     

    Advertisement
  2. Johny451

    Johny451 New Member

    Joined:
    Oct 17, 2012
    Messages:
    3
    Likes Received:
    0
    It's kind of interesting how you know it takes a while if the phone is in sleep mode. Anyway, the reason is that when sleeping, the phone tries to draw a little power as possible so only wakes up the WiFi every now and then. I think you can get apps that deliberately keep the WiFi on all the time but the battery hit isn't worth it (Yahoo's Mail app does this accidently and severely hurts battery life).
     
  3. jaliy

    jaliy Well-Known Member This Topic's Starter

    Joined:
    Aug 7, 2011
    Messages:
    895
    Likes Received:
    19
    i know this because if i wake up the phone too fast when i enter wifi range it still shows 3g
     
  4. jaliy

    jaliy Well-Known Member This Topic's Starter

    Joined:
    Aug 7, 2011
    Messages:
    895
    Likes Received:
    19
    Anyone else?
     
  5. Slug

    Slug Check six! Moderator

    Joined:
    Aug 1, 2009
    Messages:
    20,068
    Likes Received:
    15,647
    To change this behaviour, go to

    Settings/Wireless & networks/Wifi settings/Menu/Advanced

    and change

    Keep wifi on during sleep
    to always.
     
  6. jaliy

    jaliy Well-Known Member This Topic's Starter

    Joined:
    Aug 7, 2011
    Messages:
    895
    Likes Received:
    19
    it's on always by default
     

Share This Page

Loading...