Wifi Tether on rooted stock?


  1. Aremihc

    Aremihc Well-Known Member

    I can't seem to get Wifi Tether to work at all... I have tried both 2.07 and 3.1 beta, and neither will actually provide a connection. 2.07 doesn't show up as a network on my netbook, and 3.1 shows up with the local network, and says unsecured, no internet, despite me having encryption enabled and internet on my phone. I've tried changing the client to NexusOne, enabling the routing hotfix, disabling encryption and access control, everything... Any suggestions?

    Btw, I was using 2.07 (or .08) on my Incredible yesterday with the same netbook, so I know it works.

    Thanks

    Strange... I tweaked something and it worked, but won't encrypt...

    Advertisement
    :
  2. sprout703

    sprout703 Member

    Same boat. All but given up on trying to tether. A shame as my main purpose for rooting was to tether.

    Are there any Step by Step instructions on how to get this to tether out there including laptop settings?
  3. goofdad

    goofdad Well-Known Member

    Likewise, one of my main purposes of rooting was to tether (primarily for my nook, also rooted running CM7).

    After hassling with it most of this afternoon, here's what I did that WORKED:

    First, I disabled Verizon's Mobile Hotspot app (phone settings -> app, find Mobile Hotspot, disable) ... dunno if this was necessary, but it was pissing me off that it kept trying to pop up while I was debugging this and offering me an 800 number to call.

    Then, in Wireless Tether app:
    Menu->Settings
    Change Device-Profile to Samsung Galaxy Nexus (CDMA/LTE)
    Change Setup-Method to Netd (master)
    Enable WPA2-PSK encryption
    Add a passphrase
    Change SSID
    Enable "Routing fix"

    Then, it worked. Like a charm.

    I can now connect to it from my nook and download apps from the market.

    Note: the first time I tried, I managed to select the Samsung Galaxy Nexus (GSM) ... don't do that ;-)

    I got this information reading this thread on xda, which really, really helped:
    Wireless tether rezound - xda-developers
    --
    Doug

    edit:

    Actually, the first time I tried it, I got an error from the tether saying "What the hell, your phone is trying to take over the wifi" or somesuch. It then hung at "disabling hotspot" ...

    battery pull, reboot ...

    THEN everything worked!
    Junkmail8835 likes this.
  4. goofdad

    goofdad Well-Known Member

    BTW, in case you're wondering, I'm running RezROM, fresh install.
    --
    Doug
  5. sprout703

    sprout703 Member


    Did all of the above and still nothing. Im disgusted at this point. Ive spent hours and hours trying to get this to work. Considering returning my rezound for something else.
  6. Bob Cat

    Bob Cat Careful, They're sharp!! Moderator

    What rom are you running?
  7. sprout703

    sprout703 Member

    Progress!!! Installed a new ROM. Computer recognizes my rezound, signal strength is excellent BUT i get the error "Your computer is trying to use a DNS server that is incorrect or doesnt exist"

    So close
  8. sprout703

    sprout703 Member

  9. So, the title of this thread is a bit misleading. I'm rooted stock and am looking for a solution without loading another ROM. I read somewhere that it can be done, but heck if I can find it again. I've tried everything that I can think of and....no wifi tether.
  10. jlb0305

    jlb0305 Well-Known Member

    same boat... tried to tether on rooted stock and got nothing. is there a better app that works on rooted stock or does someone have different instructions for wireless tether app?

    Second thing, when I stop trying to tether/quit app it crashes my phone putting it into the long reboot (sits at the 4G LTE screen for like 5 mins not fastboot) any suggestions?
  11. pwned

    pwned Well-Known Member

    On stock you can't use infrastructure mode if I remember right. Only adhoc
  12. esmith818

    esmith818 Well-Known Member

    I am running rooted stock (with "Mobile Hotspot" and "TetheringGuard 2.3.4" both frozen via Titanium Backup app) and I am on a MacBook Pro tethered to my Rezound as I enter this post. My WiFi Tether settings are as follows:

    Device Profile: Samsung Galaxy Nexus (LG_LTE)
    Setup Method: WEXT (ad-hoc)
    WiFi-Encryption: unchecked
    Routing Fix: checked

    I tried to enable encryption and set a passphrase, but that seems to keep my laptop from seeing the broadcast. Like jlb0305, my phone rebooted once when stopping the tether, but that was while using goofdad's settings above. Since changing to my current setup, I have not had this problem again.
  13. JamrD

    JamrD Member

    I am in the same boat with the Wifi Tether app not showing up on any of my clients. The stock Hotspot feature tells me that I need to subscribe.
    What the heck am I doing wrong?????
  14. esmith818

    esmith818 Well-Known Member

    Did you freeze the apps and change the settings of WiFi Tether as I described right above your post? I'm not sure how the stock Hotspot option would do anything if it were frozen as per my previous post. ;)
  15. JamrD

    JamrD Member

    Thanks for checking back. I did get it working shortly after posting that question.
    Apparently my clients (a droid Droid X and a Ipad) did not like the SSID name I had chosen. It was "Nexus Wifi" when it did not show up. I then changed it to "Nexus" and it did show up. I can only surmise from this that it was too many characters or it does not like spaces in the SSID.
    After I was able to get the 2 clients to connect, I had a problem with them getting the internet. I then enabled Routing Fix and the clients were able to access the internet.
    I still have not frozen the stock hotspot app and Wifi Tether is working fine.

    So here are my settings.
    Device Profile = Galaxy Nexus
    Setup Method = Auto
    Encryption = WPA2-PSK
    SSID = Nexus
    Channel = 04
    Wifi Driver Reload = Enable
    Routing Fix = Enable
    Disable Wake-Lock = Enable
    *All others are not checked.

    BTW what "Enable Access Control" do? I tried it both ways and I noticed no difference.
    Thanks for the help, I hope this helps someone.
    Junkmail8835 likes this.
  16. kimasters07

    kimasters07 New Member

    What version of wifi tether do you use to get it to work on stock?
  17. esmith818

    esmith818 Well-Known Member

    I'm running version 3.1-pre110, but only because that is the apk I had on hand.
  18. bluemsw

    bluemsw Well-Known Member

    I have rooted to get the WiFi on stock Rom but I can't seem to get superuser to work. Can anyone help me out or point me in the right direction please
  19. Junkmail8835

    Junkmail8835 New Member



    Ok, so after reading this forum and MANY others before and after rooting my droid rezound I FINALLY got it to tether! I was about to throw my phone against the wall because this was the sole feature I've been wanting for over a year, and JUST NOW I got it to work!

    Listen up rezound users! It IS possible to tether after rooting WITH ICE CREAM SANDWHICH! You need to get wifi tether, then go to settings and set up a SSID (no spaces allowed)
    Then change device profile to HTC Rezound (LTE/CDMA/GSM)
    Change set up method to netd (master)
    You can enable encryption if desired...I did since I have limited data
    scroll almost to the bottom of the settings list to routing fix.. YOU MUST CHECK THIS!!!! If you don't then your computer or tablet will only show that it's connected, but can not actually actively use your Internet.


    Now you should be able to use your tethering! Good luck! Let me know if you have issues, I've spent DAYS searching and downloading many apps, but finally came up with a way thanks to all of you!

    Enjoy!:)
    rustyhokie and obscuro like this.
  20. danchap1234

    danchap1234 New Member

    I tried those settings but got an error log when the wireless teather activated. It says started with errors. "Enabling routing fix...failed" and "enabling NAT rules...failed"

    Any suggestions?
  21. rustyhokie

    rustyhokie Active Member

    Finally rooted my rezound. Got wifi tether to work with stock ROM following the instructions that Junkmail8835 has above. Have had the following connect via wifi and work: Windows 7 laptop, iPhone, and Kindle Fire.

    Cheers
Loading...

Share This Page