Root Wifi tether that works with rooted ICS Atrix 2?

Discussion in 'Android Devices' started by jkc120, Dec 6, 2012.

  1. jkc120

    jkc120 Well-Known Member
    313

    Apr 12, 2010
    2,266
    1,107
    313
    Senior Software Engineer
    El Dorado Hills, CA
    I have a friend who has an Atrix 2, which I recently helped him root. It's running ICS.

    He tried Foxfi for wifi tether, which works (side loaded, since AT&T blocks it :rolleyes:) but has the time limit. He was reading reviews about the paid version of Foxfi that it didn't work (not sure if he saw if it was specific to this phone or others).

    So my question is - what's a reliable (and unlimited) wifi tether app that can be used on a rooted Atrix 2 running ICS?

    Thanks in advance!
     

    Advertisement

  2. skearton

    skearton Well-Known Member
    43

    Jan 19, 2011
    133
    25
    43
    You could always try the FoxFi paid version, and see if it works. Then request a refund if it doesnt.

    Also you can do this:

    The entitlement check is a setting built into the AT&T ROM by default to check whether you have permission from your carrier to do things like Wifi and USB Tethering. Why it does this check upon connecting a Webtop accessory I'm not quite sure, but anyway...

    Things you will need to disable it:

    ES File Explorer (free from play store)
    aSQLiteManager (free from play store)

    1. Launch ES File Explorer and within its settings, grant it full root permissions (near the bottom of settings, go in and check all four checkboxes).

    2. From ES File Explorer navigate upward out of your SD card and onto the root of your device, then go into Data/Data/com.motorola.android.providers.settings/databases

    3. Copy the "settings.db" file found there over to your SD card

    4. Using aSQLiteManager select "Open Database" and pick that settings.db file on your SD card.

    5. Select "settings" from the four tables you are presented with

    6. Select "Data" from the top button menu

    7. You'll see a long list of crap. Hit PgDn untiul you see line 113 "entitlement_check". Hit Edit and change the value from 1 to 0.

    8. While you're here, also go to lines 117 and 118 that start with "dun" and change them both from 0 to 1. This is not necessary for Webtop but will enable wifi hotspot tethering.

    9. Exit aSQLiteManager, go back into ES File Explorer and this time copy the modified "settings.db" back into the previous/original folder from Step 2, overwriting the old file.

    10. Exit ES File Explorer, reboot your device and Webtop should work as expected.

    That post is from:
    http://forum.xda-developers.com/showthread.php?t=1912323
     
    TVCCS likes this.
  3. JeepsOLot

    JeepsOLot Active Member
    36

    Nov 5, 2012
    26
    2
    36
    Male
    Machinist
    Stuart, FL
    I used this method, and I have Wifi Hot Spot working. I also have an Atrix 2, rooted, and with ICS. In fact, I rooted my Atrix for this specific purpose, as well as to fix my Webtop.

    Jerry
     
  4. skearton

    skearton Well-Known Member
    43

    Jan 19, 2011
    133
    25
    43
    Worked for me as well. Decided to try it since you had reported success.

    Thank you.
     
  5. TVCCS

    TVCCS Well-Known Member
    103

    Jan 19, 2011
    616
    163
    103
    Male
    Consultant/Editor/Writer
    Los Angeles, CA
    Just a quick follow-up on this...does the process listed involve root access only? Thanks.
     
  6. skearton

    skearton Well-Known Member
    43

    Jan 19, 2011
    133
    25
    43
    Yes, it only works for root. Foxfi may suit your needs and didn't require root.
     
  7. TVCCS

    TVCCS Well-Known Member
    103

    Jan 19, 2011
    616
    163
    103
    Male
    Consultant/Editor/Writer
    Los Angeles, CA
    skearton likes this.
  8. coolyule

    coolyule New Member
    5

    Sep 17, 2013
    3
    0
    5
    "The entitlement check is a setting built into the AT&T ROM by default to check whether you have permission from your carrier to do things like Wifi and USB Tethering. Why it does this check upon connecting a Webtop accessory I'm not quite sure, but anyway...

    Things you will need to disable it:

    ES File Explorer (free from play store)
    aSQLiteManager (free from play store)

    1. Launch ES File Explorer and within its settings, grant it full root permissions (near the bottom of settings, go in and check all four checkboxes).

    2. From ES File Explorer navigate upward out of your SD card and onto the root of your device, then go into Data/Data/com.motorola.android.providers.settings/databases

    3. Copy the "settings.db" file found there over to your SD card

    4. Using aSQLiteManager select "Open Database" and pick that settings.db file on your SD card.

    5. Select "settings" from the four tables you are presented with

    6. Select "Data" from the top button menu

    7. You'll see a long list of crap. Hit PgDn untiul you see line 113 "entitlement_check". Hit Edit and change the value from 1 to 0.

    8. While you're here, also go to lines 117 and 118 that start with "dun" and change them both from 0 to 1. This is not necessary for Webtop but will enable wifi hotspot tethering.

    9. Exit aSQLiteManager, go back into ES File Explorer and this time copy the modified "settings.db" back into the previous/original folder from Step 2, overwriting the old file.

    10. Exit ES File Explorer, reboot your device and Webtop should work as expected."

    When I follow this procedure my phone will not restart. It just stays at the att scene, and I have to restore the phone and start over. When copying the settings.db file back to the device, I see there is also a settings.db-journal file, but it is 0kb. Should I be copying this back to the device also? Possible I am not saving the file when exiting aSQLiteManager correctly? Help
     
  9. codyasdf

    codyasdf New Member
    6

    Oct 1, 2013
    1
    1
    6
    I too ran into this problem. It turned out to be the owner/permissions on settings.db got changed accidentally. Before restarting your phone after updating settings.db, open Terminal Emulator and make sure settings.db file has these permissions:
    $ ls -l settings.db
    -rw-rw---- system system 14336 2013-10-01 10:24 settings.db

    If you don't show that, update the owner/permissions with these commands:
    $ su
    # chown system settings.db
    # chmod 660 settings.db
     
    coolyule likes this.
  10. coolyule

    coolyule New Member
    5

    Sep 17, 2013
    3
    0
    5
    First off Let me say Thanks.
    Ok, way above my paygrade. (dating myself) Managed to use terminal Emulator and got

    -rw-rw---- system system 15360 2013-10-01 18:14 settings.db

    If this is incorrect, do I just use the commands you provided above, or am I going to have to input those owner/permissions?
     
  11. coolyule

    coolyule New Member
    5

    Sep 17, 2013
    3
    0
    5
    Ok, I think I got it. Thanks again for the help. The permissions posted above were for the file before I modified it. I kept reading and understand what your update commands for the owner/permissions are doing. I will modify file and copy back to directory and then check owner/permissions and modify as needed.
     

Share This Page

Loading...