Root Wifi tethering for cyanogen 7

Discussion in 'Android Devices' started by brothakyle, Apr 18, 2011.

  1. brothakyle

    brothakyle Member
    16

    Apr 6, 2011
    11
    2
    16
    I just installed cyanogen 7. So far i really like it. the only problem is I can't get wifi tethering to work. I tried wifi tether for root users and barnicle wifi tether as well as the andriod tether and i can't get any of them to work. tethering is an absolutely essential function for me. what should i do?
    I saw something about project hosting on google code, but i am new to this whole Flashing ROMs business and i don't know what that means.
     

    Advertisement

    Bizzzy1 and random255 like this.
  2. brothakyle

    brothakyle Member
    16

    Apr 6, 2011
    11
    2
    16
    I uninstalled the apps i got rebooted and it worked...i am an idiot.

    I would delete this thread if i knew how.
     
  3. novox77

    novox77 Leeeroy Jennnkinnns!
    VIP Member
    313

    Jul 7, 2010
    3,965
    3,256
    313
    It's actually a common problem. For whatever reason, a reboot is necessary for tethering to start working the first time.

    Also, the built-in tether setting works great; it's not necessary to download the wifi-tether app.
     
    luxetical and random255 like this.
  4. random255

    random255 Well-Known Member
    16

    May 7, 2010
    47
    2
    16
    I'm glad the OP started this thread... I'm on this ROM, and I didn't think Wifi teathering worked either. Also didn't know there was a built-in wifi feature, will have to hunt for that.
     
  5. gregs887

    gregs887 Well-Known Member
    63

    Jun 21, 2010
    296
    53
    63
    Moorpark, CA
    It is in the wireless and network settings menu.
     
  6. novox77

    novox77 Leeeroy Jennnkinnns!
    VIP Member
    313

    Jul 7, 2010
    3,965
    3,256
    313
    And with CM7 (ADW Launcher), you can make a custom shortcut to the actual setting, so you don't have to actually go into Settings > Wireless And Network > etc etc. I made a shortcut in place of my old wifi-tether app. That shortcut brings me directly to the settings page where I can toggle both wifi and usb tethering.
     
    random255 likes this.
  7. farva

    farva Well-Known Member
    18

    May 27, 2010
    95
    17
    18
    This is really handy ... here's how to do what is described above:

    Long press the homescreen, choose "Custom Shortcut", then "Pick your activity", then "ADW Activities", then scroll down to and expand the "Settings" category. Find and select "Settings(.TetherSettings)".
     
  8. Gearhead_eng

    Gearhead_eng Well-Known Member
    18

    Jul 28, 2010
    49
    19
    18
    I have two Evo 4G's that I have rooted (unrevoked) have never had the Wifi Tether work Barnical working. I tried everything from wiping and flashing new roms, to restoring back to sense 2.2 and updating profile/prl. I also tried going to the Google/wifi tether page and downloading them straight off the site and installing them. Nothing seamed to work. The app just sits there like its trying to start and never does. Then if you cancel it and restart the app it says "The app started with errors, view log."

    I haven't tried the stock wifi tether I'll check it out.
     
  9. novox77

    novox77 Leeeroy Jennnkinnns!
    VIP Member
    313

    Jul 7, 2010
    3,965
    3,256
    313
    Did you ever try a custom kernel? I remember some people were able to get tether working with the stock froyo HTC kernel, but most people had the best luck with a custom kernel (or non-stock ROM which includes a custom kernel). Even then, it was sometimes hit or miss. Certain versions of wifi-tether play nice with certain kernels, so it was a matter of finding a combo that works and sticking with it.

    Lately, I've had no issues with the most recent wifi-tether app with any custom kernel/ROM.

    Also, when I said built-in tethering, I was referring to the built-in tethering for CM7 (CyanogenMod 7) which is a custom ROM. I wasn't referring to the "Sprint Mobile Hotspot" tethering app. That won't work because it contacts Sprint to see if you've paid for the tethering subscription.

    Can't attest to Barnacle; never tried it.
     
    Gearhead_eng likes this.
  10. Gearhead_eng

    Gearhead_eng Well-Known Member
    18

    Jul 28, 2010
    49
    19
    18
    Thanks, I haven't tried any custom Kernals on the Evo (I am with my Hero though... Dekafuct #589). Both Evo's are flashed with the current CM7.0 Stable Release. What is the best kernel right now for CM7? I'll give it a shot.

    I've tried several different versions of wireless tether from their site (and market) but haven't found one that works yet.
     
  11. novox77

    novox77 Leeeroy Jennnkinnns!
    VIP Member
    313

    Jul 7, 2010
    3,965
    3,256
    313
    Didn't realize you were on CM7. The built-in tethering should work fine after a reboot. No need for wifi-tether or any other tether apps.
     
    Gearhead_eng likes this.
  12. Gearhead_eng

    Gearhead_eng Well-Known Member
    18

    Jul 28, 2010
    49
    19
    18

    The built in tether worked great.... thanks for the tip! Also added the shortcut on the home screen like you mentioned. Awesome!
     
  13. mmarrero

    mmarrero New Member
    6

    Apr 28, 2011
    1
    1
    6
    Does anyone know if Sprint will charge if i setup tethering in the settings? I have a rooted HTC Evo with cyanogen android 2.3 and just wanted to know if i would be charged? thanks!
     
    LateralShamu likes this.
  14. Gearhead_eng

    Gearhead_eng Well-Known Member
    18

    Jul 28, 2010
    49
    19
    18
    No you wont be charged if you use the settings in CM7 in "Wireless & networks"... from my knowledge they only charge the $29.99/Month for the Sprint Hotspot App.
     
    LateralShamu likes this.
  15. clehmann

    clehmann New Member
    6

    Dec 7, 2012
    2
    1
    6
    My rooted Droid Eris running Cyanogenmod 7 does not have the wireless tethering option in settings, only USB tethering. Any explanation? Any fix?
     
  16. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    just an fyi, this is the evo 4g forum.........but anyways you can get the wifi tethering app from here:http://androidforums.com/evo-4g-all...net-tethering-w-evo-4g-3g-wireless-wired.html. now again it is for the evo 4g but the wifi app should still work on your phone.

    and i'm not sure why yours do not have it. in cm7 on the evo, the wifi hotspot hacked is found in settings/wireless network.
     
Tags:

Share This Page

Loading...