wifi tethering stopped working - unable to get IP addressSupport


Last Updated:

  1. jdaun

    jdaun New Member

    This is my first post here, and I'm an Android newbie so go easy on me :)

    My phone is stock - it is NOT rooted.

    I've been using the WiFi Hotspot functionality through Quick Settings for the past month or so. Light usage, no heavy downloads.

    Worked great until yesterday, Sunday Apr 17. Now when connecting my PC to the wireless network, my PC says it's unable to get an IP address. So my wifi hotspot is no longer working.

    Here are the detailed symptoms: When enabling the WiFi Hotspot in Quick Settings, everything looks normal - it says "turned on" in Quick Settings, and the blue hotspot indicator is lit up in the status bar in the upper left. So everything I see on the phone looks normal.

    When I connect my PC to the hotspot, it looks it's connected, however when I try to use the connection it says it has limited or no connectivity. When I try to repair the connection on the PC, it fails while trying to get an IP address.

    I have rebooted the phone and the PC multiple times, with no success.

    I know Sprint pushed out an update to block wifi tethering a few weeks ago, could VM have done the same now?

    Any recommendations (aside from rooting my phone, which I'm not too keen on yet)?

    Advertisement
  2. jdaun

    jdaun New Member

    Here are the details on my phone:

    Android 2.2.1
    Kernel Version 2.6.32.9
    Build number FRG83
    SW Version VM670ZV4
    HW Version 1.2
  3. 0ptimusV

    0ptimusV Active Member

    Have you tried to connect wifi to a different device besides your computer?
  4. jdaun

    jdaun New Member

    No, I haven't tried connecting any other devices (I don't have any other wifi devices.)

    Are there any settings in the phone or the PC that I should be checking?

    It stopped working Sunday and I did not make any changes on the phone or the PC during that time.

    Thanks!
  5. DBNissan

    DBNissan Well-Known Member

    I'm on my wifi hotspot right now. Have you assigned the hotspot to a network type? Like Home Network, Work Network, Public Network, etc.

    My laptop (Win7 OS) will not continue to the internet until the hotspot connection changes from Public Network (when it first connects) to Work Network (what I assigned it to). Sometimes it takes a minute for that to occur.
  6. jdaun

    jdaun New Member

    I screwed around with my PC tonight. I re-entered my WPA password, and I was able to connect using the wifi hotspot.

    Don't know what re-entering the WPA password did, but it seems to work now.

    Another question - let's say Virgin Mobile does push out an update in the future to close the Quick Settings wifi hotspot backdoor ... would there be a way to avoid that update?
  7. lou61166

    lou61166 Well-Known Member

    Yes just do not accept it,i would think when and if VM pushes out the 2.3 upgrade that patch will be in it,to more stop it,most users will want the upgrade making it easy to stop hot spotting the phone
  8. Zehrfox

    Zehrfox Member

    Mine stopped working the other day as well. In fact I heard my phone reboot, and thought maybe it was defective. Now I know what it was.

    I have been unable to get the wifi hotspot to work now. I have tried the uninstall Quick Settings, then power off, power on, copied the apk onto SD with USB connection, then reinstalled. It had retained all the settings??

    And it did not work (WPA2). So then I tried setting it up as "open", it still does not work.

    Anybody figure out a solution yet?
  9. DBNissan

    DBNissan Well-Known Member

    What software version do you have now?
  10. Zehrfox

    Zehrfox Member

    Quick Settings 1.9.8

    The only one I could find that wasn't on the Android Market, so I could copy to SD card.

    Would a newer version work?

    Did I miss a step?

    Am I the only one who is having trouble working around this new update?
  11. DBNissan

    DBNissan Well-Known Member

    I have 1.9.8 p2

    I was asking about your phone's software version since you mentioned you heard it reboot. Thinking maybe there was an update push from VM.
  12. Zehrfox

    Zehrfox Member

    Not sure which information you wanted? here is the info on my phone.

    Android version - 2.2.1
    Kernel - 2.6.32.9
    SW Version - VM670ZV4
    Build Number - FRG83
  13. DBNissan

    DBNissan Well-Known Member


    that's the info I was looking for. I wanted to see if your SW Version was different. But it is the same as I have. so, the Quick settings app should work.

    I would recommend uninstalling it then downloading it through the phone from the android market.
  14. tater_salad

    tater_salad Well-Known Member

    are you saying that you couldn't connect to your wifi network with your phone after you used the Wifi for the hotspot? It's possible that you weren't using wifi all along....
    I've had a the LGOV stick at obtaining IP when the password for my router was entered incorrectly.. once I re-entered the correct password it connected fine.
  15. DBNissan

    DBNissan Well-Known Member


    Wifi hotspot is the other way around. We are talking about using our phones as a wireless router so our laptops can connect to the internet via the 3G connection.
  16. lizm

    lizm Well-Known Member

    I tried mine today which has worked in the past and suddenly was asked for a password. I don't recall setting one up...if i did, where would it be?
  17. DBNissan

    DBNissan Well-Known Member

    Turn on the Wi-Fi hotspot, press on the words Wi-Fi hotspot then press on Configure Wi-Fi hotspot
  18. lizm

    lizm Well-Known Member

    Thanks :)
  19. greg4android

    greg4android Well-Known Member

    I'm using mine now . . . Working great!

    Not the fastest, but 880kbps is enough to surf webpages!

    [​IMG]
  20. lizm

    lizm Well-Known Member

    Last night, late, our power went out. I was watching Dexter on my laptop, streaming. The laptop had battery juice but my wifi went down with the power.

    I put on the phone's wifi hotspot, let the show load up/buffer awhile, and got to finish watching Dexter before bed :)
  21. XDreadX01

    XDreadX01 New Member

    I have a problem. My acer Iconia tablet wi not connect to my phone hotspot . I type the password in and It says obtaining ip address for a time then it says avoided poor internet connection. What in the world does that mean.
  22. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Try turning off phone. Delete network from tablet and turn tablet off.
    Turn phone on, then setup hotspot with open security. Turn tablet on and connect to hotspot.
    If good, turn everything off (delete network on tablet), then setup hotspot with your normal security. If good, great.
  23. 350X

    350X Well-Known Member

    Try Foxfi.com

Share This Page