Wifi to 3G Issue.....Support

Last Updated:

  1. DPDAndroid

    DPDAndroid Well-Known Member This Topic's Starter

    Apr 10, 2010
    Likes Received:
    Since the 2.2 update if I leave Wifi enabled and leave the connection area, 3G does not turn back on and I'm left with no data connection at all. Only way I can fix it is to restart the phone.

    Anyone have a fix?

  2. Big Calhoun

    Big Calhoun Well-Known Member

    Feb 23, 2010
    Likes Received:
    I couldn't replicate this. I activated my WiFi and went out to the store. As soon as I got out of range, the WiFi disconnected and the 3G service came right back on. Tested the browsing and everything was fine. When I got back home, the WiFi reconnected, so I turned off my router. Wifi went off and 3G came right back on.

    I would hazard to guess that the root cause is some kind of software conflict or a resource issue (low memory, perhaps).

    I'll save you a call to Tech Support:

    - *228 and option 2 to make sure you have the latest PRL
    - Try turning the radio off and then back on (just throw it in and out of airplane mode)
    - You can also try disabling and reenabling the mobile network connection (hold the power button down and turn the mobile network connection setting off, then on again).
    - If all of that fails, try placing the device in safe mode to see if you're still having the same issue. If so, then the device is most likely faulty. If not, then it's a software conflict and/or resource issue.
  3. crackers8199

    crackers8199 Well-Known Member

    Apr 12, 2010
    Likes Received:
    this happened to me once (on virtuous 2.7)...airplane mode on and then off really fast fixed it.

Share This Page