Wifi unable to find any networks now?


Last Updated:

  1. kivitarus

    kivitarus Member

    Ahh! I recently just reflashed reduc 1.2 and flashed the ManU 1.4 kernal, and now it seems that my wifi cannot even find any networks anymore! (wifi sleep policy set to never already) any ideas please? thanks in advance!

    .. hmm somehow, removing the 3g watch dog notification allowed me to scan for it and access it, but my wifi keeps on dropping now, even when the signal is high, could it possibly be that i require a radio update, just out of curiousity, is the radio and the RIL the same thing? thanks!

    .. ok its gone again after a reboot, and i've been looking everywhere for a solution for the past 2 hours, and still unable to find anything helpful, apparently changing the wpa_supplicant.conf file extension to .bak has worked for some, but im unable to find that file anywhere, (/data/misc/wifi/.. (cant even find /data)). I just tried a factory reset, and it hasn't changed anything, still unable to find any networks, and the previous network that has been saved, is now apparently out of range... any ideas please? thanks

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    What radio are you on?

    No radio and ril are not the same. You should not have to mess with the ril.
  3. InfernalByte

    InfernalByte Well-Known Member

    It's a ril problem, first flash the ManU2 kernel to see if its any better, you may need a full wipe and reflash a fresh rom to fix this.

    EDIT: There is also an old Christmas Vork kernel with a wifi fix in the drop box that might work.
  4. kivitarus

    kivitarus Member

    My radio version is 32.41.00.32U_4.08.00.09

    Ah right ok, so first i should flash the ManU kernel, then update my RIL? and then reflash the rom ? or is there no specific order for this?

    edit: my RIL version is currently at HTC-RIL 1.6.2062G. thanks!
  5. SUroot

    SUroot Well-Known Member Developer

    For the record I don't think its RIL. Could be wrong.

    That radio is pretty old though. Try a RIL first by all means but I reckon a newer radio will fix this. The RIL comes with the Rom so I doubt its that.
    kivitarus likes this.
  6. kivitarus

    kivitarus Member

    Ok cheers, i'll give it a quick go and get back. Do i need to flash anything in a specific order? Or should i just factory wipe/cache, flash rom, flash kernal, and then flash radio?
    Just out of curiosity though, whats a RIL for? i'm still not able to grasp what it actually is. thanks
  7. Hadron

    Hadron Well-Known Member Contributor

    Actually I'd update the radio - that's an Eclair radio version. You want one that's "_5" rather than "_4".

    The XDA Radios Thread is the place to get them from. The mirror site linked in the first post has md5 codes to check the download is good, or else you can also find these at AdamG's download site, Index of /radios, which is where the links in the thread point to.

    If you've not flashed a radio before, a few words of warning: if a radio update goes wrong you can brick the phone irrecoverably, so you should approach it carefully:

    Do check the md5 code to ensure you have a good download.

    Make sure the phone is well charged, as you don't want to interrupt the installation part way through (it doesn't take long, but you don't want to take chances).

    If you are S-On, or using a stock hboot/mdt, you can install the radio by flashing the zip. Copy to sd card and flash from recovery, same as any other zip. Note: the flashing is quick, but it will then install when you reboot. During the install it will reboot the phone a couple of times, so don't panic, and don't assume you are in a boot loop and pull the battery. Just leave it alone until it eventually boots normally.

    If you are using a custom hboot or mtd with a small cache partition (less than about 30 MB) you must not try to flash the zip. In this case, unzip it and you will find a radio.img file in there. You can then flash that via fastboot from your computer (laptop preferred, because as someone commented recently if you have a power cut during the minute or so this takes the laptop will act as a ups). If you are not familiar with this, read the guides and ask first if there is anything you are unsure of.

    Of course you can use fastboot even if your cache is large enough to install from recovery.
  8. Hadron

    Hadron Well-Known Member Contributor

    That order is fine. ROM must come before kernel, as the ROM will overwrite it otherwise. Do the radio last (see below).

    Installing a radio from recovery consists, as I said above, of 2 stages: first the file is loaded, then the actual install occurs when you reboot. So I would really not recommend doing anything inbetween these two stages: flash the radio zip, then reboot from the recovery menu. Don't do anything that might even potentially interfere with a radio installation.

    The RIL is an interface, the simplest analogy being to a driver in Windows. It's one of those things you mostly notice if it's incompatible with the ROM (because things stop working), and not much otherwise. If you do flash one, it has to be done after the ROM.
  9. kivitarus

    kivitarus Member

    Thanks for all the replies, i've just wiped everything, flashed with 1.2 Redux, then ManU1.4 kernal, and then the latest radio.img.. Still with no avail.. still unable to scan for any networks with the wifi.. Hmm I think its the kernal for some reason.. previously I have tried the Redux rom, but never had changed the kernal at the time, and everything worked fine, so now im completely unsure what to do next.. Any ideas please?
  10. Hadron

    Hadron Well-Known Member Contributor

    Reflash the ROM - that will replace the kernel with the ROM's included one.

    If that doesn't work, you could try the Vork kernel InfernalByte mentioned.
  11. kivitarus

    kivitarus Member

    Hmm ok thanks, so is there no chance I can get the manu1.4 kernal then? As I'm hoping to get as much battery life out of my phone as possible, or does the cork kernal work similarly?
  12. Hadron

    Hadron Well-Known Member Contributor

    Redux is pretty good even without the ManU kernel. Or you could try ManU 2.0 - perhaps marginally more battery usage but also a little snappier in my experience. Vork kernels were also good (I use the past tense because the developer no longer has a Desire). If you get a choice of kernels with which the WiFi works then you can see which one gives best battery life, but if you find that one, but only one, fixes it then that's the one to try.

    To be honest we have a bit of a puzzle here, because many people in this forum, myself included, have used Redux 1.2 with ManU 1.4 and no WiFi problems. In fact I still have a nandroid of exactly that setup on this laptop. Not all devices are identical, but I can't help suspect there is some other factor here. Have you tried WiFi from a completely clean install, i.e. wipe, don't restore anything (no apps, certainly no settings) and see whether the WiFi works then?
    kivitarus likes this.
  13. InfernalByte

    InfernalByte Well-Known Member

    As things don't work, its best to test your hardware (phone) with the things you do know that work.

    Flash a rom, JUST A ROM. See if that works, go from there.

    EDIT: Sorry Hadron I hadn't read your post through!
    kivitarus likes this.
  14. kivitarus

    kivitarus Member

    Thats what I thought, since so many people have the same rom and kernal, I don't see why my device is having so much trouble with it, yes, i've tried all that, but still didn't work.
    However.. When I got back from work today, my wifi suddenly switched itself on (possibly by juicedefender) and has connected ! hazzahh! So yeah, my wifi is now working thanks, but im afraid of ever rebooting it! Just incase it doesn't work again.. what im thinking is, this may possibly be due to previous settings by some applications, (seeing as juicedefender was able to turn my wifi on..) dunno if that makes sense, but i did do a full data wipe, and a cache wipe in recovery mode, and a factory reset beforehand, so I can't see why any settings would still be around. Does this wipe completely remove all settings i have previously used, and of the internal storage? Or would i have to perform a dalvik cache wipe (which btw I have no idea what its for, just know that its around) .. Anyhow, thanks a lot for all the help from everyone.. Hopefully wifi stays strong even after a reboot sometime

    EDIT: ah.. worst fear came.. juice defender is set to disabling wifi when screen is turned off, so when i turned it back on, juicedefender did not connect with the wifi, so i turned it off and unlocked it again, hoping it would reconnect! well it worked, but I guess from now on, i'll just have to hope by chance the wifi wont mess up, doubt i'll be able to connect to any other networks though, which is a shame..
  15. bobsuruncle

    bobsuruncle Member

    Hi all,

    Finally got the courage and rooted my HTC Desire GSM A8181 over the weekend, from the official HTC Gingerbread 2.3.3 RUU using Revolutionary.io. For my first custom ROM wanted something "simple" and went with Redux 1.2 (build no. GRI54).

    My problem: wifi signal is now very weak - it can't even hold a signal when i walk into the next room at home.

    Forums say it could be:

    (1) a kernal issue (now running 2.6.37.4-Redux-CFC-SVS vick@vick-desktop #13; previously 2.6.35.10-g3f43272 htc-kernel@and 18-2#1).

    (2) a radio issue (i checked & noticed the baseband version had changed from 32.56.00.32U_5.17.05.23 to 32.56.00.32H_5.17.05.23) i.e. from "U" to "H". Don't know what that means but could it be the reason for the drop in performance in wifi connectivity?

    Any thoughts and help would be very much appreciated. Thanks in advance.

    Regards
  16. GrenW

    GrenW Well-Known Member

    The rom should not have touched your radio. I'm not sure why the letter changed but have heard it happen before. All the important digits though are the same.

    Why not try Redux 2. Its very stable and a few months further down the line in development terms - 1.2 is around 6 months old now. The stock kernel it comes with should be fine.
  17. Rastaman-FB

    Rastaman-FB Well-Known Member

    looks like redux might be using a different ril
  18. madhatter1689

    madhatter1689 Well-Known Member

    There was a file flying around for new drivers and a new ril which I just flashed and the signal appears to be much stronger. Not sure if there is a link to the thread where I got this from. Anyone know it?

    Edit: Not sure if this will work but you can get the file from here
    http://dl.dropbox.com/u/10959933/Redux Stuff/Various/New Drivers and RIL from laked 2.3.3.zip

    Some folk had problems with 3g after flashing this but then sorted out by flashing another ril which you can find in the useful tools link in my signature.
  19. GrenW

    GrenW Well-Known Member

    Just checked and looks like mine has gone from U to H (assume through Redux flashing). Have noticed absolutely no change in wifi or mobile signal.

    I'm still using the radio I got when I did my OTA update of FroYo through Vodafone over a year ago.
  20. bobsuruncle

    bobsuruncle Member

    SUroot says "It shows as U on Sense roms and H on AOSP roms. Its still the same radio."

    Maybe I'll flash a new kernel to see what happens. Other than the wifi issue, am very happy with having rooted the Desire and running Redux. Would like to ungrade to Redux 2.0 when it becomes a stable version.

    Thanks everyone for your replies.
  21. shauny13

    shauny13 Well-Known Member

    Ive been running redux 2.0 for over a month before yesterday and it's very stable.
  22. GrenW

    GrenW Well-Known Member

    Yep, very stable. Also no point in waiting as the dev has called it a day, so unless anyone else picks it up it won't get any more stable.

Share This Page