Wifi won't connect when I move from home to work and vice-versaSupport

Last Updated:

  1. sedamo

    sedamo New Member

    Droid Razr Maxx HD

    I have no problem connecting to the internet when at home or at work; HOWEVER, whenever I leave one to go to the other, my phone will not connect to my new location. For example, I have a fine wifi connection at work. I get in my car and go home. My phone picks up other networks in my neighborhood but will not connect to my home network (and sometimes it won't even see my home network). I then have to reboot my phone. After reboot, it picks up my home network.

    I have the same problem going from home to work. Any thoughts or known fixes?

  2. IHateMyTreo

    IHateMyTreo Well-Known Member

    A few apps that help me with that issue:

    REGPON - forces wifi on. (You can also try out Keep Wifi Alive - does the same thing).

    Best Wifi - picks the best signal when faced with a choice.
  3. hansangb

    hansangb Well-Known Member

    that's very odd. You might start by erasing the network setup and creating a new one.
  4. sedamo

    sedamo New Member

    I agree, hansangb. I can't figure it out. TriedREGPON and Best Wifi -- didn't help in any way. I have tried erasing the network setup. Doesn't work. After re-boot, no problem. But I have to re-boot every single time I go from home to the office and back. Really irritating.
  5. IHateMyTreo

    IHateMyTreo Well-Known Member

    Here's another possibility. If the routers broadcast on dual bands, and assuming you can control your workplace settings, disable the higher band typically used for media. Stick with the 2.4GHz band. Also, check the broadcast channels and see if there are other competing signals - maybe switch to an unused channel.
  6. hansangb

    hansangb Well-Known Member

    As a temp work around, try putting it in to and out of plane mode. Or just turn off the Wifi in settings. Also, when you deleted the profile, I wonder if google's backup is causing you issues. Maye you have to sync the profile after deleting it to make sure google's backup isn't causing issues. Grasping at straws here....
    sedamo likes this.
  7. dhbuckley

    dhbuckley Well-Known Member

    I use Smart WiFi Toggler. Something tells me that it might fix your problem. I love it because it prevents attempts to connect to unknown hotspots. Turns off WiFi when leaving known spot, on when arrive known spot. Let us know how it works for you.

Share This Page