Wifi won't reconnect automatically when in range or by enabling wifi?Support


Last Updated:

  1. rpeters83

    rpeters83 Active Member This Topic's Starter

    Joined:
    May 12, 2010
    Messages:
    25
    Likes Received:
    4
    It's done this twice now (before and after factory reset). 2.1 OTA, not rooted.

    Whenever I turn on the wifi, or I become in range of my WPA2 network, it doesn't always connect. I say "always" because it seems to be random. If I toggle wifi on or off, it doesn't always connect. Sometimes it connects after 30+ seconds. Every other device connects just fine.

    The only sure way to get it to connect is to force it to rescan, usually by going to Settings and displaying all SSIDs in range. THEN it connects, always and immediately.

    The even sillier thing is, it will alert me of open networks, but never connect to my own saved network.

    Any idea? This is annoying. Thanks.
     

    Advertisement
  2. dallasreno

    dallasreno New Member

    Joined:
    May 15, 2010
    Messages:
    1
    Likes Received:
    0
    I have the same problem. I found that if I enable mobile data network that the wifi connects every time.

    dr
     
  3. DIMiller

    DIMiller New Member

    Joined:
    Sep 9, 2010
    Messages:
    4
    Likes Received:
    0
    Dallas, can you be more specific for us newbies (what steps to get to "enable mobile data network" in 2.1)?

    Thanks
     
  4. Podivin

    Podivin VIP Member VIP Member

    Joined:
    Nov 29, 2009
    Messages:
    3,679
    Likes Received:
    881
    Mine sometimes does the same thing. I've found that just by going to the wi-fi settings screen that it will connect like it should. I don't have to DO anything on that screen, just go there - so I put a shortcut on my home screen that takes me right to the wi-fi screen.
     
  5. R1ggs

    R1ggs New Member

    Joined:
    Mar 19, 2012
    Messages:
    3
    Likes Received:
    0
    I've noticed there is nothing specific to the model of phone with this issue. I bought my Droid phone (LG - Optimus) 4 days ago. Everything seems to bee just great.

    Except the Wifi issue. If my phone goes into Standby upon resume I am told I don't not have an internet connection. It won't use the data on my mobile network it just tells me I have no internet connection but the wifi status states it is connected to my router although the status icon is not green. It is white. Turning wifi off then back on solves the problem 99.9% of the time. Except once when it refused to turn itself back on.

    I have mobile data enabled, use of Wifi networks enabled. I have installed several apps and uninstalled several apps. Doesn't matter though because the Wifi still fails.

    I would assume it was the 2wire router I am using but if my phone cannot detect an internet connection then why does it say it's connected to my router and why won't it just use the mobile network? There aren't many answers to this issue and lest I restore the phone to factory state I am fine with turning the wifi off and on again. The phone is an LG. I have seen other threads with different phones having this issue so I suspect it is related directly to the Droid OS software. It's a real pain in the behind. This means I have to shut the wifi off to even attempt to have the phone use the mobile network for internet. Which is never as fast. Has anyone seen a fix for this out of the 10 or so threads that are located on these forums that discuss the same issues?
     
  6. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,620
    Likes Received:
    1,896
    Just a guess - since you have WiFi sleeping when the phone is powered down, when you turn on the phone reestablishes a connection to the router, but the router has not assigned a DHCP address and DNS server info to the phone.

    In settings->wireless->WiFi settings (I'm not sure what the exact path to ge t to their is on your phone), press menu->advanced settings and set the Wi-Fi sleep mode policy to "never".

    The WiFi (or mobile network) status icon changes color from white to (in your case) green when the phone has established an authenticated connection to Google services (for Play Store connectivity, sync services, etc.) Since WiFi is faster than 3G and uses less power, your phone is probably better off with WiFi sleep policy set to never.

    See if that helps.
     

Share This Page

Loading...