Wifi Won't Stay On All the TimeSupport


  1. Rlad78

    Rlad78 Member

    Newly purchased, 2.1 non-rooted.

    So I have my Captivate connected to my home wifi, but after 30min or so, while I'm not using it, it switches back to 3G data transfer. Now this isn't really that bad since it switches back to wifi literally 3 seconds after I unlock it, but I'm still worried that it could be syncing my apps and updating while on 3G data transfer (I have a 200MB/month plan, so I try to use wifi when I can).

    Anyone know a fix for this that DOES NOT involve flashing to 2.2 (I know there's a button for exactly this thing, but I really don't want to root my phone. Rooted my LG Vu awhile back and it became a real hassle to maintain)? I have an app called Widgetsiod that can disable 3G data transfer, but it only works if you turn it off while 3G data transfer is on (if it goes into wifi mode and then comes back out of it, 3G will still be on).

    tl;dr: Phone loses wifi after 30min of non-use.

    Advertisement
    :
  2. CrimsonPride

    CrimsonPride Well-Known Member

    did you put wifi on never sleep? go to settings > wireless networks > wifi settings > menu button > advanced > wifi sleep policy > never
  3. Rlad78

    Rlad78 Member

    Um, I don't think I have that option...

    Wireless and Network -> Wi-Fi Settings brings be to this:
    (x) means checkmark
    ( ) means no checkmark

    ---------------
    Wi-Fi Settings
    ---------------
    Wi-Fi (x)
    -Connected to [my network]

    Network Notification (x)
    -Notify me when an open network is available

    WPS button connection

    ----------------
    Wi-Fi networks
    ----------------
    [My Network] (sync symbol) (secure symbol)
    -Connected

    [other networks]

    Add Wi-Fi network
  4. CrimsonPride

    CrimsonPride Well-Known Member

    when you get to the wifi settings menu press the menu button, the one on the far left of the bottom of the phone and a menu should pop up and choose advanced
    EarlyMon and Rlad78 like this.
  5. Rlad78

    Rlad78 Member

    AAAAHHHHHH! I keep forgetting about that button!

    Thanks for the help :D
  6. sremick

    sremick Well-Known Member

  7. elnator

    elnator Member

    I had the same problem with my Samsung Moment. Even having 'never sleep' turned on didn't help. I eventually had to change the phone from using DHCP to using a static IP even though my router does have a DHCP server built in and several computers on my network are uaing dhcp just fine via wifi. Was very odd. Once I set the phone up with a static IP everything worked fine.

    Interestingly the phone works fine with DHCP if it's on an unsecured network. My home network,however is WPA2 (AES) encrypted. No way am I turning that off either.

    What's even more weird about this is it's inconsistent. On my phone I have to use a static IP for some reason... but my wife's phone... same phone, same build, same kernel, same firmware, same rom.... works with DHCP just fine.
  8. sdneidich

    sdneidich New Member

    I am having the same problem on my SGH-i777 AT&T Samsung Galaxy S II. Anyone got any thoughts?
Loading...

Share This Page