WIFI won't turn on (phone has no MAC)Support


Last Updated:

  1. ncmilder

    ncmilder New Member

    This morning I went to turn on wifi and connect to my home network. I pressed the button to turn the wireless radio on and it said "turning on" for 10 seconds or so and then immediately turned off. It was working fine yesterday and I have made no changes since then. Also, within the wireless settings, my MAC address appears as 00:00:00:00:00:00. This is some BS. Oh, and I've done a bit of searching already and tried the typical troubleshooting steps. Nothing.

    Advertisement
  2. imnotmikal

    imnotmikal Well-Known Member Developer

    Have you tried a factory reset?

    Obviously you'll lose all your apps/data, but it may fix the problem.
  3. ncmilder

    ncmilder New Member

    No, I haven't factory reset. Barely had it for 2 days, so you can see why I don't think that would be a longterm solution. I'll try it though.
  4. stargazertony

    stargazertony Well-Known Member

    Both my son and me are having the same problem. Got our Droid 3's yesterday and tried to connect to our home WIFI (other devices connect perfectly). Get an excellent signal but the phones authenticates, scans, connects and then immediately disconnects. The message under Wi-Fi networks in Wi-Fi settings is "Disabled, secured with WPA/WPA2 PSK". The phones keep on scanning but not connecting. A forced reconnect does the same thins. Does this on both phones. Tried deleting and resetting up the network again the get the same results. Did a factory reset but got the same result with wi-fi. Any suggestions?

    Where did you see the mac address and other network settings?
  5. ekyle

    ekyle Well-Known Member

    Weird. I have two access points in my house, one WEP the other WPA2. Both connect just fine over WiFi.
  6. carrotguy

    carrotguy New Member

    Ok guys, I just got my Verizon Droid 3 today, specifically because I was tired of my og Droid 1, glitching out on me having to reset airplane mode all the time to fix data.

    Well, the Droid 3 gives me the same problem as you guys, but with just the WiFi.

    Im a little pissed.

    Before I went into the store I wanted to buy the Sony Play, even tho I want use the Play part, because of user reviews.. but I talked myself into the 8MP and the Dual Core...

    Big mistake.

    The play has much better battery life, people are happier, and instead of dual core, has single core and gpu,, (prob smarter,, graphics process diff,, and helps battery)

    And the battery life on the droid 3 is a joke.. just a joke.

    I dont care anymore about my wifi problem,, the fact that I had so many glitches with the Droid 1, and now this seemingly recurrent one in the Droid 3, and with the seeming failure of the Xoom to deliver expectations,, leads me to believe that while Motorola stays up front, they dont take time for the details and Im getting tired of it.

    Tomorrow I go trade in for the Play,, and will probably have to pay the $35 restock fee even tho my phone is defective, because I am switching.
    breathe

    whew

    I am going to get what may not be all top of the line but what seems to keep its peeps happy.

    Thanks guys for confirming this bug for me, and for listening to me vent!!!
    It is appreciated!

    cg
  7. carrotguy

    carrotguy New Member

    I have this same problem. And I agree, a factory reset does not instill much confidence in me of being a long term solution :(
  8. stargazertony

    stargazertony Well-Known Member

    I don't think it's the phone and therefore a factory reset won't help. I took my Droid 3 to several restaurants and other places yesterday and it connected to their WI-FI's perfectly and without issue. This phone is astonishingly fast on WI-FI. I have an Ipod touch which I connect wirelessly and thought it was fast however the, Droid 3 blows it away. Web pages just appear on the screen instead of loading slowly. I think my problem might be my home wireless router which is several years old and of moderate quality. Think I will invest in a more modern, better quality router & see what happens.
  9. ekyle

    ekyle Well-Known Member

    Good find. Maybe the radio isn't compatible with certain routers. Maybe you could even try updating the firmware on your existing router to see if that resolves the issue.
  10. stargazertony

    stargazertony Well-Known Member

    I've fixed my problem and now can access wi-fi on the Droid 3 at home. The problem was an unfortunate password malfunction. Case in important.
  11. Onsted

    Onsted New Member

    Had the same problem after installating my "favorite" apps on my D3. The wifi would search, connect and promptly DISconnect. I did a factory reset and it worked flawlessly. Began downloading and installing the apps again, one at a time, then testing the wifi. When I installed the "Dex" phone book app, the wifi again disabled with the same symptoms.

    Odd part was, wifi capability didn't return when I uninstalled the app - so, another factory reset and app download session followed, but this time using an alternate phone book app. The phone's wifi works flawlessly.

    Evidently, SOME apps' install routines misbehave enough to somehow modify a configuration somewhere that an uninstall won't cure.
  12. imnotmikal

    imnotmikal Well-Known Member Developer

    Battery life isn't as bad as you're making it seem, really.
    There's a thread here with tips to increase battery life, have you checked that out yet?

Share This Page