WiFi (WPA + TKIP encryption) disabled by AT&T Android 2.2 (Samsung Captivate)


  1. ConsuDave

    ConsuDave Member

    I installed the very recently released Android 2.2 (froyo) update for AT&T/Samsung Captivate customers, and thought the WiFi signal strength indicator was gone, but it seems that the problem is that my home router is an old one, a Linksys, set to WPA + TKIP encryption.

    There

    Advertisement
  2. kaepos

    kaepos Active Member

    Both TKIP and PSK use essentially the same WPA standard, just different ways of encrypting the same thing (hence WPA-PSK TKIP and WPA2-PSK AES).

    PSK stands for Pre-Shared Key and depends on a passphrase to connect devices. TKIP is just the encryption protocol that the has been included in the WPA standard.

    As far as your question, your device (the Captivate) is looking for both WPA/WPA2 PSK protocols.

    I would recommend switching your router to WPA2 PSK AES anyway as it has shown to be more secure than the standard WPA-PSK TKIP.

    Your wife might gripe, but if she's also using a cappy, then it won't matter since it's looking for both protocols - just use the same passphrase. For any other device, it takes a minute to change the settings and get everything up and running.

    All that being said, your router settings might not have anything to do with the wifi problem. Before I started flashing ROMs, I had to constantly switch my WiFi off and then back on before it connected.

    Hope that helps and wasn't too confusing.
  3. ConsuDave

    ConsuDave Member

    Thanks. What's a "cappy"? A Captivate?

    Wife uses a Blackberry and an IBM laptop and a Roku box and an Apple AirPort and an iPad and who knows what else . . .

    What's "Flashing ROMs"?

    The wireless router settings create the problem. When I (accidentally) reset the router's security to none, the Captivate connected no problem. But wife's devices wouldn't connect automatically since that changed the router name (SSID) as well.

    Is there a way to revert to Android 2.1 without losing my apps/settings/data?


    Seriously, why won't the Captivate with froyo Android 2.2 connect with WPA-PSK TKIP?
    :(
  4. rubiconjp

    rubiconjp Well-Known Member

    PSK is the cheapo passphrase mechanism, versus the enterprise RADIUS server for session passphrase in use at big companies.

    You should upgrade from TKIP anyway. TKIP is basically WEP, but with re-keying capability to defeat statistical deciphering of your key. It usually re-keys every few thousands packets or so. TKIP can now be hacked.

    AES is much more secure and much faster as its algorithm can be implemented in hardware.

    I have an old router with WPA/TKIP. I will boot it up tonite and see if my 2.2 Cappy can use its wireless network.
  5. ConsuDave

    ConsuDave Member

    Hey rubiconjp - how did it go? :confused:
  6. rubiconjp

    rubiconjp Well-Known Member

    Sorry haven't tried it yet... for sure tonite! ;)
  7. rubiconjp

    rubiconjp Well-Known Member

    OK I am posting this thru my 2nd AP, which uses TKIP. Maybe you'll need to hard reset your Captivate.
  8. mab91862

    mab91862 Member

    I had a similar problem and I did some research. Looks like there are many issues with WiFi and the Captivate, in particular after the 2.2 upgrade.

    What fixed my problem was to run "FXR WiFi fix and rescue" free on the market.

    Also, another fix is to start up "Allshare", but this would only work until I went out of range or turned off Wifi, then I had to re-start it again when I wanted WiFi again.

    Good Luck!
    amari9419 likes this.
  9. CamaroZ28c

    CamaroZ28c Well-Known Member

    Ever since updating to 2.2, 7 out of 10 times, my phone will just show "scanning" and never jump on the known, saved wifi profiles when I get within range. I have tried the FXR program and, unfortunately, it didn't help at all.
  10. digicurt

    digicurt New Member

    I just got my captivate a week or so ago so it was already updated and i was having the same problem i could connect for one day but the next day i just got "scanning" or "obtaining ip for" but never would connect. my solution and so far it seems to be working is i set a static ip for my phone and it connected immediately i turned the wifi off then back on and connected again no problem. i know this is not a fix for open networks like at school or work {really have not tried at those locations yet) but for home it works great.
    well i went to work this morning turned off the static ip and since they have a network open to the public (also have a secured one for work purposes) it connected right away used most of the day with no problems at all, then i came home and went into the setting and turned the static ip back on and connected to my home network right away so for me that seems like an acceptable solution others may not want to do this but it seems to work.
  11. rubiconjp

    rubiconjp Well-Known Member

    OK connected and use wifi at another residence with TKIP - no problem. I upgraded my phone (old unit with build date 1007) with stock 2.2 and did a factory reset.

    For sure TKIP works on stock 2.2.
  12. digicurt

    digicurt New Member

    yeah i fixed mine with a factory reset also but the same thing happened again in a day or two keep us posted to see if it continues to work as i would rather not have to have a static ip.
  13. ConsuDave

    ConsuDave Member

    Thanks, everybody. I set up a 2nd wireless router, connected via ethernet to the first one. the 2nd one uses WPA2 PSK, and that works fine. the only hassle was i had to manually enter, on my desktop computer, which is now ethernet-connected to the 2nd router, the IP address of the wireless printer on the first router's network (I haven't tackled printing from Android yet).

    I fear running into the WPA (not WPA2) problem on other routers, but am ok at home now. Of course, not everybody has a 2nd router lying around (I moved into a technophile's house, and she didn't need my router.).
  14. sinjin

    sinjin Active Member

    I had this too. It was actually the straw that broke the camels back for me. Ended up rooting and changed to a custom ROM. Could not be more happy. Enjoying Paragon RC6.
  15. rubiconjp

    rubiconjp Well-Known Member

    since she's a technophile, she should really move to AES instead of using TKIP for 2 reasons: AES is more secure AND much faster (way less overhead) when compared to TKIP and WEP.
  16. jkteck

    jkteck New Member

    My wife and I got Refurbished Captivate phones from ATT,
  17. ConsuDave

    ConsuDave Member

    Thanks again everybody. The 2nd wireless router I set up is a NETGEAR. :)

Share This Page