1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

Wildfire S random touch glitchesSupport


Last Updated:

  1. crsklr

    crsklr Member

    (Specs below)
    Can't seem to find any other threads like this, so here goes...

    My Wildfire now has a glitching touchscreen. As in, it will randomly touch 2-3 phantom/ghost touches anywhere on the screen (including capacitive touch buttons below the LCD) without any predictability at a single moment.
    It happened immediately after I unlocked/rooted.

    If I pull my battery and boot into HBOOT where the recovery menus are, the capacitive touch buttons below the screen are perfectly accurate, no glitches, like brand new. Not a very good testing place, but that tells me it's not a hardware issue...right?
    Sometimes after I load up to the lockscreen, it still has no ghost touches (for 2-3 minutes). But after that, it goes back to glitching.

    Something else I noticed: the screen also seems to "freeze" (the touch input does not accept touches) for about 1.5 seconds before the spazing-out/glitching/ghost-touching.

    Specs:
    Wildfire S (HTC-PG762)
    MetroPCS
    Android Ver: 2.3.4
    Software Number: 1.05.1550.00
    Kernel Ver: 2.6.35.10-g6a3d395
    Unlocked/Root via SimpleGoldCard
    ROM managed by ClockworkRomManager
    Stock MetroPCS rom by insink71
    Other roms tried: (and glitches were still there)
    Metropcs Stock new HBOOT by insink71
    Metropcs Stock old HBOOT by insink71
    SuperWipe (clears all rom/internal memory)
    Team MarvelUSc Bugless 2.3.4
    JMZ WildFireV2.0

    Will post more details if requested.

    Question1: Is the kernel updated when a new ROM is installed?
    Question2: Does the kernel determine if a device is rooted/unlocked?
    Question3: Does the kernel handle touchscreen inputs?
    Question4: Could the kernel have anything to do with this problem?

    Advertisement
  2. CafeKampuchia

    CafeKampuchia Well-Known Member

    Did you do a nandroid backup before flashing the custom ROM? If so, restore it now and see what happens.
  3. Caro332

    Caro332 Well-Known Member

    I would suggest the same thing...Restore a nandroid backup and see if the glitches are still there.
  4. crsklr

    crsklr Member

    Yes I still have it, and I just restored to it last night. Still glitching.

    Q1: What is modified when rooting/unlocking?
    Q2: What does the Nandroid backup utility actually backup? Just the internal memory partition?
  5. crsklr

    crsklr Member

    Bump, anyone have a clue? This is getting unbearable now.

    I'm going to retry the rooting/unlocking procedure again to see if there is any difference.
  6. filipedgb

    filipedgb New Member

    After a deep search on google about this problem seems like I have finally found someone who has this glitch too. My htc wildfire is like 7 months now


    The glitch is exactly as you described it, the random ghost clicks on the touch screen (mine is not that random, seems like it has a preference for clicking the search button, although it also clicks other things on the screen) . Then crashes, like touchscreen not responding, just as you said.

    At least I'm alone in the world with this problem!

    I have no idea what to do anymore, if the phone decides to glitch I have no option but just wait, and this just can't keep happening. PLEASE answer me if you were able to solve your problem, I'm desperating


    Edit: This glitch has stopped for a while in the past, but then it came back again. I'm talking about like 1 week working perfectly well, making me think that it was some application messing up the phone, but it is back now. And I didn't install anything since that "good week". Wth is going on?! This is completely weird
  7. crsklr

    crsklr Member

    About the same time length for me too. I haven't paid any attention to fixing this issue since my last post in this thread. Most of my searching has yielded no results due to bad descriptions, bad english (ergo, bad descriptions), or wrong phones. So my search continues.

    For a short while, I had this preference as well. But now, mine has moved over to home and back. Now that I think of it, it hardly ever presses menu.
    As far as the "crashing" portion, I think it would be better described as "frozen". I noticed that with some of these "freezes" it sequentially cues any further touches. Then, when it decides to respond 2 seconds later, it will carry out my commands, but then add its own random touches on after mine. For example, I may be typing a msg, and halfway through a word it will freeze, but I will continue to type each letter without the visual feedback. When it unfreezes, it will quickly type the rest of what I typed correctly, but then add garbage touches on top.
    Just a note.

    I few days ago, I was looking at taking out a small portion of my savings to get a galaxyS2, but then my wildfire stopped acting up for about a day. Of course, it kicked back in the next morning.

    Same here. I had about 1 week of near-perfect usage, then it decided to slowly come back to a steady standard glitching pace.
    Recently, to resolve some REALLY bad glitching (like, can't even slide to unlock the phone for 2-3 minutes) I would simply restart. (soft-restart, not a hard-restart where you pull the battery out and hit power) It slowly goes back to freezing after a short while. I recommend you trying this out and telling me if it works for you.


    Now, here are my speculations. Again, these are just what I hypothesize are the issues.
    For me, it does NOT seem to respond differently to pressure sensitivity. I initially thought it responded differently to soft/light touches or harder touches, but it doesn't seem to matter.
    For me, it DOES seem to respond to temperature. When it's hot, it seems more erratic. Several times I've taken my case off and let it sit on a cold table surface for a while.
    For me, it DOES seem to respond to "casing pressure". That is, pressure of any cases on it. I've taken the protective case off, as well as the battery case off and it seems to be a little more chilled out immediately. I think this is tied with temperature, as well.
    For me, it DOES respond to charging. Almost instantly. When I plug it in, it seems to immediately act up. So much, that I must unplug it before using the phone for any touch screen related tasks. I believe this combined with temperature is a big problem.


    I have a few questions for you.
    #1: IS IT ROOTED??? Most important question of them all.
    #2: When did yours start glitching? I dont exactly remember when mine began glitching. I purchased mine in January, I believe. I rooted, and it seems to have started flipping out about that time.


    Whatever other info you got, please post it!
    Thanks. -C
  8. Caro332

    Caro332 Well-Known Member

    Do you guys have a protection screen? If you do, maybe that is interfering with the phone.
    Or, since you say the temperature plays a huge part, especially when charging, have you ever tried changing battery? Maybe it's faulty and becomes too hot for the phone to handle.
  9. crsklr

    crsklr Member

    No, and no.
    I'll be purchasing this battery:
    3500mAh Battery Replacement w/ Case Cover for HTC Wildfire S/A510E | eBay
    If it doesn't work, I'll still have a 3500mAh battery.

    Anyone have suggestions for face protection? (one that protects the sides too, not just the screen) I won't be able to use my current case due to the increase in battery door size.


    Also, just to note, I have a close friend who has this same exact phone, virgin. (unrooted, locked) He's not willing to root (for me to test), and I don't blame him! These glitches will make you throw your phone through the wall.

    I really need to know if filipedgb's phone is rooted or not, and what method he used if he did.
  10. crsklr

    crsklr Member

    I've changed my mind and decided to go with this one instead, because it's local (free quicker shipping), and also comes with an extra charger. Pretty neat!
    3500mah Extended Battery w/ Black Cover and Dock Charger For HTC Wildfire S G13 | eBay

    The same company sell a package with two batteries also, for anyone who may be interested. ( 2x 3500mah Extended Battery w/ Black Cover and Dock Charger HTC Wildfire S G13 | eBay )
  11. filipedgb

    filipedgb New Member

    My phone is virgin. I've only done the updates that came out since I bought the phone (december).

    I'm thinking of an hard reset, to see if the problem was a result of these updates.

    If the glitching persists, I will have no alternative but sending it back to the guarantee to see what they'll do about it.

    Also: some random things that I've done yesterday and that seemed (only, cause i'm never sure) to reduce the glitching: I removed the case of the phone, because i read something on other phones about static electricity (whatever , I don't remember the explanation, I just did it); I disabled the vibration when touching the buttons (those in the bottom - home, search, back.. - I don't know if they have a specific name); I did a calibration of the keyboard...Yep, just random stuff that I've been testing all the time to see if I found the source of this problem.

    Can you list me the apps you have installed on your phone? Just to see if we have any common app that may be destroying the phone.

    Thanks, Filipe

    Edit: forgot some of your questions, that I can answer.

    Well, when it is randomly clicking buttons I click the shut button, and unlock the phone again, to see if it stopped for some seconds at least. Sometimes it does stop, sometimes doesn't. In this cases i have to wait or reboot the phone...but

    Rebooting is no that efective with me...Neither soft reboot, nor hard reboot. I tried removing the battery yesterday for a while, for like 5 minutes, and it was glitching again immediatly when i turned it on (inserting the pin, keeps clicking the emergency call button; then impossible to do the pattern because it will click randomly again in the pattern, I had to repeat it like 5 times until it worked)

    Battery, well... You said that your phone gets worse when you plug it on, right? (sry , but Im not english sometimes I can misunderstand things). Well in my case i think it's the opposite :S When i'm low battery, it glitches a lot more, and it's a lot slower aswell... When I plug it in and/or when it's full battery, it tends to glitch less, and run smoother.

    I'm not sure if it is not a hardware issue...maybe in sensors...? I realised that my phone will click buttons whenever I shake the phone. When im not holding it, it tends to glitch less (although it does, I must say)

    About temperature...I can't really say, I haven't paid attention to that but since now I will

    Thanks again
  12. crsklr

    crsklr Member

    Update:
    It's hardware. It will glitch, even in HBOOT. But hopefully it's just a digitizer, which isn't too hard to replace.
    Go to bottom of this post for my conclusion.


    I bought mine in Feb of this year. It came as 2.3.2, I think. I updated to 2.3.4, but stopped because I thought I would not be able to root. I found out later that I can. The 2.3.5 patch was only to reduce Metro's stock application sizes.

    Just thought you should know.
    I've reflashed to a few different ROMs, including cyanogen, insink's stock rom, and a few others. The glitching was still there.
    The ONLY place my phone does NOT glitch is in the bootloader menu. (A developer boot menu for loading different ROMs.) There is no touchscreen driver running because all you are using is the menu buttons at the bottom for navigation.

    I'm convinced it's a hardware issue now.
    I just went to two stores yesterday, asking for answers. One was corp, was one retail. I told corp I rooted, they said all she can do is manufacture reset (which I've done before, no dice), but she won't replace it due to the voided warranty (rooting voids it). Retail, however, never asked about it. They'll be calling me Thursday when they get my replacement in stock. She was pretty noob looking, so hopefully they won't notice I've turned my phone S-Off.

    Yep. The back case and button vibration seem to affect it. Not sure about keyboard calibration.

    Here's a list of my downloaded apps:
    Handcent (SMS replacement)
    Play Store
    Root Uninstall (removes bloatware)
    Super User (for root apps
    TeamViewer (remote connection client)
    Missed Call reminder (self-explanatory)
    Terminal emulator (shell utility)
    Open Garden (WiFi/mobile data broadcaster)
    Network (Special app used for network driver repair)
    DroidSail Super (App2SD)
    Quick settings (Self explanatory)
    MSL Reader (Another special app for software repair)
    SMS backup+ (Self explanatory)
    Clockworkrom rom manager (Self explanatory)


    Yep. Exact same for me. One exception: when I restart, it almost ALWAYS works perfectly fine with no problems for about 5-10 minutes. Then it comes back.

    I've not noticed any difference between low or high battery. It's the same for me, either power level. I just know, when I plug in, it SEEMS to glitch more. It may be a fluke (coincidence).

    Update:
    Found a few threads regarding chargers and touchscreens. You should try changing your charger (MAKE SURE IT'S CORRECT VOLTAGE/AMPERAGE), see if it helps/hurts.
    http://androidforums.com/motorola-droid/177777-touchscreen-going-haywire.html
    http://androidforums.com/droid-2-accessories/166801-wall-charger-messes-up-touchscreen.html

    YES! Same problem.
    I have noticed one more thing. When I "twist" my phone, or put pressure at any points on the case or screen, it almost always goes HAYWIRE.
    For some reason, with my new 3500mAh battery, my phone has NOT interrupted any youtube videos. (Usually, it will kick off after a few seconds when it glitches on the bottom menubar buttons) I've been watching a 3 hour youtube video, and it only turned it off twice. (This is really good!)
    A few minutes ago, I pressed the back of my phone (without touching the screen) while the video was running, and it went haywire.

    Also, a few months ago when I first made this thread, I saw a few resolved threads with other phones. Like these:
    http://androidforums.com/desire-z-support-troubleshooting/388555-major-touchscreen-error.html
    http://androidforums.com/motorola-droid/54399-ghost-writer-touchscreen-lost-control-touchscreen.html

    Now, I do not think temperature still affects it. But if I notice the temperature coincidence again, I'll test it with a theory. Maybe place it over my A/C vent to cool it off?

    My conclusion:
    I think it's hardware. Here's why:
    But, what about this?
    I will test if it still goes haywire after I restart. This will answer the question: Hardware defect or software glitch?



    Side notes:
    Got my 3500mAh battery in yesterday. Though the battery itself fits fine (has the correct shape, amp rating, voltage), but the back is NOT correct. It is for the GSM model. Hence: "HTC Wildfire S G13" whatever that's supposed to mean...

    On that note, just did some searching and there seems to be no DETAILED documentation about the difference between models of Wildfire S. I went on HTC's site and this is what they have listed:
    HTC Wildfire S
  13. crsklr

    crsklr Member

    I've made a comparison from the specs info on HTC's website, and here's what I've come up with.

  14. crsklr

    crsklr Member

    I just went to the store today and got my warranty replacement. Worked perfectly fine. She pointed out the LiPo was a little expanded. This is familiar to me, as I've got a hobby with RC helicopters, and the phrase "inflated lipo" doesn't surprise me as a problem causer.

    Anways, they didn't even ask if I rooted or anything. Hopefully where ever it goes they wont care that I set it to S-Off...with custom recovery...and rooted...and custom roms...

    Am I screwed?
  15. Rbhawkins

    Rbhawkins New Member

    This is my problem EXACTLY, and it's gotten to the point where sending a text is difficult, because the back button is phantom-pressed every few seconds.

    Have there been any concrete solutions?

    -Thanks
  16. crsklr

    crsklr Member

    Hey,
    No, I never did narrow down exactly what was wrong with my old Wildfire. I simply concluded it was a hardware bug and traded mine in for a new one. The representative asked me one or two questions about the phone's problems and simply exchanged it out for a new one.

    Now, I did mention that the Li-Po battery was expanded, and that the HTC representative said "if you can place it on a table and spin it like a top, it's inflated". And, an inflated Li-Po could press against the internal plastic housing, which could warp the motherboard within, causing small disconnects and fractures in some of the connections across the phone. In this case, the digitizer.

    I'm curious, does your phone also spaz out when you twist it, or press in certain points on the housing? Does it also glitch while using the ClockworkMod or HBoot interface?

    Let me know some more details about it.
  17. danwiches

    danwiches New Member

    The descriptio​n completely matches mine. And a thing I have noticed especially is that it only taps at the very bottom of the screen. Notice how it's always pressing the search, home and back button very often and also the letters at the bottom, like the space bar, the back and enter buttons, along with all letters on the bottom line and full stops. If it's the same way with you guys let me know please.
    Another observatio​n of mine is that it acts up a lot when watching videos, which as you know is super frustratin​g.

    But yeah, I too have googled so much about phone viruses, and even downloaded an antivirus which said my phone was clean..so it definitely isn't that.. I factory restarted it and all (so those of you thinking about doing that, don't, it doesn't work).

    There were some very interesting things said on this forum, and I have learned a bit more about the situation, such as it's most likely a hardware issue, like the battery.

    I'm going to write a letter (email) of complaint to hTc, as this shouldn't just happen to phones, and after spending over 230 euros, it is truly one of the most annoying things ever to deal with a phone. I would greatly appreciate it if you write one, too. We gotta look out for each other :)


    btw..if anybody actually has any solutions, please post it here
  18. momojaan

    momojaan New Member

    Hello everyone, it looks like i'm in the same ordeal as you guys. Mine bought in Pakistan from a shopping network website. It seems to love touching itself near the bottom of the screen the search, home and back button especially the search button. It was there even before i rooted this phone, started nearly after 6 months from purchase, and any sort of software tweak doesn't seem to work on it even glitches in the Clockworkrecovery menu (pretty sure its a hardware issue). Make you wanna smash the phone to the wall or something, its really annoying at times, so untill i find a solution ive been using htc explorer. It is not a battery issue, as i have 4 of the same default batteries that i use with htc explorer aswell. I removed the screen protector just to check but thats not the problem. Maybe ill give it to the repair shop see what they have to say.
    Please let me know if someone actually found a solution thank you for reading...
  19. momojaan

    momojaan New Member

    Hello Everyone !!

    Let me tell you how i fixed the problem of random ghost touches around the bottom of the screen the home, menu, back and especially the search button.
    Always thought it was a hardware problem and it was. So i dismantled the phone myself. There were special screws on it (torx), i had to make something of my own to open them and it seemed that the screw behind the search button was over tightened somehow. So i dismantled it all and put it back together again and now it works like its brand new. I never saw the screen touching itself ever again...

    thanx for reading
    let me know if you also gonna try to fix yours and aaaaif aait worked...

Share This Page