Will factory reset remove viruses?Support


Last Updated:

  1. androidvisitor

    androidvisitor New Member This Topic's Starter

    Joined:
    May 1, 2011
    Messages:
    3
    Likes Received:
    0
    Hi, I have an LG Optimus T with T-Mobile, after downloading and installing 2 SNES emulators (Snes9x EX and Snesoid Lite), I noticed that when I go to secure websites for example wlm.com (msn messenger) and citicards.com, it keeps telling me the website certificate is not to be trusted. When I check the certificates, it shows the website was assigned to completely unrelated organizations? e.g. for citi, it's assigned to d.xp1.ru4.com signed by geotrust. I checked the same page on my computer, and it's correctly assigned to citibank by verisign. I thought I was infected by a virus, so I removed and formatted my SD card, and did a factory reset, but the problem has not gone away, I am still getting the non-trusted certificates problem. This had not happened before... What are my options? my phone is not rooted and not unlocked yet. I downloaded and scanned with Lookout AV, and returned negative, too. thanks!

     

    Advertisement
  2. sitlet

    sitlet Banned

    Joined:
    Apr 11, 2010
    Messages:
    5,867
    Likes Received:
    632
    If you did a factory reset, that would have removed any viruses that were on your phone. It must be a problem with their website.
     
  3. androidvisitor

    androidvisitor New Member This Topic's Starter

    Joined:
    May 1, 2011
    Messages:
    3
    Likes Received:
    0
    thank you, I guess it could be my phone software too, I ran a software update recently as well. Or could a SIM card harbor any sort of virus, since it can flash contact info, it must have some memory? (though I doubt it). This unsettles me though when I go to citicards.com and it tells me the certificate is from d.xp1.ru4.com. If I wanted to correct it, what other options do I have? thx
     
  4. EarlyMon

    EarlyMon The PearlyMon Moderator

    Joined:
    Jun 10, 2010
    Messages:
    57,604
    Likes Received:
    70,190
    Verify this anomaly on a clean desktop browser before proceeding further.

    Contact CitiBank immediately and report the hijacking to their fraud dept, state both results, phone and desktop.
     
  5. A.Nonymous

    A.Nonymous Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    7,061
    Likes Received:
    964
    It's likely not an issue with your phone and is an issue with the website. They're probably using a certificate that requires an intermediate certificate be installed and it's not configured properly.

    FWIW, I went to citicards.com on the mobile browser on my Galaxy Tab (which I'm fairly certain is not infected) and got the same message you're getting. It's a problem with the implementation of security certificates on the server side, not client side. Phones are dumb devices when it comes to reading certificates and if it's not set up just right on the server side, they don't read them correctly.
     
  6. androidvisitor

    androidvisitor New Member This Topic's Starter

    Joined:
    May 1, 2011
    Messages:
    3
    Likes Received:
    0
    Thank you A.Nonymous, hopefully that's the case. I just pulled my SD card and SIM card out, and factory reset the phone, still the same, so what you said is likely true. thanks

    I also tried chase credit card website, the certificate presented is that of *.doubleclick.net as well, signed by "google internet authority".
     
  7. A.Nonymous

    A.Nonymous Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    7,061
    Likes Received:
    964
    I'd bet money that if anyone here went to citicards.com on their phone's browser, they'd see the same thing.
     
  8. novox77

    novox77 Leeeroy Jennnkinnns! VIP Member

    Joined:
    Jul 7, 2010
    Messages:
    3,965
    Likes Received:
    3,256
    CM7.0.2.1. Don't see any problems. even after logging in. (gingerbread-based ROM; might have something to do with it?)
     
  9. dylo22

    dylo22 Well-Known Member

    Joined:
    Apr 19, 2010
    Messages:
    743
    Likes Received:
    119
    Yeah no problems here with log in. I have stock thunderbolt.
     
  10. GrenW

    GrenW Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    799
    Likes Received:
    130
    I've had 2 or 3 instances of invalid certificates in the past week. All with sites I trust. Never had any problems.
     
  11. Matransh

    Matransh New Member

    Joined:
    Jan 2, 2016
    Messages:
    3
    Likes Received:
    0
    I have a coolpad dazen 1. I got some viruses and need to remove them. I need to do flash for removing them. Instead of doing flash, will factory reset remove the virus ? Pls tell me. I'm in safe mode now. Should I do factory reset or flash ?
     
  12. mikedt

    mikedt 你好 Guide

    Joined:
    Sep 22, 2010
    Messages:
    16,771
    Likes Received:
    7,443
    If the malware is in system, i.e. root. You'll have to re-flash it. Try a factory reset first, and if that doesn't clear it, then flashing with a clean manufacturer's ROM is definitely required.
     
  13. Matransh

    Matransh New Member

    Joined:
    Jan 2, 2016
    Messages:
    3
    Likes Received:
    0
    Ok thx bro
     
  14. Matransh

    Matransh New Member

    Joined:
    Jan 2, 2016
    Messages:
    3
    Likes Received:
    0
    I can do factory reset and I've done it too but it didn't worked. I don't know how to flash my phone. Can u pls tell me how to remove the virus by doing flash. Pls tell me if u know. Thank You.
     
  15. mikedt

    mikedt 你好 Guide

    Joined:
    Sep 22, 2010
    Messages:
    16,771
    Likes Received:
    7,443
    Best Answer

    Main task is, you got to find an appropriate ROM for it, i.e. a ROM for Coolpad Dazen 1. And once you've got it, should be able to do it via recovery. Unfortunately Coolpad don't have anything you can download. You might have to contact them about it I think.
    http://www.coolpad.com/us/support
    http://www.coolpad.cn/
     
    Last edited: Jan 2, 2016
    #15

Share This Page

Loading...