Will not connect to iphoneSupport


Last Updated: 2013-08-08 23:05:01
  1. Feasdroid

    Feasdroid Member

    I have the wifi only TF700T and an iphone 5 ( I know, I know). As I have an unlimited internet package on the phone my plan was to connect tablet to phone via wifi and use the iphone's "personal hotspot" to provide the internet connection. Well that was the plan!

    I tried it for the first time the other day with no luck. The tablet sees the iphone (as an available wifi connection), I try to connect them and it asks for the password but after I've entered this, nothing. They don't connect, no window appears to tell me anything is happening, nothing.

    I've tried to connect them using Bluetooth, nothing again although this time I get a message on the tablet saying they are "not compatible" or something.

    I've tried using a cable, again no luck.

    I tried a laptop and this connected 1st time to the iphone Personal Hotspot (via wifi), everything worked fine.

    Neither the tablet or phone are "rooted", "jail broken" or whatever (don't really understand this and don't want to!)

    Has anyone else tried to connect their infinity to an iphone in this manner? I'm starting to think the tablet has a fault but I don't want the hassle of returning it until I'm sure.

    Is this just an "Android doesn't play with Apple" issue? I realise this is an Android forum and Apple is probably a dirty word but I have no allegiances in this regard, I just want technology that works and I can't see any reason why this shouldn't.

    Advertisement
  2. cambo1

    cambo1 Well-Known Member

    not sure what the prob is. I connect my Nokia to my tablet to use the WiFi without problems..maybe it recognises that an inferior device is trying to connect...
  3. TexasBadger

    TexasBadger Well-Known Member

    Your problem is that you have a stupid iPhone. Apple does not allow tethering. Get rid of that thing and go buy an Android phone. Then install Foxfi and your tablet will love your new hot spot.
  4. Feasdroid

    Feasdroid Member

    The phone does allow tethering, to everything other than the infinity! I've become increasingly disenfranchised with Apple, this was my reason for choosing the Asus tablet rather than an ipad. Despite this and chiefly because I've purchased so many apps, I decided to "upgrade" to the new iphone 5. I'm now locked in for two years so buying a new phone really isn’t an option.
    Again, I really can't see why this shouldn't work, it seems that the tablet will connect to all sorts of other manufacturer’s device and I can't shake the feeling that this is all a result of the ongoing war between Apple and the rest of the world!
  5. TexasBadger

    TexasBadger Well-Known Member

    There are two types of wi-fi hot spots, but I no longer recall the proper terminology.

    My old Droid Eris would only set up an ad-hoc (?) network. It could be seen by an iPad or a Windows laptop, but not by my old TF101. The iPhone hot spots are the same as my old Eris. Basically, they will only connect to iPads and laptops.

    My Droid Bionic, and virtually all newer Android phones, set up a more modern kind of wi-fi hot spot that will support 5-8 Android, iOS, and Windows devices simultaneously. With FoxFi, they do so for free.

    Sorry to read about your new iPhone5 with its crappy little screen and unreliable navigation. To get it to support a tablet, you will need to downgrade from your TF700T to an iPad. Or give your iPhone to an elderly family member and upgrade your phone to a nice new 5" Android device. There are lot's of choices.
  6. Feasdroid

    Feasdroid Member

    I've contacted ASUS and after the usual "restore to factory defaults" solution didn't work they've asked me to return the tablet so they can have a look. While it is still under warranty, if this problem is just the way the tablet/iPhone work and the unit doesn't actually have a fault, they may charge me for this service.

    I know I'm asking a lot but if anyone has a TF700 and has or knows someone with an iPhone, could they just check to see if they can link them via the personal hotspot feature on the phone? This might help to confirm where the problem lies.
  7. TexasBadger

    TexasBadger Well-Known Member

    Everyone in my family has the latest iPhones and iPads. I am only only one with Android devices, a Droid Bionic and an ASUS TF700T. I am the only one that can set up my phone as a hotspot that everyone can use. I am also the only one who has reliable navigation, an accessible file system, and widgets.

    There isn't anything wrong with your TF700T. The problem is your phone.
  8. joshnl

    joshnl Member

    I'm having the exact same problem as the OP. Funny, since when I first got my TF700 - and it was still on ICS - tethering to my iPhone 4 worked fine. I hadn't tried it again since updating to Jelly Bean until today, only to discover that the TF700 sees the iPhone and allows me to enter the password, but then nothing happens. This isn't an issue with my specific iPhone, since the TF700 will not connect to my friend's iPhone 4 either.

    This leads me to believe that something in JB is causing the problem.

    Please no comments on how crappy my iPhone is. They are not constructive.
  9. novox77

    novox77 Leeeroy Jennnkinnns! VIP Member

    does the iPhone provide a hotspot via ad-hoc or infrastructure mode?

    the typical wifi router that you connect to at home or at a Starbucks uses infrastructure mode. I suspect the TF700T only works with infrastructure mode. If the iPhone is broadcasting in ad-hoc mode, it could explain the issue.

    I tend to think that the software layer should support both modes. That said, a rooted android device can handle ad-hoc mode...
    ocnbrze likes this.
  10. joshnl

    joshnl Member

    Feasdroid: After some scouring through the internet, I finally found a solution that worked for me. I had an apostrophe in the name of my iPhone - when I removed the apostrophe, it was all good. Hope it works for you!
    puka pai, Feasdroid and ocnbrze like this.
  11. Feasdroid

    Feasdroid Member

    It worked! After days of pulling my hair out I thought I'd have to return the tablet to Asus, you've just saved me a whole load of hassle and probably money, thank you so much.

    Actually thanks to everyone for your contributions, this is my first post on this forum and, while I hope I don't have any further problems, I'll know where to bring them if I do.
  12. joshnl

    joshnl Member

    Sweet! After all the times people on these and other forums have helped me, I'm glad I could finally be of help to someone myself!
  13. GRIP62

    GRIP62 New Member

    Joshnl,

    I presently am trying to do the same thing, the only differance is that I have the iPhone 4GS. Can you hand feed the process in that you did so I can make my happen. Would be greatlyappreciated - not that savy when it comes to this. Thanks
  14. Feasdroid

    Feasdroid Member

    GRIP62 - assuming you haven't got the answer already (really should check this forum more often!), on iphone go to "settings", then "general", then "about". Select "name" and you should be able to alter the phone's name and remove the troublesome apostrophe.
  15. puka pai

    puka pai New Member

    Thanks so much for this! I've been trying to help out my son and this was the only stumbling block (so far...) I rooted my old Nook Tablet for him and so wasn't sure if it was a problem with that or the phone.

Share This Page