Windows 7 64-bit Doesn't See Droid X


  1. Guncrazy

    Guncrazy Member

    I've got a Droid X that I'm trying to connect to my PC, which is running Windows 7 Home Premium 64-bit.

    I plugged the USB cable into the computer, then into the phone, and nothing happened. The phone does not show up in "My Computer."

    I've tried several different USB ports, with the same result.

    I loaded the Motorola Drivers (found here), rebooted, reconnected the phone, and still nothing.

    I've tried opening Media Share, selected "Computer", "Copy", "USB"...and then on the step when I'm supposed to "Enable Memory Card Management," I press the button, select "PC Mode", "OK", "Next", and then I'm told that "Memory Card Management mode must be turned on to continue." (The same thing happens when I select "Windows Media Sync" or "USB Mass Storage".)

    Am I missing something, here? Is there a setting that I need to enable on my phone in order to make it visible to Windows?

    Thanks in advance for any help.

    Advertisement
  2. krichek

    krichek Well-Known Member

    Two questions.. Are you sure you plugged the cable into the phone completely? I know it sounds stupid but at least on mine you have to give it a good push to get it to actually make a connection. 2nd Question is did you install the drivers with administrator privileges and reboot?
  3. Guncrazy

    Guncrazy Member


    Yes, and Yes. Still, no joy.

    When I plug the cable into the phone, the screen comes on, but there's no indication that anything is happening. No response from the PC, and the phone doesn't charge. (When the USB cable gets plugged into the AC adapter, however, it does charge.)

    I am the only user on this PC, and I have an Administrator account.
  4. krichek

    krichek Well-Known Member


    UAC can be weird, even if you are using an administrator account I would still try right click "run as" reinstall the drivers and then reboot.

    When you plug the cable into the phone you do get the USB connect notification and can select any of the four options presented right? Or do you get no indication of a connection on either device?
  5. Kadgarth

    Kadgarth Active Member

  6. Guncrazy

    Guncrazy Member

    I do not get the "Run as Administrator" option when I right-click the file, because I am an Administrator.

    When I plug the PC and phone, there is no indication from Windows that a device has been plugged in. The only indication I get on the phone is that the screen comes on when I either plug it in, or unplug it. Neither device asks for further input, nor shows any indication that they see each other.

    Program installed, but still have the same problem...

    Thanks for the help, guys. Any other ideas?
  7. dookie1

    dookie1 Well-Known Member

    win7 x64 here...no issues at all. was prompted to install a driver when i first connected the phone, which i did. the process also installed a motorola taskbar phone management app and created a start menu group with a driver installer shortcut.
  8. SiXiam

    SiXiam Well-Known Member

    I have Windows 7 Professional 64-bit & it installed after I ran the program.
    It did give me an error, but continued without trouble installing. It probably had 32 & 64 bit drivers and was it failed on the 32, but had no trouble with the 64 ones.

    I also copied the set-up files if anyone needs them, just send me a pm that you need it with your email address. ;)
  9. Guncrazy

    Guncrazy Member

    Well, the Droid isn't the problem. It's Windows.

    Plugged the phone into someone else's computer, which was running Windows 7 Starter Edition, and it connected right away.

    If anyone is a Windows guru and knows what might be preventing it from seeing my Droid, I'd appreciate any suggestions.
  10. Theeulogy

    Theeulogy Well-Known Member

    Make sure that USB mode is not set to "charge only". When you plug it in USB drag down the information tab on the Droid and click on "USB conection" to see.
  11. Citrusdude

    Citrusdude New Member

    Mine does this very same thing. Is it true you need a USB cable from Motorola for the Droid X to communicate with the PC? I'm at wits end trying to get past this issue. I'm leary in that the DroidX does nothing when connected like the USB isn't communicating.
  12. colchiro

    colchiro Well-Known Member

    I have Win7 x64 Ultimate and these drivers worked fine for me: http://androidforums.com/all-things-root-droid-x/130116-how-root-your-droid-x-2.html#post1210990

    I had to install them, then from device manager, do another scan for new hardware.

    Right now, with my X in "PC Mode", I show an "ADB Interface" with a "Mot Composite ADB Interface" below that.

    If I change the "View" to "Devices by Connection", then expand the USB Root Hub, I have:
    Motorola USB Composite Device
    . DROIDX
    . Mot Composite ADB Interface
    . Motorola USB Modem
    . Motorola USB Networking Driver

    These drivers allowed me to get ROOT so I know they work.
  13. Sek0n

    Sek0n Well-Known Member

    I had the same problem when I first got it too.

    These should work, but if I'm not mistaken, the media link above should have had the drivers in them as well.

    Anyways, worth a try:
    Motorola Droid X USB Drivers (64bit): http://www.motorola.com/staticfiles/Support/Experiences/Global_Drivers/USB_Drivers_64_bit_4.6.0.zip

    Motorola Droid X USB Drivers (32bit):
    http://www.motorola.com/staticfiles/Support/Experiences/Global_Drivers/USB_Drivers_32_bit_4.6.0.zip

    Edit: After looking, the how-to linked by colchiro has the same drivers. Ah well. :p
  14. mruno

    mruno Well-Known Member

    Make sure your phone is not locked when you plug it in.
  15. ezflip

    ezflip Well-Known Member

    Do you have a firewall or anti virus program running on your PC?

    Windows 7 should automatically find the device and load the appropriate drivers. I needed to do nothing when I got my DX. Plugged it in, it found it, if said loading drivers, it was done and I was good to go. No input from me needed.

    However, a firewall or anti virus program can disable unknown devices from being recognized by the PC. Turn them all off, plug the phone in again and see what happens. (Dont just close out of them...make sure they are completely shut down)
  16. mweiland

    mweiland Member

    settings->applications->development->check 'usb debugging' on

    ...is a functioning workaround. at least for me.

    good luck.
  17. phxdroidx

    phxdroidx New Member

    having the same issue.. plug my phone in the usb, phone says "connection detected" and is charging but my computer dosent do anything at all.. didnt have this problem a few days ago.. been syncing music and movies fine and all of a sudden my computer acts as nothing is plugged in.. i havent downloaded the motorola software and frankly, i shouldnt have to.. can anybody solve this issue..
  18. colchiro

    colchiro Well-Known Member

    phx, did you drag down the status bar and change to "PC mode" (for root) or "USB Mass Storage" to copy files?

    I installed generic drivers, which didn't work but uninstalling them and installing the Motorola drivers DID. Why ask for help if you're not going to do what is recommended?
  19. phxdroidx

    phxdroidx New Member

    ok, tried using usb mass storage.. still nothing from my computer.. installed the motorola drivers using the link provided and it says "failed, consult your manufacturer for assistance getting this device installed" but its weird cause it was working fine this morning..
  20. rbh5081

    rbh5081 Well-Known Member

    I had the same problem turned out I had turned off the usb link setting on the phone. I had deleted all the individual on/ off widgets so I put had to add the Android power control widget turned it on and now I connect no problem.
  21. phxdroidx

    phxdroidx New Member

    ok, i left my computer off for a half hour, turned it on and used the mass storage option and everything went smooth.. not as smooth as before but it gets the job done.. but now im wondering should i care about the failed installation of the motorola drivers or is it just whatever..
  22. Exiled

    Exiled Well-Known Member

    My X connected to my 64bit Win7 with no problems for a few days. Then all of a sudden it stopped being recognized by the computer, no matter how many settings I changed on both the computer and phone. Then, I restarted my computer while my phone was plugged in, and it was finally recognized. The strange thing was that it decided to install the motorola software on my computer (which I allowed). But I don't understand why it never tried to do this before.
  23. colchiro

    colchiro Well-Known Member

    When I installed the Motorola drivers, it installed one device. From within device manager, I clicked on "scan for hardware changes" (just right click anywhere) and it found 3 or 4 more devices.

    phxdroidx, if it works and you don't have any yellow !'s in device manager, I'd leave it as-is.
  24. effin_eric

    effin_eric Well-Known Member

    hey guys.. I have Windows 7 (32 bit) - I had this same problem until I read on another forum to connect the phone to the comp., turn off your phone while it's plugged in. Leave it plugged in and turn it back on then... VOILA drivers installed themselves. Hope this helps some of you!!
  25. apshuler

    apshuler New Member

    If you've loaded the Android Task Killer &/or Android Task Cleaner, make sure you check the autokill lists. I had the "motorola.sync" software autokilled and wasn't able to adjust USB setting. Ensure you have motorola.sync (or sync.motorola) removed from the autokill list and ignored by both ATK and ATC.

    "Motorola services" might be another problem spot.

    Also recommend Motorola Media Link as a good platform to transfer data to DX. Easy to use, iTunes-esque, and syncs to iTunes or WMP.

    Using XP SP3 (HP Media Center PC).

Share This Page