Windows does not see Nexus 7Support


Last Updated:

  1. PortNerd

    PortNerd Active Member

    I have an (2012) nexus 7. When I plug it into my (win7 x64) PC, the PC doesn't see it. The nexus shows that it's charging, but the PC acts like it doesn't it.

    I've tried multiple cables (which all work with my nexus 4) and multiple USB ports (ditto). I've multiple PCs, and I have even tried doing "wipe data/factory reset" to the tablet.

    It's been a while since I've tried plugging this into the PC, so I cannot be sure, but I suspect that it's the recent android update that is causing the problem.

    What else can I try?

    Advertisement
  2. PortNerd

    PortNerd Active Member

    Android version 4.3

    Kernel version
    3.1.10-g1e8b3d8
    Tue Jun 11 2013
  3. PortNerd

    PortNerd Active Member

    I have turned on USB debugging. No change. When I plug it into the PC, the only thing that happens is that the charging symbol turns on.
  4. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    You won't follow it through with actually rooting, but Wugs root toolkit has instructions on how to completely remove current drivers, then install the correct set. Have you tried that?
  5. Joon525

    Joon525 Well-Known Member

    Check in Device Manager to see what driver Windows is using for the N7.
    I had trouble with the N7 but my N4 was working perfectly.
    I noticed that the N7 was using winusb.sys as a driver but the N4 was using wpdusb.sys.
    I went in to try to manually change that and got some dialog box about MTP stuff and followed it all the way through and now the N7 is recognized as an MTP device and working perfectly.
  6. PortNerd

    PortNerd Active Member

    It doesn't show up in the device manager at all.
  7. jhsrennie

    jhsrennie Well-Known Member

    It was a while ago, but I think I ran into the same problem with a friends new N7. The solution was to go into the N7 Settings/Storage and change the storage type to PTP. When connected to the PC the N7 then appeared as a camera. When I changed the storage type back to MTP and reconnected the N7 the PC saw it as you'd expect.
  8. WoohooGuy

    WoohooGuy Well-Known Member

    Did you by chance uninstall Windows media player from your system, or not update it?

    The MTP protocol that is required to view the nexus 7's internal memory is largely provided by the installation of Windows Media player 11 on XP devices and should be native on Win 7 unless you changed/removed it.

    Try re-installing windows media player 11 on your system and see what happens.
  9. lvt

    lvt Well-Known Member

    I had the same problem with my Windows XP in the past, I uninstalled the old Windows Media Player then installed the latest version for XP. It worked like a charm.
  10. John Bean

    John Bean Happy Wanderer Guide

    Windows 7 (as the OP uses) is not XP and doesn't require Media Player to allow connectivity with MTP devices.

    I would encourage the OP to install the Nexus Root Toolkit mentioned earlier and use it to install/verify a functioning windows driver. There is no need to actually root or modify the Nexus during the process but you can of course do this (if you want) using the same toolkit once you get the drivers working correctly.
    El Presidente likes this.
  11. WoohooGuy

    WoohooGuy Well-Known Member

    I stumbled across these instructions while perusing XDA and remembered someone here with a similar issue, glad I located this thread.

    Try the following on Win7 -

    If you have an issue with Windows 8 there is also a similar process listed in the same thread you can try.

    You can visit the thread and give the props due here - How I fixed the MTP issues on Nexus 7 - xda-developers
  12. TheAmazingDave

    TheAmazingDave Well-Known Member

    Sorry guys, I didn't read the whole thread so I don't know if it was resolved, but I want to share this:

    My mom's N7 did the same exact thing. It had been charging very erratically for months, and one day, while preparing to do a full stock firmware flash, I found that hers too would not be seen at all by the Windows 7 computer. No indication at all, no unrecognized device chirp, nothing. Nothing in device manager, but the N7 still showed charging over USB.

    The lock on the connector which attaches the USB port on the N7 to the data ribbon which links it to the mainboard was unlatched, and the ribbon had dislodged partially! I reseated the ribbon, locked the latch down, and the tablet charges perfectly, and fully in 2 hours, and Windows sees the tablet again.

    http://androidforums.com/6147715-post1.html
  13. zysmith

    zysmith New Member

    For some reason the USB Computer connection had both options deselected. Not sure when/how this happened. Opened Settings -> Storage -> then USB computer connections form the drop down menu, upper right corner of screen. Selected MTP and it loaded the drivers and worked fine. Thanks to a previous poster for mentioning a similar fix which led me here.

    :thumbup:
  14. inb4tehlulz

    inb4tehlulz New Member

    Just wanted to say thanks, I've read a ton of threads with the same issue and it seems like everyone has relegated the issue to being that a car charger "Broke" the usb port. This is the first time anyone said anything about the USB options setting. I would have never thought to look because everything normally pops up in the menu. Just had to select one and install the new drivers and works fine now.
  15. ajax1812

    ajax1812 New Member

    Followed
    this pc/properties/device manager/portable device (or acer)/nexus 7(or some model number)/update driver/browse my computer for driver software/let me pick/mtb usb device/next

    but first i had to get device manager to see it, turned on developer option on n7 and turned off usb debugging. My device showed as acer/model number instead of portable device, changed to portable device after fix.:eek:

Share This Page