Windows Explorer Thumbnails won't display S3 jpegs - what gives?Support

Last Updated:

  1. work4crown

    work4crown Member

    Problem: When I use my computer to browse the SD card or Internal memory in my S3 my computer displays icons instead of thumbnails for the jpgs. This makes it a pain to find the image I am looking for.

    Info: I have two Windows 7 64 bit computers that I have tried to connect my Verizon S3 to. I experienced the same problem on both computers.

    Procedure: When I first connect the cable to my computer's usb and the S3's USB I get some information in the S3's notification tray:

    Connect as: Media Device (MTP). This is the option that is selected. I could also change that to Camera (PTP). I have tried switching to PTP and that does not help.

    Then the AutoPlay window on my computer pops up and I select 'Open device to view files'.

    From the Windows Explorer window I can either browse 'Card' or 'Phone'. I select 'Card' then 'DCIM' and in there I can see lots of .jpg files that I took with my old phone (Original Droid Incredible) that I recently put in this folder. Each jpg is represented by the same icon that looks like a sunny day at the lake or something.

    Why can't I see the thumbnails?@! :mad:

    I have also made sure I have the thumbnail setting turned on in Control Panel and in Windows Explorer.

    I have tried moving the slider up and down to resize the icons. (You know, that slider that goes from 'Extra large icons', 'Large Icons', 'Medium Icons'......all the way to 'Content'?)

    Someone please please tell me how to get the thumbnails working. This is really annoying.

    Thanks!!!!! :D

    Redkylie likes this.
  2. patrick64

    patrick64 Active Member

    I have the same problem. I Googled it and found nothing. Somehow when you are connected to the phone, it doesn't show you images. what I did find out is that if your copy your files to your computer, you are then able to see the images.
  3. mrsb2005

    mrsb2005 New Member

    Same thing here. Google shows nothing. I have the Galaxy S2. This happened when I upgraded to Android 4.0. Other wise I never had a problem.
  4. rdandy5875

    rdandy5875 Active Member

    Did anyone ever find a solution for this? Kies sucks IMO and all that's missing from using explorer effectively is thumbnails. There isn't much info on this problem but it seems to affect everyone.
  5. haowan

    haowan New Member

    Same problem here - can't see thumbnails. Preview Pane in Windows Explorer doesn't work either.

    Additional problem - can't drag directly from the card to open applications; I have to copy the file to the PC first.

    Most annoying.

    I thought this was an Android 4 feature/bug but other users with ICS (e.g. Nexus phone) are reporting that it is working fine.

    I do wonder though as with Mass Storage in Gingerbread it all worked fine on all platforms, and now this MTP/PTP stuff is just annoying, confusing, and doesn't work on Mac either. MOST ANNOYING I SAY
  6. Redkylie

    Redkylie New Member

    Thank you Thank you! I thought I was going insane! Have had a tech support friend looking at it for me because I was doing something wrong.

    Would love to know if there will be a solution to the problem as I use my phone for uploading photos for work and having to go through all the pics I take individually is starting to drive me insane. I'll just have to go back to using my other phone or my actual camera instead! lol
  7. _Aardvark

    _Aardvark Well-Known Member

    This is a limitation of Windows and/or the MTP protocol. Mass Storage mode works, but that's not an option on most new Android devices (inc the S3) it seems.
  8. SumChickieBum

    SumChickieBum New Member

    I am having the same issue and it's driving me batty as well. I figured if I posted here that maybe I would hear about the solution. You would think it would just be a software driver or setting or something simple. Just silliness! :smokingsomb:
  9. SodaPopinski

    SodaPopinski New Member

    Has anybody figured out a fix for this issue yet? So annoying.
  10. hbryder

    hbryder Well-Known Member

    i know this isn't a fix, but I use dropbox and also installed it on my pc, so all I have to do is open my dropbox on the pc and my pics are there ready to edit or download. Might work until there is a fix

    I have it set to auto upload. you can do this with either data or wifi, or set to both. It can eat up data if you take a lot of pics. But it's very nice to not even think about uploading, it just does it in the background.
  11. true

    true Well-Known Member

    still waitiing on an answer!
  12. davidmanvell

    davidmanvell Well-Known Member

    Think this is a windows issue or an issue with the connection format. you know how windows has different types of windows like media windows and disk windows etc, they all do different things and display differently.
  13. nrishiraj

    nrishiraj Member

    I've just noticed the same problem.

    I'm just using crappy Kies in the meantime.
  14. bigjon1684

    bigjon1684 Member

    Same issue here. With my previous phone (HTC Desire Z) I had to select a setting to "Mount as disk drive" or similar. Haven't found an equivalent on the S3, it just linked up without fuss, but I can't see the thumbnails.
  15. DrKrall

    DrKrall New Member

    Hi , i use Airdroid and it shows all thumbs. Its a nice app and it is helpfull to get around this issue (witch sucks). Another issue that is annoying in my oppinion is the fact that u cant install apps and run them from sd card. These 2 issues with the sd-card is totally ruining the otherwise nice experience with the S3

  16. XplosiV

    XplosiV Master X is Watching You VIP Member

    Bthe easiest thing to do is just copy the folder containing the pics to your pc then they will thumbnail as normal.

    I don't see why that's so difficult.
  17. exspore

    exspore New Member

    The problem isn't solved by this. I have a Droid 4 and copying the pics to a local folder and showing thumbnails only shows the thumbnail for a small percentage of the pics. The rest of the pics are icons and when double-clicking the icon to open in Photo Viewer, I get "Windows Photo Viewer can't open this picture because the file appears to be damaged, corrupted, or is too large."

  18. kasper007

    kasper007 Well-Known Member

    Same freakin problem here, cant see the dam pics...Maybe it's a samsung thing...I never had this problem with my Dinc or Dinc2 . just my s3....
  19. GBB0131

    GBB0131 Active Member

    I never had any issues with my Motorola Phones or an LG Revolution. Funny part is that when I remove the Micro SD Card and put it into my laptop it shows thumbnails.
  20. _Aardvark

    _Aardvark Well-Known Member

    I don't understand why people still seem confused in this thread.

    The reason is Windows Explorer does not support thumbnails on devices that connect as a multimedia device (MTP originally for MP3 devices I think). This is different then what a USB thumb drive, external hard drive, or memory card reader do - they are "Mass Storage" devices. There is also PTP protocol that makes the phone act like a camera, that doesn't do thumbnails either.

    Some Android phones connect as Multimedia devices. Some Mass Storage. Some give you the option. Our S3 are MTP or PTP only. No Mass Storage. No thumbnails.

    You have to use something other than Windows Explorer or hope this is different in Windows 8.
  21. biep

    biep Member

    Guys...I've found it !! happened to me also and I was fed up with it. worked on GB now on ICS no more.... I installed several apps but this one really worked :
    USB switcher from ZATTA, there you can switch between USB mode and MTP. Now I can see all of my pictures again when connecting my sgs2 to my pc. This apps simply changes the USB mode somewhere in adb....brilliant !!!
    IT WORKS ON SGS2 - (stock but rooted with siyah kernel)
  22. davidmanvell

    davidmanvell Well-Known Member

    I know the answer to this. MTP protocol says that the filesystem and such is on the source device (The phone in this case) so Windows cannot manipulate it like it can a regular drive. So it's a limitation of the protocol. if Android were to add the ability for this into their filesystem then Windows would be able to use it.
  23. guestaccount

    guestaccount New Member

    So I figured out what works for me. Downloading that Zatta app didn't work for me, probably because I'm not rooted.

    Okay so go to Settings>More>USB Utilities>Connect Storage to PC
    If you're charging through USB it will tell you, "USB is connected. Remove the cable." So remove it and plug it back in again and then click the button which now says, "Turn on USB storage" then OK.

    Now it should be using it like a disk drive.
    Hopefully this works for you. I just switched from my HTC so everything is messy. In other words I have now my old folder that I named when the SD card was in my HTC and another drive, "Removable Disk" under that. But all my new and current files are there.
  24. work4crown

    work4crown Member

    Where is this menu structure?

    Settings>More>USB Utilities>Connect Storage to PC

    I don't see those options on my phone. Is that from within some app?

    Sorry, I'm a little lost trying to follow that. :)
  25. duc_ryder1

    duc_ryder1 New Member

    Got the same problem with my s2, and when I saw this thread with that menu structure I got excited, but I cant find it...
    Where might it be found?

Share This Page