Witstech A81-EGeneral


  1. Medic005

    Medic005 Well-Known Member


    Looking forward to your review!
  2. badankles

    badankles Well-Known Member

    Wow, for about $50 more than the augen gt78, it's almost just right. No accelometer, though...hmm...

    Wait, if it has froyo 2.2 then why the flash issue? It should already be built in.
  3. badankles

    badankles Well-Known Member

    Wow, for about $50 more than the augen gt78, it's almost just right. No accelometer, though...hmm...

    Wait, if it has froyo 2.2 then why the flash issue? It should already be built in.:confused:


    Edit: Crap, sorry for the double post.
  4. CooL_SpoT

    CooL_SpoT Well-Known Member

    GOOD NEWS!! Yesterday morning I woke up at 7:30am to the unpleasant sound of the doorbell ringing only to find that my tablet has finally arrived!!! So for those keeping track; I bought through Merimobiles and had my order confirmed on 4 Aug. Three business days later I received my tracking number and spent the next 9 business days trying not to go insane.

    So it took a little longer to arrive than I had hoped, but all in all, I'm not too upset about the shipping time. Fortunately I didn't have much cause to e-mail Merimobiles at all, so I have no idea how helpful they may be.

    On to the immediate un-boxing! I was surprised to find the manufacturer's box nestled inside another box (which was liberally covered in tape) for shipping, so the original box is left completely free of labels, tape and the like! Certainly not a deal-breaker by any stretch, and it may be standard practice, but I definitely appreciate having an un-damaged box.

    Everything I expected came with the device (claw-style car mount, car adapter, wall charger, protective carrying case, 3 inch long mini-USB -> USB plug, 3000mAh battery, warranty card (I'm guessing, it's in Chinese) and a stylus (left in the device)). And each component (except for the stylus and warranty card) was wrapped in its own plastic bag, and the device was actually shipped in the carrying case. A little excessive, maybe, but you can be fairly sure it's not going to get damaged! :)

    Okay, first impressions. This feels like a very solid device. The case doesn't creak at all when you squeeze it and there isn't any "play" in any of the seams. The buttons (six of them, counting the volume rocker as two) all feel well-installed. They have a satisfying click feeling when you press them, but they are mercifully free of any actual clicking sound. Moreover, it doesn't feel like you're bending or flexing the board underneath when you push the buttons.

    When you flip the device over you see that it's a very clean design. Though somewhat thick, the back of the device is curved in such a way that it's very comfortable to hold any way you want. The battery cover clicks in very solidly, and doesn't feel like it should unexpectedly pop off. The battery itself fits very snugly into the battery compartment, and I don't expect it'll have any room to wiggle free on it's own. Also the battery itself has a convenient tab on the side, so taking the battery out yourself isn't even a little difficult.

    The built-in kick-stand is an ingenious idea, and after using it all day yesterday, I'm starting to think this should be a standard feature on all small tablet devices. Not only does it stand the device in a perfect orientation for, say, a desktop picture display (which I haven't played around with at all, yet), but it also offers a decent hand-hold for reading one-handed (more on that later). I don't imagine anyone had that in mind when they came up with the idea, but the point is, that kick-stand is a far more versatile and useful feature than you would ever have guessed. It, also, feels very solidly designed, and despite being very slim, it doesn't feel fragile at all, and doesn't feel like you might snap it off by accident. My only gripe with the kick-stand is that it can be very difficult to pull out of its housing. It doesn't have any sort of tab on it that you can get a fingernail into, and its so tight in its compartment that you've got to put some decent amount of force on it to get it out.

    It seems there's a lot of controversy over resistive touch-screens now that capacitive screens are so commonplace. And I must admit, I was a little leary over buying a resistive touch panel. This one serves very nicely, though. It is very accurate, though it did infrequently press the wrong key while typing. Otherwise, though it's certainly accurate enough. You don't have to press too hard for it to read at all. If you've used a decent car GPS unit, this feels similar in terms of responsiveness. Scrolling on a resistive screen is more difficult than on a capacitive screen, though, there's no denying that. Often while trying to scroll through a menu, I'd end up accidently selecting something I didn't want to.

    Now for the firmware. I should point out at the outset that this definitely feels like a very alpha firmware version. Be warned, there are bugs!! This is clearly little more than a direct port of a phone's OS onto a tablet device. Now, this isn't a huge problem, really, but little things like the phone shortcut on the app drawer, the signal strength icon in the status bar (which perpetually reads "no signal", of course), and all the phone-specific options in the settings menu all serve to keep reminding you that at its core, Android is still a phone OS.

    Those little reminders aside, though, this is a very capable OS. I've found little difficulty doing much of anything I wanted to, though there were some hiccups here and there. The Marketplace is working, but there are a number of apps that don't seem to be showing (Seesmic which is a popular Twitter client, for instance). Many online sources, such as Android FreeWare can get you around those problems. And as I understand it, this can be gotten around through firmware updates as well.

    Side loading apk's wasn't an issue in any way. The firmware comes pre-loaded with APK Manager which make it a breeze to load/uninstall any program you wish. I did find some apps that display funny due to the larger screen than the app expects. The app will run fine, but it will be constrained to this tiny chuck of area at the top of the screen. If you've seen iPhone apps running on the iPad, you know what I mean.

    I did get Laputa (an e-reader app) loaded on with no problems, and it runs beautifully full screen. I spent a good 2.5-3 hours reading on it last night and once I turned the screen down to it's minimum brightness I had no problem reading on it at all. It was quite comfortable, really. While there's no in-built accelerometer, there are a number of apps that run naturally in portait mode, and mercifully, Laputa is one of them. Holding the device in portrait mode was quite comfortable, and once I discovered I could use the kick-stand to steady the device on my hand, I didn't have to grip the device too hard, and could have read all night, if I hadn't needed to get up early this morning! ;)

    I had no problem connecting my device to my WiFi network, which is secured with WEP 128 bit encryption. No experience at all with other forms of encryption, so YMMV. There were a couple of unexpected disconnects from the network, but they both happened when I had gone outside, so I can't be too terribly upset about it. In the house I haven't really had any problem with the WiFi connection, so there's not much room to complain, I guess.

    I couldn't get the GPS to work at all really, though I'm told that's a firmware issue, and that it will work under WinCE. [As an aside, WinCE is a freakin' beast to use on this machine, I highly recommend sticking with Android, despite the firmware issues. It's just better designed for this type of implementation.]

    For the rooters and ROM-fiends out there, this is a really easy device to root and flash new ROMs on. Mns over on SlateDroid already has a custom firmware out, and though I couldn't successfully get it flashed on my device, Mns is very active on SlateDroid and seems willing to help in any way (s)he can, despite this being his(her) first release. And if you end up with something you didn't want, links to the official firmware releases for both Android and WinCE can be found at the Merimobiles link at the start of the review.

    Oh, and the one issue that's really becoming irritating is the battery indicator is totally out of whack. It doesn't seem to have any idea how much juice is left at all. In fact it's gotten to the point that it doesn't even bother to change at all anymore. I do seem to be getting the 5-6 hours with WiFi on out of it, as advertised, however. But it is annoying to look at a full battery indicator, and watch the device go black because the battery's dead.

    Take note, though, that almost all of the issues I've had with this device can be rectified through firmware updates. And WitsTech does seem to be keen on updating the firmware frequently. Even better, this device is gaining popularity, and as such, is gaining a developer community, so even if WitsTech completely turns it's back on this device, there should still be firmware updates and people working to fix the software shortcomings that are there now.

    As for the "Yea/Nay"... I would definitely say Yea! I can easily recommend this device. If you're looking for an e-reader that isn't just and e-reader, you're getting more out of this device for about the same price. If you're looking for a tablet just to get into owning a tablet, you're spending less than you might otherwise and still getting a decently reliable machine. And if you're a developer, then definitely Yes! This device has so much room to grow that you would have all kinds of fun exploiting this device.

    ...Sorry if I've made anyone's eyes bleed! ;)
    badankles likes this.
  5. darndot

    darndot Member

    Great news Cool_spot. Sounds like we wanted the tablet for the same reasons.

    My tracking number showed up on the Merimobiles website today. I ordered mine on the 16th of aug. Can't wait to try mine.
  6. badankles

    badankles Well-Known Member

    thanks for the review. good stuff. how is the loading of web pages, scrolling and zoom? speedy and smooth?

    i have the augen and it's stutters quite a bit and not evenly sensitive throughout the whole screen.

    edit: i just read the site's spec for it and it says GPS works under both android and windows.
  7. weewullie

    weewullie Member

    if you go to spare parts and turn off compatibility mode and most apps will run full screen
    CooL_SpoT likes this.
  8. CooL_SpoT

    CooL_SpoT Well-Known Member

    Awesome tip, worked like a charm!
  9. CooL_SpoT

    CooL_SpoT Well-Known Member

    I haven't noticed any un-evenness over the screen at all. Scrolling is relatively easy. Once I got used to the idea of using my fingernail for most things, the device got much easier to use in general. Keep in mind, though, that this *is* a resistive screen. It's a very good resistive screen; better even than I expected, but you're not going to get the light-touch control of a capacitive screen.

    Web pages load relatively quickly. There's a few seconds wait, but not enough to get frustrating. And I haven't used zoom too much at all. No multi-touch on a resistive screen, so you're either stuck with the zoom buttons at the bottom of the screen, or the double-tap method, which I use far more frequently. Those times that I was zooming into web-pages, it was smooth quick enough for me, no complaints.
  10. darndot

    darndot Member

    I got my A81-E today. After having bad tracking numbers, and the device setting at St Louis because the address they put down was totally wrong.

    My wife summed it up pretty good. It looks and feels like a big GPS unit.

    Am running a custom rom over from Slatedroid. It is not half bad.

    Half of the applications don't show up in the market. I am going to have to figure out how to get the apps I want.

    I am comparing it to a hero phone. The device is fairly snappy.

    Will it replace my laptop, mp3 player, the kid's dvd player, and gps? No, but may the ones out for black Friday will.

    Would I buy it again? yes, if it didn't take a two weeks and a several emails to get one.
  11. friedje

    friedje New Member

    Bought it from Merimobiles.
    received email with tracking number.
    It never showed up on DHL.
    So i mailed them and then got a new tracking
    number which showed up as picked up that very same day ????

    Anyway, received the unit a few days later.
    Now the firmware is a bit buggy (2.2). and some things don't work.
    But as said, it appears there is a lively community and there are updates
    every 2 or 3 days. The screen works good. It is advisable to have all your
    apk files around, because after a firmware update you never know what
    apps you get (or loose).

    I got gps running full screen (motonav Igo8). I also got bluetooth up and running. Wifi works flawlessly. I am just a bit concerned on battery life.
    For now i don't get more then 2 hours out of my 3000mAh.

    And one warning: never enable : "airplane mode" in the settings, or you will have to reflash firmware, since you can't toggle it back.

    more news in a few weeks.

    I can recommend this unit to ppl who are not afraid to experiment a bit and
    wait till the 2.2 port will be perfect.
  12. Cuautemoc

    Cuautemoc New Member

    Last week I took the plunge and bought my Witstech A18E from Merimobiles. Received the product within 1 week of ordering it.

    The unit was able to connect flawlessly to wifi, access the internet, play videos from Youtube, etc. I have been able to access and install a couple of widgets. The Adobe reader comes pre-loaded, but does not provide any bookmarking capability, remembering where you left off, etc. So I really need a decent ebook reader too. Unfortunately, I cannot access the Android Market and more specifically find the Laputa ebook reader.

    I am curious if anyone knows of any work around so that I can connect to the Android Market and/or help me find an alternative install location for Laputa.
  13. Martimus

    Martimus One bite at a time... Moderator

    According to the Witstech forum over on Gadgets & Tablets the fix for the Android market is to modify the build.prop file to make it think your tablet is supported. The modification also requires root access.

    Also, you may be able to download Laputa directly to your tablet from getjar.com:

    Download Laputa Book Reader for Mobile

    Worst case you might have to select an android device on it's list of supported devices when it asks you what type of device you are downloading to. It says it supports the Archos 5 and the Droid/Droid X/Droid 2.
  14. darndot

    darndot Member

    Slatedroid had custom rom with root access based off the newest release.

    Finding apk so far is the worst part.
  15. CooL_SpoT

    CooL_SpoT Well-Known Member

    Is that the 90 day trial version, or the full version? If it's the full version, do have a link for download?
  16. zerozed

    zerozed Active Member

    I don't think I've seen anyone mention this on this thread, but if you guys haven't installed Aptoide as an alternate market, you really should. It lets you load a number of repositories...you just have to google for other repositories. Aptoide can be downloaded from appbrain or directly from the website here: aptoide
  17. zerozed

    zerozed Active Member

    dupe post; ignore me
  18. Medic005

    Medic005 Well-Known Member

  19. Martimus

    Martimus One bite at a time... Moderator

    As seems typical with many of my ideas anymore, I got the brilliant idea tonight to try to upload the new firmware image (0832) on my Witstech A81-E tablet. I formatted a 1gb microSD card and dumped all the necessary files on it, powered down my tablet, connected the AC power adapter, and then attempted to boot it up per the documentation (holding the left volume button and the power button). Nothing happened. I tried holding both buttons down for 15 or 20 seconds and nothing. I then tried to boot the tablet using the power button and that wouldn't work either. I ended up having to pull the battery and replace it to get the tablet to power up.

    Since I really don't want to ship this tablet back (or eat the cost of the tablet), does anyone have any ideas how to get this tablet to boot properly so I can upgrade the firmware? Has anyone ever heard of an app that will drop the tablet into it's upgrade mode?
  20. weewullie

    weewullie Member

    you have to format with the proper programm.go here and it will tell you how to do it.........bill
    Martimus likes this.
  21. Martimus

    Martimus One bite at a time... Moderator


    Thanks for the suggestion! I finally figured it out. The issue I was running into was actually a timing issue. When I attempted to load the upgrade I hit the left volume button immediately followed by the power button. This, at least for my tablet, was the problem. To get the upgrade process to work I found that I needed to hit both buttons simultaneously. Sooo simple... yet so aggravating at the time.

    And to compound matters, the new version of Android loaded on the Witstech web site turned out to be the wrong image. For some odd reason Witstech posted an Android 2.1 image on their forum in a thread indicating that it was Android 2.2 (0831).

    I was, thankfully, able to download a copy of the correct Android 2.2 (0831) image from the Digital8 forum.
  22. weewullie

    weewullie Member

    if you go to the bottom of that page you will find the latest update there....bill
  23. Medic005

    Medic005 Well-Known Member

    Just un-boxed my Nationite-MIDNite and playing around with it. Will have to get use to the touch screen, though.

    [​IMG]
  24. weewullie

    weewullie Member





    enjoy!!!!!!!!!!!!!:D:D:D:D:D
Loading...

Share This Page