1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

wm8650 I turn it on and only blue power led comes onSupport


  1. kwest799

    kwest799 New Member


    I bought a wonder media wm8650 it worked fine the ay I got it but the next day after charging overnight. I unplugged it and pressed the power button the only that happened was the blue LED lit up and nothing else. I have not dropped it or anything like that I hsven"t even downloaded on to it yet! I would really appreciate any help I can get.
    Thank You
    Kevin

    Advertisement
  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Welcome to the forums! :)

    It sounds like you may need to replace, but I'll move to the WM8650 forums where other users may be able to provide assistance.
  3. tannim

    tannim Active Member

    Generally best not to recharge these things overnight. WHen it's done charging and you're not using it, unplug it.

    Turn it on, press a pointy thing into the reset button for about 30 seconds(or read up on how to do that). Turn it off, turn it on. See what happens.

    Then contact the seller about getting it replaced when that fails.
  4. Rabid1

    Rabid1 Well-Known Member


    You might want to try the reset on the bottom of the tab. A small pin should do it. Or you can try flashing new firmware. Contact your seller and see if they have a link to get the stock firmware or search Uberoid in Google. You did nothing wrong by charging overnight you should be able to leave theses plugged in 24/7 if you want to.
  5. gerberbd

    gerberbd Member

    same problem with me. ples some body help up!!!!!!!!!!!!!!!

Share This Page