WonderMedia WM8650General


  1. ndh777

    ndh777 Well-Known Member

    If we do have the same tablet, the link I used help me best. The downloads from the forums didn't work for me for some reason. Here is the post that I used: WM8650_1.3.0_HoneyCombMOD_20110510-HcH.7z | Game Front or Uberoid_WM8650_2.2_v1.2.2_NL_20110414_8-HcH.7z

    If I'm not mistaken, one of those links from markdmac was the one that helped me. I believe it was the second link from MediaFire although I am not sure. I downloaded the file and installed it just like everyone else had posted. You can find his entire thread by going to the first page of this thread where the download link is as well as extra information that might be useful to you. Here's his post in entirety:

    I believe that these are the instructions that I used to install the ROM onto the tablet. If this doesn't work, let me know and I will see if I can find another method that I probably used.

    The links from TechKnow didn't seem to want to work on my tablet for some reason.

    If Mark is still using the forum, he seems to be the absolute best at getting these tablets to be rooted correctly. If not, I'll try to help you as best as I possibly can.

    If these instructions don't help either, I would suggest heading over to TechKnow's website and seeing what kinds of information they have. The guy who runs that forum is a genius and created the hack and is regularly on the forum. He also created a thread there that details how to install the ROM which should be the same exact method that we use, that's if you don't want to wait around for us to get back online or something.
  2. flandurka1

    flandurka1 New Member

    I just had to write to say thank you to all! It took me all day (as I'm such a newbie) but I used the Honeycomb link and actually did it! Can't believe it! Couldn't have done it without everyone's responses in here. :)))):D
    ndh777 likes this.
  3. smurfie_y

    smurfie_y New Member


    I have a 9.7" Wondermedia
    Wm8650
    Android ver 2.2
    Kernel 2.6.32.9-default
    Generic-eng 2.2
    Froyo 1.1.1-20110217.154319
    Blue LED
    Black audio jack.

    I need the correct ROM for this tablet please ?!?! I do not want to brick it by using the ROMs in this thread, as they are for 7/8", and I have a 9.7".

    Any help would be appreciated as when I boot with M008S ROM, I get the screen that says WM8650 Android 2.2 upgrading....... , and there it hangs.
  4. ndh777

    ndh777 Well-Known Member

    It sounds like you have the same tablet that I have. I would recommend downloading this link: Uberoid_WM8650_2.2_v1.2.2_NL_20110414_8-HcH.7z which was the one that worked for me.

    How long did you leave the tablet on when it said "updating"? It took a few minutes before mine was finished. The best thing to do is when updating and stuff like that takes you a long time, do overnight while you sleep. If you wake up and it is still "updating", something went wrong. In very rare cases, like when I rooted my HTC Evo 4G, it took me over 3 hours to root when rooting only takes about 30 minutes at top usually.
  5. smurfie_y

    smurfie_y New Member


    Thanx. Downloading now, and will report back. Just to confirm - this should work on the 9.7 inch ?
  6. ndh777

    ndh777 Well-Known Member

    I'm not sure as to the exact size, but just about everything else you mentioned seemed exactly on point with the one that I have.
  7. smurfie_y

    smurfie_y New Member


    Did not work. I only get a black screen. Left it for the whole veening - still the same. Guess I'll have to keep searching...................
  8. ndh777

    ndh777 Well-Known Member

    I'm sorry. Well, keep looking. I had to try about 2-3 before I finally found that one that worked.
  9. mzstaingang

    mzstaingang Well-Known Member

    Hello i just my tablet trying to figure out how to get this thing working.It has a blue light and its 2.2 and has 3g and wifi im trying to root it and get a new rom.Im also trying it see if its a app to get it working with tethering.
  10. ndh777

    ndh777 Well-Known Member

    Go up a few posts and try the link I included. If it doesn't work, please let me know so I can find out if that one is the one that worked or not. If it doesn't work, please let me know and I'll try looking for a solution. It appears that you and I have the same model. If it doesn't work, it should just not work. It shouldn't destroy your tablet or anything.
  11. mohammad.sham

    mohammad.sham Member

    hey dude,

    I am using Wondermedia WM8650 ver. 2.2,
    kernel 2.6.32.9

    I want to update the OS, can u tell me which is the latest version and how to do it.

    Reply me Plssssss
  12. ndh777

    ndh777 Well-Known Member

    An update to this device? I doubt it. My root is kind of an update but kind of not. It looks newer and runs slightly faster. Read through the posts to see how to root your device or check out the TechKnow forum or ask the guy above as he claims to be one of the creators of the tablet.
  13. mohammad.sham

    mohammad.sham Member

    @ndh777

    yup, my tablet works good, it has no prob. then also if there is an update pls let me know. Can u tell me ur talking of which person, who is expert in this type of tablet.

    and moreover I want to ask that plss anyone can tell me what their tablet gives as a indication when it gets fully charged, let be green LED or Blue LED.

    Thanks
  14. ndh777

    ndh777 Well-Known Member

    JasonWangCN claims to be the developer of this tablet. But markdmac is really good at rooting and knowing lots about this device as he has experienced many problems with the device and done lots to his. He's been one of the big contributors to this thread we are on.

    Well, mine is hard to tell lol I just take it off the charger and it'll say on the screen whether it is fully charged or not. I have the Blue LED, 3G one and it turns a slight redish color but mine doesn't notify me when it is done charging via the light.
    mohammad.sham likes this.
  15. mohammad.sham

    mohammad.sham Member

    ok, can u tell me how much time it takes for your tablet to get fully charged ? mine will get fully charged within 2Hrs. after that i will blink for sometime and then it gets off.
  16. ndh777

    ndh777 Well-Known Member

    What did you mean by the last sentence? I don't quite understand what you are trying to say when you say "after that i will blink for sometime and then it gets off"

    To be truthful, I've never actually sat there and checked the time it takes to charge this tablet let alone any of my devices now that I think about it. I usually just put it on the charger every night and let it charge overnight.
  17. mohammad.sham

    mohammad.sham Member

    Sorry, by mistake " T " was not typed.

    " after that it will blink for sometime and then it gets off "
    ndh777 likes this.
  18. ndh777

    ndh777 Well-Known Member

    LOL funniest sentence typo! :D

    Um, I'm not sure. My tablet light doesn't blink at all.
  19. mohammad.sham

    mohammad.sham Member

    Ha ha ha ha,

    see this link it says they have Android 3.2 with many new feature, But as u know I am totally new to Android. I am not getting a bit from that site. Please help to get that version.

    Android 3.2 Platform | Android Developers
  20. ndh777

    ndh777 Well-Known Member

    Yeah, one of the common problems with Android is that even though a newer Android firmware is released, some devices still will not or never get the update.

    On our tablets, we have a stock Android 2.2 if I remember right. As far as I know, there are no new updates for us to get. If you'd like to check, go into Settings then go down to the very bottom and click "About device/phone". In there should be something about firmware and/or updates. Try telling it to search for the latest update.

    The only person here who would know for sure would be JasonWangCN if he really is the developer of this tablet. I would try sending him a private message or some other type of message to get his attention and ask him if they have released a new Android firmware or any new updates to the tablet and how you would go about installing those new updates.

    If he doesn't respond or you'd like a different way, try contacting the person who sold you the tablet and seeing if they can contact someone who can ask for you or try searching the web for a contact number/e-mail/etc. and asking a company representative outright.

    They may have one, but I doubt it as this is a pretty cheap tablet.

    When I rooted my tablet, it appears as if it is running Android 3.0 in the User Interface and all but I'm not exactly for sure if it is the real Android 3.0+ firmware or not. It does run much more smoothly and much more faster than when it wasn't rooted.

    If you don't know what rooting is, I can explain it further if you'd like.
    mohammad.sham likes this.
  21. mohammad.sham

    mohammad.sham Member

    Ya sure ur most welcome to teach me, I was going to ask you what is meant by rooting ? Is it same as what we call formatting in windows ?

    pls chk this one...........

    How To Install Honeycomb on Android Tablet | AndroidOS Tablets

    it also claims that they have new update and the interesting thing is that, they took the name of our Tablet WM8650.

    pls chk it and let me will it work. as i have downloaded it but afraid of trying it.
  22. emilylane1

    emilylane1 Member

    Hi all, just wanted to share the download I was given that has turned my wm8650 from total trash to an awesome little unit.
    I have the 7" 3g model, 3g external dongle, not 3g sim slot.
    Blue led light, silver back, 9v model. It was only running the stupid chinese app market and would not sync with google or gmail etc but after a simple download to a micro sd its now working just like my samsung galaxy phone! Here is the download link and the simple instructions that were given to me:
    DOWNLOAD THE FILES FROM THE LINK - http://173.255.228.138/~rogercalver/Slatedroid Singularity M009s FINAL Firmware/Slatedroid Singularity M009S Final v5 (WMT1.5.0 Based).zip


    UNZIP THE FILES
    TRANSFER TWO FILES TO YOUR MICRO SD CARD

    Transfer "wmt_scriptcmd" and "FirmwareInstall" on to the sd card.

    Those 2 things should be sitting next to each other on the main directory.
    Turn your tablet off and plug it into a power point. Then insert the sd card and turn it back on. It will begin flashing the device and installing a new firmware/operating system. It will tell you when to remove the sd card. When you remove it, the tablet will automatically reboot. The first boot always takes a little while so don't be alarmed. Just wait for it to boot up.
    If your tablet gives you the options of a "launcher", mine came up with 3 options and i was advised "LauncherPro" was the pick of the bunch and fastest and so far I would have to agree.
    After choosing the launcher my tablet was able to access the normal android app market, i was able to sync my google account and gmail, the whole tablet just ran faster and smoother.
    I did not write the ROM so cannot answer any sticky questions on its details, all I can tell you is it has this cheap tab running very sweet and I hope sharing it may help others who are tearing their hair out like i was! :)
    Kindest Regards
    Lisa in Oz
    ndh777 likes this.
  23. ndh777

    ndh777 Well-Known Member

    I will check out that link later today and come back here and tell you what it says and if it is legit or not and how to install.

    But basically, rooting is removing security that was pre-installed on the Android device.

    For example, I have another Android device, the HTC Evo 4G. This unit comes from HTC and Sprint and Sprint and HTC have loaded all sorts of junk into the phone. This junk is stuff like apps that I don't need or want and can't get rid of. Sprint has also added some security to the phone that makes it so that I can't use the "wifi tethering" feature without paying an extra $30 to them every month.

    So what rooting does is basically unlock that lock that the developers put on the device. It basically puts you in control instead of Sprint/HTC/etc. You are then able to do whatever you want with the device and on our tablets, we are able to add an American version of the Android Market or other things that it didn't initially come with.

    Rooting also allows us to install what are known as ROMs. Each one of these ROMs allows us to customize the interface of the phone in any way we like. Many developers of these ROMs have taken other Android firmwares like Android 2.0, Android 2.1, Android 2.2, Android 2.3, Android 3.0, etc. and made them available for other phones that the initial developer did not intend to be put on the phone. So on our devices, once you root it, you are able to install and uninstall anything you'd like that you don't like or that you may like.

    It's like having a car and ripping off the speed limiter. It allows you to set the speed you want.

    I just skimmed through that link you sent me and it seems legit. I'd say go for it.

    I tried using a couple of different root methods but none of them worked on my tablet until I found the right one. When those didn't work, it simply just froze. Nothing bad happened, just a freeze. If the list says that it will work, and it seems good enough to you, I'd say go ahead and try it. I may try it myself just to see but not for a while. If you do try it, let us know how your experience was.

    From the way they describe the Android 3.0 version that you can install, it sounds similar to a root in that you don't have all that unnecessary junk on it. If you do install that update, you may not be able to root via our methods. But that's a maybe.

    Thanks for the extra tip!
  24. mohammad.sham

    mohammad.sham Member

    @Ndh777,

    I am now just with a box. The link which i gave you, i followed it now I am with a small box.
    It did all the steps and now after switching it on it keep shouting UBEROID............

    Now, its a big headk for me. Earlier it was good, no problem was there. Just I did fingering. Any help from ur side to get back to my old OS.
  25. ndh777

    ndh777 Well-Known Member

    So it didn't work? I believe there was something in the link that explained what to do if your install wasn't successful. I'll begin looking on the article and get back to you if I see anything that would fix the issue.

    Try letting the device run out of power or turn it off if you can. Once that is done, try starting it up again.

    Usually if something were to go wrong, I would use a .zip file known as Caulkin's Format. Unfortunately, I forgot that our tablets cannot access the HBOOT or I can't remember how to access it so that won't work unless I can figure that out.

    If that doesn't work, there may be a solution elsewhere online and I'll begin searching tonight and hopefully have a solution tomorrow.

    When my roots didn't work, it simply didn't work and restarted and there were no problems. For this, I've never heard of such a problem happening. But don't worry, your tablet is not destroyed.

    You could also try redoing the process to see if you may have done something wrong along the way as that can sometimes happen. Be extra careful when installing the update this time making sure you don't skip any step.

    Hopefully I'll have the solution tomorrow.

Share This Page