Won't auto-connect to my Bluetooth handsfree unit (Jabra Cruiser2)Support


  1. jaydee77ca

    jaydee77ca Well-Known Member

    I have a Jabra Cruiser2 bluetooth handsfree unit in my car. It worked great with my Galaxy S. It works with my Galaxy S3 but with one issue: it won't auto-connect.

    I went through the whole pairing exercise and the Galaxy S3 says that it's paired. The first time I paired it, it connected and I was playing music and taking calls through the Jabra. Then I left the car and turned off bluetooth.

    When I got back in the car I enabled bluetooth on the GS3 and hit the connect button on the Jabra Cruiser2 but nothing happened. Normally with my Galaxy S it would connect again and everything would work. But not the GS3, nothing happens. If I go in to Bluetooth settings on the GS3 it shows the Jabra Cruiser and says that it's paired. But it doesn't connect.

    If I hold in the Cruiser2 button to force it in to pairing mode again then it pairs with the GS3 again and connects and then everything works again.

    With my Galaxy S3 sometimes if I wasn't out of the car very long it would even automatically re-connect without me having to even hit the connect button on the Jabra Cruiser2.

    It's incredibly annoying to have to force it to re-pair every single time I get in the car.

    Does anyone know how to get it to just automatically reconnect when I press the connect button on the Jabra Cruiser2?

    Advertisement
    :
  2. jimbo1mcm

    jimbo1mcm Well-Known Member

    I am having a similar kind of problem with the bluetooth connection in my Benz. I have a Viseeo module. It seems to work only when I have my S3 out of the screen time out mode and actively on as I approach and get into my car. As I open the door, the Viseeo Module starts looking for bluetooth devices. If my S3 is in sleep mode, it doesn't connect. When I have the phone active and move into the car, it connects and downloads contacts so I can use the handsfree steering wheel controls. So my present solution is to just click the phone on prior to getting into the car. My previous, IP4 connected automatically!!
  3. jaydee77ca

    jaydee77ca Well-Known Member

    Further to my issues, it's not just that it won't auto connect, but it won't connect at all.

    When I turn on bluetooth on the GS3 it brings up a notification saying bluetooth devices available. I select the notification and it takes me to the bluetooth settings screen where it shows the Jabra Cruiser2 in the list as Paired. I tap the Cruiser2 and it says "Connecting..." for a few seconds, then it goes back to "Paired" and nothing happens. If I tap on the cog beside the Jabra Cruiser2 then it takes me to the settings where "Call audio" and "Media audio" are unchecked. If I try to check them then again it says "Connecting..." for a few seconds and then nothing.

    This is all while holding the Cruiser2 in my other hand right beside it.

    The only way to get it to work is to hold the button on the Cruiser2 until it goes in to pairing mode, then tap the Cruiser2 on the GS3 and it pairs again and then connects and everything works.

    What the heck?
  4. jaydee77ca

    jaydee77ca Well-Known Member

    It looks like this managed to get resolved. I went to the Jabra site and on there it mentioned that you can reset some devices by inserting a thin object in to a hole on the unit. I couldn't find a hole on the unit but I figured there might still be a way to reset it. I started holding down different buttons to see what would happen. I got a language setting menu and then after fiddling a bit it connected to my Galaxy S3 but this time on the Galaxy S3 I got a prompt saying that the Cruiser2 was requesting permission to access contacts on the phone. I said "Ok" to the prompt and the Galaxy S3 connected to the Cruiser2. Since that was a different interaction than I had before I wondered if it had maybe resolved my issue. So to test I turned off Bluetooth on the GS3 and it disconnected. After a few minutes I turned Bluetooth on on the GS3. I got the same "Bluetooth devices available" notification. I pressed the connect button on the Cruiser2 and lo and behold it connected to my GS3! No need to enter any menus on the GS3 or anything! So, my theory is that the Cruiser2 was somehow still linked only to my old Galaxy S Captivate and in fiddling with the buttons I somehow managed to reset it so it linked to the new Galaxy S3. Now it appears to work as desired!
    Knoll42 likes this.
  5. craighwk

    craighwk Well-Known Member

    I had a similar problem connecting mine to my Subaru, but found out I had to use the steering wheel/voice controls to pair the phone, rather than using the physical knobs on the head unit. Now it auto connects every time.

    Hopefully this will help someone.
    nooaah likes this.
  6. nooaah

    nooaah Well-Known Member

    Interesting. I'm having the same issue with my 2012 VW GTI. I'll have to try this. Thanks!
    DukeLeto5070 likes this.
  7. SBdrumz

    SBdrumz Member

    Same issue with my jawbone icon. There must be some secret to auto-connecting that we're not aware of.
  8. DukeLeto5070

    DukeLeto5070 New Member

    I can confirm this. I thought I had tried everything. Used the steering wheel/voice controls in my WRX to pair my phone and now it auto-connects. Awesome!
  9. kb5

    kb5 New Member

    I just bought a Viseeo MB-4 for my Mercedes and could not figure out how to have my Droid RAZR auto connect (to be able to call out) until I read this thread. Thanks for posting the solution to wake up the phone before getting in the car. I have a ticket in to Motorola to see if they have a solution to why when the screen is off on the phone it will not send calls out. On my Command screen it shows the phone is connected and paired, but if I don't wake up the phone before getting in the call I can't call out.
  10. Knoll42

    Knoll42 New Member

    Thanks for this. Got me in the right direction till issue resolved. I had to hard reset Jabra first by holding call/end + Volume up + FM at the same time, then switched off immediately after the pairing mode announcement.

    I think it is a permissions issue with Jabra needing access to phone contacts. If it isn't granted permanently, I guess the phone has problems accessing contacts next time around and gives up trying to connect. Hence why the request pops up during pairing. I ticked 'don't ask again' before pressing OK. Plain sailing after that.
Loading...

Share This Page