Wont charge/Wont connect to PCSupport


  1. Scheith

    Scheith New Member

    I have a T989 that will not connect to my PC. When i plug it in to a charger it gives no notification that it is charging( phone being on or off). However i can drain the battery turn on the phone and as i should it powers down due to dead battery but when i do this and plug it in it stays on like it is receiving a charge but still acts as if it is not charging. What is going on?!

    Advertisement
    :
  2. Atma

    Atma Well-Known Member

    Welcome to the forums Scheith :ciao:

    Have you tried a different cable? If you have some compressed air, also try blowing out the port on the phone.
  3. Scheith

    Scheith New Member

    haha Thanks

    Yeah ha ha I've tried five different cables, all have been tested and proven to work.
    I also tried cleaning out the charging port.
  4. Atma

    Atma Well-Known Member

    If is still under warranty I would take it to T-Mobile. You might try a factory reset and see if that helps, although it sounds more like a hardware problem than software.
  5. Scheith

    Scheith New Member

    Yeah haha she is a little past warranty...I tried a factory reset and hard reset...Do you think a new micro USB port would correct this?
  6. Atma

    Atma Well-Known Member

    Possibly. At this point you don't have much to lose. You might try going to a Tmo store and see if they have a new battery you could just test with, or maybe they have some way of testing the port.
    Scheith likes this.
  7. Scheith

    Scheith New Member

    I tried a battery that has been tested and is good but it had not effect. Yeah thats not a bad idea on seeing if they can test it. Ive been trying to charge it and it has gained some charge though the phone does not recognize it is being charged.


    Just out of the blue the phone started charging, i hasnt been moved for an hour
Loading...

Share This Page