1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support Won't connect to internet after coming out of sleep


  1. theFan667

    theFan667 New Member

    Hi,

    I have the following simple setup:
    - Netgear DG834G v5 modem/wireless router
    - 1 LG Optimus Black (P970) running android 2.3.4.
    - Win7 PC connected via ethernet cable to modem/router

    The android phone is using WiFi to connect to the modem.

    The problem is that when my phone goes to sleep, then i take it out of sleep, the wifi reconnects to the modem but i don't have internet access. What i do now is disable wifi on the phone, then re-enable and i can access the internet.

    It's annoying to say the least.

    There are apps that basically keep your wifi enabled during sleep by disconnecting/reconnecting but i'm going through a full battery in less than 24 hours which is worse than the original problem.

    Any idea why my LG phone is not reconnecting to the modem properly?

    Advertisement
  2. Digital Controller

    Digital Controller The Real Bass Creator Guide

    There is a setting in your device that keeps wifi on through sleep.

    By going into the Wifi options you can set it to "always" stay connected. This might help, but with the battery issue, hmm. Have you tried restarting your router at all, and then see what happens?

    Are you using any apps that stop the wifi connection when the device is asleep, like Juice Defender?
  3. theFan667

    theFan667 New Member

    Thanks for the reply.

    I've always had that setting enabled that keeps wifi on during sleep.

    What i've done is i tried out a router (actually a Sonos ConnectAmp) connected to the netgear modem then connected my phone wirelessley to the router/sonos and the problem is gone so it must be my netgear modem/router.

    Tim

Share This Page