Won't connect to my router via WiFiSupport


  1. My HTC Hero can detect my router, but when I try and connect nothing happens. The dialogue box pops up asking for the WEP key, I put it in but nothing happens.

    The router and phones wifi works though because I have another pc connected through wifi and I went to mcdonalds and it managed to connect to their hotspot.

    Ive tried 64bit wep, 128bit wep, wpa/wpa2, ive also tried it disabled along with the routers firewall disabled but nothing seems to work. My router is a Belkin F5D8636-4

    Any thoughts?

    Advertisement
    :
  2. daleoffret

    daleoffret Member

    I have had problems connecting a Blackberry 8820 to a Linksys router. The problem I found was the use of WPA or WPA2 with AES type encryption. I had to use TKIP encryption instead of AES. After I changed to TKIP, I was good to go.

    TKIP has recently been hacked by Japanese University researchers. (But I still use it at home. Don't tell any war drivers.)
  3. Thanks for the reply but that didn't work :(
    It's supposed to say its connecting or obtaining address but nothing happens at all, it just goes back to the screen showing available routers.
  4. daleoffret

    daleoffret Member

    Two there things to try, though they may be silly.

    Does the belkin wifi router have other wifi devices working on it?
    Do your phone successfully connect to other wifi networks with you then being able to browse the internet and such?
  5. Yeh, i have another computer that works on the wifi, and my phone manages to connect to the wifi at mcdonalds, but not at home. Also my friend who also has a HTC Hero can't connect to my router, but he can connect to his at home.
  6. daleoffret

    daleoffret Member

    Don't know then. Maybe try another router if you can land one used or cheap. :(
  7. I bought this one not long ago aswell :(
  8. kape

    kape Member

    I'm having a similar problem. My HTC Magic used to connect to my WiFi at home and all of a sudden it won't connect anymore. I haven't changed anything on the router or the phone. I too am using WPA with AES encryption. My router is a D-Link WBR-2310. I have three other devices successfully connected to the WiFi. I've also successfully connected my HTC Magic to other WiFis.

    In the Router's log it says Authenticating... then Wireless PC Connected, then exactly 60 seconds later, it says Authenitcating... then Wireless PC Connected and so on. On the HTC it keeps telling me the password is incorrect, but believe me, I've tried so many times I would have gotten in correct even if just by luck.

    Any ideas what it might be? This is really frustrating.
  9. ukherouser

    ukherouser Member

    If you have an N router turn it off so it only uses b and g. The Hero isn't compatible with N routers.
  10. elliot

    elliot New Member

    Hi, I'm also unable to connect to my wireless router (Siemens Gigaset SE587) with my HTC Hero. It was fine the first time I tried, I was able to surf the net etc but then the second time I tried to connect - Nothing. Basically I tap the network, enter my WPA2 password then nothing happens!

    I am able to connect to my uni wifi but at home I get nothing. I thought it might be the router not giving me an IP or something so I tried using the static IP option and still nothing.

    I dont understand. It worked for a couple of hours then stopped. All my other devises connect fine and I've never had an issue with the router.

    I've also tried turning off the security so the network is open and I get the same problem. This leads me to believe its something to do with the router not wanting to connect to me rather than a problem with the type of encryption. Also it has no support for N so I can't see how that would affect it.

    Any help would be greatly appreciated.
  11. Sambain016

    Sambain016 New Member

    Hey im new to forum and due to the same problem i found my way here, i was able to connect my htc hero to my wifi the first day however i was having problems making a google account and was unable to even use an account to log in so i wasnt able to get my mail or acces the market so i read online and people suggested to hard reset my phone so i did this and when i reset it and went through all the starting instruction i could no longer connect to my router, like in previous replys i could type in my wep code but when i press connect it doesnt even try to obtain the ip address, i know it should work because i had it working before i reset the phone. i have a laptop connected to the router using the same wep code so i know it isnt the router and my phone also trys to obtain other people ip's when i try to connect to them just not my own i would really appreciate the help :) i hope this is enough information, i havent tried to set the static information because im not too sure how but i didnt think i would have to with me already being able to connect to my router
  12. daveybaby

    daveybaby Well-Known Member

    Never heard this before, but it would explain an awful lot. Do you have a link to more info?

    802.11n is backwards compatible with g and b and a. So surely the hero should work just fine with an 802.11n router, even if it doesnt actually support 802.11n itself - is this due to some flaw in the hero's wifi implementation?
  13. jbryan2468

    jbryan2468 New Member

    Thanks to ukherouser

    Had same problem on HTC Magic, changed my router settings, turning N off so it only uses b & g, wifi works fine now.
  14. Stalker007

    Stalker007 New Member

    I'm replying to this even tho you prolly already figured it out long ago, but since there was no answer I was letting everyone know. If you were entering your password that is not what it is looking for...its asking for the WEP key which you will have to log in too your router to see it. It is a hex format being it will be a mix of several number and capitol letters i think 23 in all, and will be listed under your wirless settings tab and it will be listed as key 1 as there will be several keys listed it is the 1st one in the list. Hope this helps someone. I just got an android intercept and ran in too the same issue and figured out that was the problem.
    redlocs15466 likes this.
  15. Finnbjerke

    Finnbjerke Member

    I have contacted Belkin directly they informs me that the wireless router N1 is "not campatible with HTC" I have the latest firmware from Belkin .. its wireless and useless it seems

    My Belkin Wireless N1 Connects to PCs (windows and Ubuntu) , and other Phones, HTC Desire + Android 2.2 however does not work with this modem.

    My HTC desire Z does not connect to Belkin Wireless router N1, the Belkin support claims they are "not comptabile with HTC" I do hope Android 2.3 can deal with this - its just not good enough. Android 2.1 seems to work with belkin wireless but Android 2.2 does not. Im not sure if its a software or hardware problem or both.

    Samsung + Android 2.1 connects to Belkin Wireless n1
    HTC desire + Android 2.2 does not ..

    HTC desire + Android 2.2 does connect to other wireless modems... rather diaspointing Belkin is not connecting

    I ended up buying another router which iskinda stoooooooooooopid.
  16. senan

    senan New Member

    Hi guys
    I had same problem, but I fixed it by turn the modem off and on, then my Sony Ericsson works just fine. :)
  17. Dad61

    Dad61 New Member

    I registered just to tell you guys this, turn off the 802.11e/WMM QoS. I had the same problem, did all the things everyone else did, pulled my hair out for a week on this, both routers, the Belkin Play and an older Belkin G router. Mine was a tad different though, I had taken the Cable Co. Router/Modem back and gotten a plain Modem and had set up a server and a new network with both these routers on it (big house and garage). I had been on it with my phone before that, apparently the default for that is on, as soon as I shut it off, on one router, bam, I was on, same with the play router. I don't know the tech reasons why, but that's what worked for me ;)
    WilfMoralee likes this.
  18. sam3971

    sam3971 New Member

    Hey guys, this can really help if you did not already know this. Yes N Routers are backwards compatible with B and G wireless devices but that must be enabled. I personally own a belkin N router and there is an option

    Wireless > Channel and SSID

    Make sure the option:
    Code (Text):
    1. Wireless Mode >
    is set to this value:
    Code (Text):
    1. 802.11b & 802.11g & 802.11n
    If you have it to just N you will not be able to use G or B certified wireless devices because the compatibility is not there. Same thing goes for if you have N and B, you won't get G. So try that dude, good luck.
  19. Ruth11

    Ruth11 New Member

    Hi<

    I just got my android 2.2 mini laptop 2 days ago. Takes a lil getting used to< but I love it>

    Problem is! It won't load my blackberry? Even if I use the SD card on it's own it still won't load.. also>> even tho I instlled the bluetooth app a couple times it won't turn opn??? And it says the office (word< excel etc>) are preloaded but I can't find them anywhere and I have been on this laptop for a number of hours now trying to find everything?figure it out and get acquainted with my new gadget> if anyone can answer even one of these i'd much appreciate it.

    Ruth
  20. kduffin2

    kduffin2 New Member

    Hi, My phone connects to all Wi-Fi apart from my own. It is a HTC WildFire and my Wi-Fi is from BT Broadband. It does detect the router and asks for the Password. Once I have written the password it comes up "obtaining IP address" and pretty much stays in this state until I switch the Wi-Fi on my phone off. It doesn't seem to have a problem connecting to other Wi-Fi's and other people in the house have HTC phones which connect to the router fine. I have tried Factory Reset but not too sure about the ins and outs of how the wifi works.. any help would be appreciated.
  21. adastro

    adastro New Member

    I have a Xpeira Arc S and had problems dropping the wifi connection. After an upgrade of firmaware the phone stayed connected.
    BUT after that, everytime I have had my router/modem powered off, the phone won't connect when I power on again.

    To get connected again I have to:

    1) Disable the WIFI security of the router so it is open (no problem connecting)

    2) Put the secutriry settings back [WPA/WPA2-Personal(PSK), WPA-PSK, TKIP+AES]

    The everything works, until next time I power off and on the router/modem.

    My Belkin model is # F5D7633-4
    The firmware upgrade i used was version: 1.00.17, OS compatibility: Any from: en-au-support.belkin.com/app/answers/detail/a_id/2600/kw/F5D7633/r_id/166

    As I don't want my router powered on 24/7 please anybody, is there any permanent solution??
  22. intanet

    intanet Member

    In working with the Craig netbook with Android 2.2 I had a problem with the Wi Fi connecting to my router. I thought it was defective (may yet be) but found a work around. First of all I have a WPA 2 personal level of security on my Linksys WRT54G router. I added my network SSID to the Craig netbook manually and put in the network key but it would not connect. I know the wi-fi is working because I am picking up other networks in my range. My network is in the list too (because I added it manually) but it does not have the icon on the right (looks like a lock on secured networks requiring a key). The other networks have the icon but mine didn't. And also, it reports my router/network as "out of range". Out of range? I'm one foot away from my router while setting this wi fi up. So I figured this to mean that, because I don't broadcast my SSID, it is not picking it up as an available network. OK, I enabled "broadcast SSID" in my router just to check that out and I was then able to connect with the netbook. But I don't want to broadcast the SSID (for security reasons) so I put my router back to NOT broadcast SSID and tried to figure out another way.
    Ok, on the device (in my case, the Craig netbook), in the Android 2.2 Wi Fi settings, I turn the WI Fi OFF. Then I reboot. It's set to enable Wifi by default at start up. For some reason, doing it that way, not leaving the WI fi on when shutting the netbook down but turning it off before shut down, when the operating system boots up the next time and automatically starts the WiFi again, I am then able to be connected to my network. Weird huh? I tried this procedure five times already and it has connected all five times. Don't know why it's like this but all I care about is that I can connect now. Hope this helps someone else.


    P.S Dad61...VERY cool of you to register just to post a help to others.
  23. intanet

    intanet Member

    P.S. Not 100% fix as I'm just learning. I couldn't connect with this method the next time I powered on. But rebooted and then I was able to. This is the third Craig I had trouble with. Two tablets that went back and now this netbook.
    Anyhow...
  24. intanet

    intanet Member

    OK, I got the answer in my situation. Before I brought the Craig Netbook back to RiteAid for a replacement because of this internet issue, I called Craig tech support. Here's what I learned. The agent told me they tested the units and they have connection issues with Verizon internet service because it's Mi-Fi and not Wi-Fi. The agent was actually surprised that I connected at all. I had a Craig tablet for a few days that connected effortlessly. And this netbook intermittently but it still connected at times for hours. They should have that information out front, especially for us New Yorkers, NY being a main service area for Verizon. I got the feeling that two of the units I bought were returns because of fingerprints and apps that were installed when I got it. Maybe that's why they were returned. Geez. It's a jungle out there.
  25. samturner159

    samturner159 Member

    Greetings I just registered to tell all of you with belkin router issues that I solved it very easily no messing about with static ips or anything. Have had a sensation xe for about a week and spent most of that time trying to get on my wifi. my router is about 4 years old so hope this will work for some of you.
    If your htc device has WPS(wi-fi protected setup) in the wireless settings enable it with the wireless on, now somewhere on the back of the router should be a small button with a padlock above it hold, that down for 5 seconds and the padlock symbol on the front will flash and then thats it you should be connected. no need to change any complicated settings. Hope this helps some of you guys out am in UK so dont know if it will be same in the US
Loading...

Share This Page