Won't Go Into Sleep Mode With WiFi On?Support


Last Updated:

  1. clunkercar01

    clunkercar01 Well-Known Member This Topic's Starter

    Joined:
    Feb 14, 2011
    Messages:
    98
    Likes Received:
    6
    Hi All,

    Just got rid of my LG GT540 for a HTC Wildfire S

    One problem I am having though... if I have WiFi connected - the phone won't go into sleep mode.

    On my LG I used to leave it connected to the WiFi and if the timeout was reached for sleep (ie 1 minute) then the WiFi would disengage and the phone would sleep. When I woke the phone the WiFi would then kick back in.

    Am I right in saying the Wildfire wont go into sleep mode if WiFi is enabled?

    Cheers.
     

    Advertisement
  2. brotherswing

    brotherswing Well-Known Member

    Joined:
    Feb 22, 2011
    Messages:
    3,054
    Likes Received:
    1,282
    Not quite. The wifi won't keep the phone awake, but something else is and if the phone is awake the wifi stays on. Something on your phone has what's called a wakelock, preventing it from sleeping. Look for Better Battery Stats in the market, it can identify what has a wakelock, and help you isolate the culprit.
     
    clunkercar01 likes this.
  3. clunkercar01

    clunkercar01 Well-Known Member This Topic's Starter

    Joined:
    Feb 14, 2011
    Messages:
    98
    Likes Received:
    6
    Exceelnt advice brotherswing - I had no idea at all about wakelock. I installed an app I thought may have been messing things up then reinstalled it again and now my phone does sleep as it should.
    Cheers.
     

Share This Page

Loading...