Won't mount phone memory or SD card as disk drive unless I reboot?Support


Last Updated:

  1. Kitten Mittens

    Kitten Mittens Well-Known Member This Topic's Starter

    Joined:
    Mar 14, 2010
    Messages:
    64
    Likes Received:
    10
    I am running one of the leaked 2.2 OTA Roms, everything has been working fine, except lately, as of a week or two ago, the phone won't mount as Disk Drive unless I reboot, and it wasn't a one time fix, I have to do this every time. I noticed that when I plug the phone into the computer, I don't get the message saying "Charge Only / HTC Sync / Disk Drive / Mobile Broadband Connect etc." And yes, I have it set to ask me every time, and I even set the default connection type to Disk Drive, and still I unplug it and plug it back in and nothing. I know it connected okay, the computer recognizes it as HTC Android device or whatever it calls it, and the orange light lights up on the phone showing that's it's charging, but in my computer all that pops up is a weird optical drive that I can't access. Anyone have this problem, and how can I fix it?
     

    Advertisement
  2. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    5,577
    Likes Received:
    1,958
    have you tried on other computers?
     
  3. Kitten Mittens

    Kitten Mittens Well-Known Member This Topic's Starter

    Joined:
    Mar 14, 2010
    Messages:
    64
    Likes Received:
    10
    Not yet, I'm fairly certain it's a problem with the phone not the computer, since restarting the phone fixes it, at least temporarily.
     
  4. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    5,577
    Likes Received:
    1,958
    Try deleting the drivers and install them again or try another computer or try a factory reset.
     
  5. jj36extreme

    jj36extreme New Member

    Joined:
    Aug 25, 2012
    Messages:
    1
    Likes Received:
    0
    has anybody found a cure for this? All the searches that come up are from people who have never had this problem. Not on solution fixes it. Nor have I have seen the origianl poster reply with a fixed. Not trying to be rude but this is getting old. I'm tired of not being able to use my phone properly. It's not the PC. It's not the cord. My boss and I have the same phone EVO 4g. I charge them both at work. Her's mounts as a disk drive mine does not. Nor does it on any other PC i plug it into. Unistalling and reinstalling the drivers will not work. Yes debugging is checked. Yes i have disk drive checked for when i plug into USB. Searching the web this seems to be a very common problem among Android phones yet I have not seen one true solution. Any body that has ever had this problem actully found a solution?
     
  6. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    5,577
    Likes Received:
    1,958
    You said your boss's phone mounts, but weren't clear if you tried using her cord and computer. If you have, the only thing left would be to try a factory reset, other than that it would be a hardware problem. Different pins inside the USB plug are used when charging vs mounting as a drive, so just because it charges does not mean it isn't the cord or port on the phone.
     

Share This Page

Loading...