Won't recognise memory cardSupport


Last Updated:

  1. beeboroach

    beeboroach New Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    4
    Likes Received:
    0
    Bought a new Samsung Galaxy 3 (Apollo).
    I used to use a Nokia Xpress Music with a 4G Micro SD (so I know it works)

    However, when I put the card into my new phone it doesn't recognize the memory card and they message "removed SD card: SD card has been removed. Insert a new one".

    I've tried formatting it to FAT32 and FAT but netiher are recognized by the Samsung Galaxy 3 :confused:
     

    Advertisement
  2. barqers

    barqers Well-Known Member

    Joined:
    Nov 5, 2010
    Messages:
    753
    Likes Received:
    72
    Have you tried a different memory card?
    It could be your memory card port. If it doesn't work with a different memory card and both those memory cards work in other machines, I'd return the phone.
     
  3. beeboroach

    beeboroach New Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    4
    Likes Received:
    0
    I tried someone else's micro sd and it works perfectly so I guess the port is not the problem. I'll continue trying different formats on my 4GB micro sd although the manual says it only supports FAT

    Also, I think it does scan the memory card I have but then it ejects it automatically
     
  4. barqers

    barqers Well-Known Member

    Joined:
    Nov 5, 2010
    Messages:
    753
    Likes Received:
    72
    Hmm, have you tried FAT32 vs FAT16?
     
  5. beeboroach

    beeboroach New Member This Topic's Starter

    Joined:
    Mar 3, 2011
    Messages:
    4
    Likes Received:
    0
    I've tried NTFS, exFAT, FAT and FAT32 but no change...maybe I should just get a new memory card =\
     
  6. barqers

    barqers Well-Known Member

    Joined:
    Nov 5, 2010
    Messages:
    753
    Likes Received:
    72
    That's what I would do. If another one works in that slot then it might be the card. But you said it worked in another phone which is really weird. It may be in the process of dying, with a loose connection. Better not to use it in that case!
     

Share This Page

Loading...