Won't Turn On!Support


Last Updated:

  1. Daryl1992

    Daryl1992 Member This Topic's Starter

    Joined:
    May 7, 2011
    Messages:
    5
    Likes Received:
    0
    I've had my Play for about a month now. But today I've had a massive problem, it was very laggy so I turned it off. Tried to turn it back on and its been stuck on the black screen with Sony Ericsson across it since. The screen will go black, but if I press any button, the Sony Ericsson reappears. Any ideas on how to solve this?
     

    Advertisement
  2. Varking

    Varking Well-Known Member

    Joined:
    Jan 11, 2010
    Messages:
    179
    Likes Received:
    43
    Try taking out the battery on the device, then plugging it into the wall without a battery. After that turn it on and if it loads up, place the battery back inside and allow it to charge for about 25 minutes without turning it on. If it still works than awesome. If not, it sounds like a faulty battery and you may have to take the phone in for repair if a new battery doesn't work.
     
  3. Daryl1992

    Daryl1992 Member This Topic's Starter

    Joined:
    May 7, 2011
    Messages:
    5
    Likes Received:
    0
    Ive just tried this, it wasn't successful, thanks though. Without the battery in, nothing at all happened when I plugged it in. I think the battery's dead, becauuse now with it in nothing happens, and if I try to turn it on the LED flashes red a few times, but as soon as I plug it in it returns to its old state. PC companion won't recognise that there's a phone connected, so I can't try to update it either
     
  4. Daryl1992

    Daryl1992 Member This Topic's Starter

    Joined:
    May 7, 2011
    Messages:
    5
    Likes Received:
    0
    I've reinstalled the software twice with SEUS and it's' done absolutely nothing. Checked the battery and the patch which apparently goes red when the battery is damaged, is white meaning its fine
     
  5. Ncaissie

    Ncaissie Well-Known Member

    Joined:
    May 9, 2011
    Messages:
    230
    Likes Received:
    8
    Sounds like a dead battery. Call Sony for a replacement.
     
  6. Daryl1992

    Daryl1992 Member This Topic's Starter

    Joined:
    May 7, 2011
    Messages:
    5
    Likes Received:
    0
    I've sent it to Sony now, the batterys fine, tried it in my friends Xperia Play and it worked fine. Apparently there's a problem with some files on it, at least thats what a guy in the T-Mobile shop told me
     

Share This Page

Loading...