1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support Won't turn on :(


  1. Declan325

    Declan325 Active Member

    Hi Guys,

    I have a Galaxy Tab 7.7. I hadn't used it for a couple of weeks and went to turn it on but it was dead. Figured the battery was flat so I plugged it in. Got a battery icon with a clock on it and left it for a few hours. I unplugged it the next day but didn't get round to turning it on until a week later. Same thing, it wouldn't turn on so I figured it may have drained the battery again so I put it on charge over night.

    When I was convinced the battery was fully charged (being plugged in for 12 hours) I unplugged it and tried to turn it on. The Samsung Galaxy Tab 7.7 screen comes on and it holds on this constantly. I've tried turning it off and on, holding the power button, holding it with the volume down and hitting cancel to restart it again, holding the power with the volume up. All to no avail.

    Is there anything I can do to get this freakin thing working again? At the moment the only thing I can think of is getting a microSD putting some sort of firmware onto it and trying to install it. I really shouldn't have to though, I can't believe this thing is failing after such little use!

    Any help would be greatly appreciated. I'm really regretting this purchase right now!

    Advertisement
  2. CJeffo

    CJeffo New Member

    Hi,

    I've had a similar problem. It started yesterday, abut i was not able to turn my tablet on. I assumed that it was due to the battery being flat, so i left it on charge all night. When i press the power button the screen just stays blank. Also when i try to enter recovery mode the screen does not respond. The only time the tablet responds is if i hold power and volume down, and then i get the android screen for downloading a custom rom.

    I have rooted my tablet with the root.zip technique and i can't think if that is affecting the system.

    Thanks
  3. BatfinkUK1

    BatfinkUK1 Well-Known Member

    Just checking you are you both using the "original" wall/mains charger not usb or generic? Have you tried leaving it plugged in for boot? If you can get in to recovery mode have you re-flashed the stock firmware?
    If non of the above works I suspect you have faulty units, return for refund or replacement.:(

    There are other reports of non booting tabs etc over at XDA you will also find instructions for flashing back to stock too. Samsung Galaxy Tab 7.7 - xda-developers

    Hope you get them up and running; It's a great little tab.:)
  4. KHKPK

    KHKPK New Member

    I am facing the exact same problem right now!
    I'm very sure that I switched my tab off last night and the charging sound/icon appeared.. I left it to charge overnight but when I tried to turn it back on just now, the screen just remained blank no matter how long I pressed the power button....
    :(
  5. alsemawi

    alsemawi Member

    today, i have the same problem, its has started with a freeeez mode, then suddenly went off... and im sure that the battery has at least 70%
  6. tomcatter

    tomcatter New Member

    Same here. Sure it had plenty of battery life left last night. Tried to power up this afternoon and got nothing, just a cold black screen. Put it on charge for a good four or five hours and still nothing. Can't even reset it via the power/volume combination.
    Waiting to hear back from Samsung, but unless someone can suggest a cure I guess it will have to be shipped off to be serviced. Shame, because it's a great little tablet.
  7. caldwelljt

    caldwelljt Member

    I am having the same problem... (Twice!)... And I am really frustrated, because i like it a lot. I would love it even more if it was stable enough that I could work on rooting, CWM,

    flashing, nandroid, etc. As with any of my big ticket or crucial items, I spent time using the device as intended. Using the device in "normal" mode allows me to weed out faulty equipment

    and a baseline for comparison.

    The first one was going fine initially. I was warming up to the features and performance until, after a few days of flawless use, I was finishing a phone call. I was using a bluetooth,

    headset when, without touching the unit, the call beeped indicating the call was over, and then a few minutes later I reached for the unit, and then... nothing... nothing would make it

    wake-up, reboot, or even indicate it was operating on any level short of dead. I tried every manner of key combinations, connections, and charge/wait/holds/etc.
    a
    I was taken by surprise because I didn't unlock it myself, I had only installed a few basic apps (i.e. tunein, etc). After a while, I got really irritated (mostly because I had paid rush

    delivery). I had wanted it to replace my flip phone on vacation. I had some issues that made returning difficult. After 4 busniess days, a dozen or so phone calls, gnashing of teeth, and

    some refunds; my device was returned and either replaced or "repaired".

    EDIT: I am still kicking myself for not documenting the serial number, "just in case." I was, however, about 95% sure it was a replacement because of some of the particulars of how my

    return process worked.

    A few days after that, I received a replacement. After 4 days it happened again. This time it had only stock apps... i've done almost everything but cracking open the case and seeing if the battery can be unhooked and rehooked to ensure there isn't some kind of sleep issues... i've let it power for 24hrs... i even tried to hook it up to a pc with adb, but it didn't recognize it.

    Is there any kind of recall/known issue im not aware of? and/or is there a way we can find out if there is a range of serial numbers or otherwise indication that a "batch" has issues. I am not looking forward to returning this one, for the same issue.

    -D0c
  8. dfin

    dfin New Member

    guys,

    dont worry.

    just get one set of power bank/pack to jump start/charge your battery(i'm pretty sure your battery is still good). you can find many in market(power bank-i'm using yoobao power bank YB-642-11200 mAh). price like~ USD 40. can charge 2x your tab.

    peace bros.
  9. dfin

    dfin New Member

    due to the battery safety feature, just remember next time
    1. do not let your tab battery utilized till zero power, start charging accordingly.
    2. do not charge the battery too long. (1st one~6hrs, normally~3hrs)

    if happen, then use your power bank/pack mentioned. any brand can do.

    adios.
  10. adriannesabri

    adriannesabri New Member

    Found this thread and my problem solved. tq... just knowing about power bank. will buy it soon.
  11. miki7

    miki7 New Member

    I had this exact problem, when my tablet was a few weeks old too, and just happened on this, which fixed my problem, and haven't had an issue since. Hope this helps!
    My Nexus "goes on strike"
  12. desfry41

    desfry41 New Member

    Hi

    My first post

    My tab wouldn't turn on this morning. I thing the cause was that I left the tab connected to my PC (via supplied USB cable) overnight while both were switched off. I think this completely flattened the tab's battery! I connected the tab to the supplied mains charger (travel adapter) and left it on charge for a couple of hours. Still would not turn on.
    Solution - I reset the tab by holding the power-on switch for 15 seconds, at which point the battery charging icon appeared on screen. What a relief!
    I am leaving it now until it is fully recharged.

    I saw an earlier suggestion to use a power bank to solve the 'won't turn on' problem. Why does that work when the supplied charger does not?

    Finally, at night I always turn the tab off instead of leaving it in stand-by. Is this recommended practice? What do other members do?

    Thanks for reading.

    Keep the faith!
  13. desfry41

    desfry41 New Member

    This happened again today. This time it was during a normal use session and the battery was 80% charged. It just turned off and would not turn on again. I attached the charger cable and held power button for 15 seconds and it started charging. Tablet does not seem very reliable. It's only 3 weeks old and looks as if I am going to have to return it.
  14. alex1028

    alex1028 New Member

    If battery is completely flat, regular USB cable will not charge it, leave it on for a week, whatever. Micro USB adapter works like a charm, or the aftermarket USB cable with charge/ data connection switch. You will see that tithe battery is charging right away.
  15. ce31601

    ce31601 New Member


    What do you mean by a micro usb adapter? Where would I plug one into?
  16. ce31601

    ce31601 New Member

    I left it unplugged for 48 hours then tried plugging it in again. And it seems to be charging now. YAY

Share This Page