Work in progress - scaling video on c03ref/f16ref


Last Updated: 2014-01-07 11:38:31
  1. stane1983

    stane1983 Well-Known Member Developer

    I'm working on it now, stay tuned...

    Advertisement
  2. stane1983

    stane1983 Well-Known Member Developer

    Issue not solved.... For some reason, scaling on both frame buffers must be turned off when reproducing video...

    If anyone solved scaling issue during video reproduction on Amlogic chipset (8726Mx, GB or ICS, doesn't matter), feel free to share :)

    I tried to fix the problem by modifying enable_freescale_MBX, disable_freescale_MBX and GL_2X_scale in LibPlayer/amplayer/player_set_sys.c which are called by mediaplayerservice but with no luck so far.
  3. stane1983

    stane1983 Well-Known Member Developer

    Issue is solved with latest Amlogic sources (Android 4.0.4). I'm impressed by the way, it's bug since Gingerbread.... :)
  4. cheeyee

    cheeyee New Member

    Would you share the method or code that fixes it. Or provide a pointer to where we should look in the gingerbread code.
  5. stane1983

    stane1983 Well-Known Member Developer

    It all goes trough AmPlayer, packages/amlogic/LibPlayer/amplayer/player_set_sys.c. Enable/disable freescale and enable/disable 2x/2xy scale functions...

    See what functions are called in AmlogicPlayer.c inside frameworks/base/media/libmediaplayerservice.

    Idea is to read ubootenv variables instead of default ones...

    Edit: Now I was looking at ICS branch, but on GB sources should be the same, I remember I tried to fix that on gb as well...
    cheeyee likes this.
  6. chaplin_u

    chaplin_u Member

    Hi stane1983 !

    I have this device with f16ref.
    And internal player have wrong scaling as you said.
    How can I solve this problem ?

Share This Page