Root [WORKING]CWM Recovery v5.0.2.8

Discussion in 'Android Devices' started by lMonsterl, Mar 3, 2012.

  1. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    Give all thanks to playfulgod (Donate to him)

    This one is not touched based. You need to use the volume rocker to navigate and the Search button(magnifying glass) to select. Back button works to go back as well.

    Confirmed to run on both Boost, Sprint, and Virgin Mobile versions.

    Open zip and run the according file.

    Make sure phone is ON and debugging ENABLED. You must be ROOTED.

    Notes:
    ==========
    1. Bionic Chronic noticed that if you try running the batch file as admin you will get errors. Run it regular.
    2. Backup and Restore working 100% (dont be scared, I have done both)

    DOWNLOAD LINK
    MIRROR

    If u have issues with the linux script use this:
    Code (Text):
    1. adb shell
    2. su
    3. adb push Files/cwmrecovery.img /data/local/tmp/cwmrecovery.img
    4. dd if=/data/local/tmp/cwmrecovery.img of=/dev/block/mmcblk0p4 bs=4096
     

    Advertisement
  2. thomasmbl

    thomasmbl Well-Known Member
    53

    Jul 11, 2011
    480
    72
    53
    U created a thread for cwm n i created a thread for root for the marquee we are making a difference for this fone n thank you so much playfulgod
     
  3. Bionic Chronic

    Bionic Chronic Well-Known Member
    93

    Feb 18, 2012
    645
    158
    93
    Michigan
    It did work Mad props to PlayfulGod for the time and hard work that you put into the dev of this. And thank you |Monster| for walking me through it!
     
  4. ethanhunteg

    ethanhunteg Active Member
    16

    Feb 22, 2012
    30
    5
    16
    so is this sprint or boost or both?
     
  5. chevanlol360

    chevanlol360 Well-Known Member
    323

    Oct 28, 2011
    2,828
    2,184
    323
    Male
    tech videos/ Dev'ing
    new york
    Both
     
    kevindroid likes this.
  6. Bionic Chronic

    Bionic Chronic Well-Known Member
    93

    Feb 18, 2012
    645
    158
    93
    Michigan
    |Monster| and I have Boost.. Though i think it will work with sprint as well!
     
    kevindroid likes this.
  7. ethanhunteg

    ethanhunteg Active Member
    16

    Feb 22, 2012
    30
    5
    16
    Is there anything that we should have to post over on XDA to check that out first or is there already enough known and enough confidence that it just needs to be tested on sprint
     
  8. Bionic Chronic

    Bionic Chronic Well-Known Member
    93

    Feb 18, 2012
    645
    158
    93
    Michigan
    I am not sure yet if it is tested on Sprint. Though the phones are the same minus the radios I believe. So it will work on Sprint Marquee's if it worked on Boost's Marquee.
     
  9. ethanhunteg

    ethanhunteg Active Member
    16

    Feb 22, 2012
    30
    5
    16
    That's what I meant. I am a sprint marquee user and would be willing to test it if the i's are dotted and the t's are crossed in the same way as it was for boost.

    before I test this should playfulgod take a look at boot and or recovery.img to compare or like the mounts dump that was posted etc? I can just ask over in that thread too, unless you guys already know the answers. And, if you know it's alright then i'll go ahead and test it later on sprint
     
  10. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    the only difference would be with carrier id. your phone may say boost on the lockscreen or notification. the phones are the same.
     
  11. thomasmbl

    thomasmbl Well-Known Member
    53

    Jul 11, 2011
    480
    72
    53
    Monster I had the admin add your thread to the all things root guide
     
  12. sik00

    sik00 Well-Known Member
    78

    Dec 17, 2011
    276
    135
    78
    Indiana
    Installs and boots into recovery just fine on the Sprint Marquee..currently doing a backup now.

    Edit: Restore also worked with no problems, thanks guys..I don't post at xda but I do follow the threads, and I'm happy you guys put in the time to talk to the devs over there. And thank you playfulgod and all others who put their time and work into this. Seems the CWM works for both Boost and Sprint now.
     
  13. ethanhunteg

    ethanhunteg Active Member
    16

    Feb 22, 2012
    30
    5
    16
    So I'm apparently missing a step here because I try and run the bat and get to

    "
    * daemon not running. starting it now *
    * daemon started successfully *
    "
    and there it hangs.

    In the steps at the beginning it lists have USB debugging mode enabled (i do), install all drivers (i installed both driver exes from the driver folder), and that usb internet connection is selected in usb mode.

    I think I'm caught up on the last one perhaps? When I connect via USB I'm only presented with two options either Charge Only, or Mass Storage. I also tried to get at it under settings -> Wireless and networks -> Tethering & portable hotspot -> USB tethering
    However, when I click that I get an error for "Error code 67, Unable to eestabligh wireless data connection. Please select update profile to correct this problem. If the problem persists, please contact the mobile phone company."

    So is that normal? Am I going down the right path, and should I continue by trying to update profile and enable that again or am I on the wrong thing here?

    Thanks in advance
     
  14. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    dont mess with the tethering at all, leave usb on charge only. then try again
     
  15. ethanhunteg

    ethanhunteg Active Member
    16

    Feb 22, 2012
    30
    5
    16
    Okay so I also restarted PC, have tried both cmd prompt as admin and regular and all just hang at the place in the screenshot.

    Any suggestions?
     

    Attached Files:

  16. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    copy adb from the files folder and the .dll's and put them on your desktop.

    run cmd w/no admin
    Code (Text):
    1.  
    2. cd desktop
    3. adb devices
    4.  
    does it display your phone?
     
    ethanhunteg likes this.
  17. ethanhunteg

    ethanhunteg Active Member
    16

    Feb 22, 2012
    30
    5
    16
    No

    The first time I ran it I got the error at the top, so i moved adbwinapi.dll to the desktop as well and ran it again, no devices were listed. I unplugged and re-plugged to a different USB and verified it said USB debugging again on the phone and same result.

    Thanks again for the help
     

    Attached Files:

  18. sdb18sdb

    sdb18sdb Member
    15

    Mar 3, 2012
    15
    0
    15
    can't open file on computer
    help please
     
  19. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    it didnt recognize your phone, its not going to work if u cannot use adb. u need to fix this adb issue before you can install cwm recovery

    you could try adbwireless from the market
     
    ethanhunteg likes this.
  20. ethanhunteg

    ethanhunteg Active Member
    16

    Feb 22, 2012
    30
    5
    16
    Okay I'm going to try the adb wireless from the market next. I went to another computer that had not had android stuff on it before, downloaded the files, installed the drivers, then plugged phone in debug mode in. I got driver unsuccessfully installed. It seems certain things were installed, others not. I attached that screenshot.

    I then tried adb devices with similar result (though this time I ran it from within the files folder as well and got a slightly different result)
     

    Attached Files:

  21. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    i'd restart the computer and run the drivers again the phone one, not modem. Click "repair" see if the rest installs.
     
    sdb18sdb likes this.
  22. ethanhunteg

    ethanhunteg Active Member
    16

    Feb 22, 2012
    30
    5
    16
    oops ... well saw this after I already tried the wireless option.

    I basically had the cwm recovery program going in one command window and in another cmd window did the adb connect 192.168.x.xxx:5555 command while the cwm bat was running (at the place it was hanging before) and it seemed to proceed okay then. It got to "finished" and my phone restarted.

    After it got back to home screen i pulled batt and did vol down and power and got into CWM-based recovery v5.0.2.8. Going to start with backup/ recovery test now.

    Thanks again for all the help. Hopefully if other people are having these driver issues this works for them too I guess.
     
  23. Craptorman

    Craptorman Well-Known Member
    53

    Mar 2, 2012
    216
    90
    53
    How long do you hold the vol down and power to get into the CWM Recovery? I've tried on my Ignite but it never goes into recovery.
     
  24. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    like 10-15 seconds
     
    Craptorman likes this.
  25. Craptorman

    Craptorman Well-Known Member
    53

    Mar 2, 2012
    216
    90
    53
    Wierd. They must be different. 10 seconds it boots normally, 15 seconds the screen just goes blank.
     
Tags:

Share This Page

Loading...