[WORKING]~*how to root micromax a75 *~


  1. ninadchaudhari

    ninadchaudhari What's up !

    Presenting WORKING WAY to ROOT MICROMAX A75

    developed by Ninad (aka, ninadchaudhari)



    Not recommended now .... See other ways in the Sticky !


    As you know this phone cannot be rooted by current popular common exploits
    After a lot of work with almost 5 zips, more than 1Gb of bandwidth and countless hours, finally the phone is rooted ;)


    You can just download the ROOT4.7z A75-ROOT.7z from here:
    EDIT : Updated...

    Presenting A75-ROOT.7z for root A75


    -- This is Mandatory Check the extracted system.img for checksum with HASH TAB

    for
    SHA512 :
    67CFF60EC2ACD7ADC591AF0340443FD669AA18C3A801181688C7398E4D0C9A4FB9116439A0A42EFACFEE2BEAFC1869CDA4989A8B4368A6577D4C84B0059B3B92
    Whirlpool:
    B0DE38CF827A70B16A1AD1482EDC5CB6D4CF445361073B65A7B4FDBE7BD12B6BC98788E57C308E21130E8BEE7A0461BDAC60A39FC9C5692636748E37264C8ED9

    1. -- Now replace this system.img with the one from the update package.
    2. -- Follow the exact way you flash your device from the new update
    3. -- Restart your device
    4. ---

      Updated : No need of wifi and other stuff now !
    • -- Voila , you are ROOTED !
    • -- Wifi Fixed


    Flashing instructions :
    go here: http://androidforums.com/micromax-a75/497925-how-flash-your-a75.html#post3968233


    I will recommend ppl to use ROM -> UB-A75-1 it is much better :)


    Video Tutorial :
    Thanks karthik for this :

    The video is of old version ... new versions launched ...
    http://www.youtube.com/watch?v=y3CFbaK3zHA

    Special thanks for karthik947 (<--- for constantly and promptly trying my last 5 experiments and assuring me that he won't complain even if his phone goes to thrash ;) )
    also :
    Karanpr :)eek: you can find him in this color !)
    abhishek for beta testing the one click wifi fix tools
    Sam for giving the Simple idea of Logcat ( team work yields :p Do not know even after sooo many things i tried just a elementary logcat did'nt click me )
    rudrateja ( for trying the very first experiment ! but later got busy !! :) )


    plz do not quote the entire post

    Advertisement
    :
  2. madhureddy

    madhureddy Member

    thanq
    its worked at last my phone is successfully rooted with this,thanks again brother.
  3. chughgopal

    chughgopal Well-Known Member

    Titanium???
  4. Ankysoni

    Ankysoni Active Member

    hey now tell me what are the benefits of rooting
  5. ninadchaudhari

    ninadchaudhari What's up !

    Yup everything is working awesome
    I had many fixes for it !
    Just download and ya after u restart ur phone do not forget to install Busybox as your favroute Titanium backup requires it
    also you will face slow backups and restore timings as the app and binary i have installed are stable versions so just update the superuser app from Market


    Hope that helps
  6. ninadchaudhari

    ninadchaudhari What's up !

  7. erandevishal

    erandevishal Active Member

    hi ninad.
    i got whats rooting.
    pls will u tell the whole procedure right from the begining,with all required softwares and all.
    i have done nothing yet to my phone.
    thanks
  8. ninadchaudhari

    ninadchaudhari What's up !

    :) A video tutorial is in the progress for complete n00bs ,
    I will soon uploading a package with all the stuff necessary ...
    you can refer the thread for flashing in the same forum..
    pkotenetwork, sajipv and n1newbie like this.
  9. EverWin

    EverWin Active Member

    Hi,
    @ninadchaudhari
    thankyou for your hard efforts, i was able to flash new system.img but to download busybox i was unable to connect my currrent WiFi.

    tried flashing again with no luck then i have flashed back to original New System.img and WiFi works now.

    i am able to enable & insert WiFi password, it stuck afterwards with the message Obtaining ip address.

    Hope you will fix this too soon.

    Thanking You
  10. ninadchaudhari

    ninadchaudhari What's up !

    @everwin , i do not think that might be a problem ...
    as library files have not been touched by me !
    there may be some different kind of local problem
    1.) report if you already have flashed the new update from mmx ?
    2.) try installing Cachemate from market and try clearing the cache
    3.) some times a simple restart ( twice) helps
    4.) it might be some problem with ur router try restarting the router
    5.) try deleting the wifi and connecting again

    As it has to be noted that in a ROM installation if wifi bugs are present , the wifi does not start up ... it displays "Error" message, more over the wpa supplicant is also not touched by me..
    you can try the above options and i am sure the problem wil be solved ..
    EverWin likes this.
  11. karandpr

    karandpr Well-Known Member

    SHA 512 and Whirlpool .Do you work for the military ,DOD !! :p :D .SHA 256 is more than enough .(I dont trust Md5 though .Curse you google)

    Second thing
    For busybox
    JRummy's one is better than Stericson :) (preference :) )
    Busybox
    ninadchaudhari and EverWin like this.
  12. EverWin

    EverWin Active Member

    1.) yes done that & WiFi works
    Flashed your system.img again
    2.) Installed Cachemate
    3.) rooting twice done
    4.) nup WiFi working Fine on other devices
    5.) Done several times. also, tried Open Shared without any luck.

    None of the above worked :(
    I have to flash system.img only or else just like new mmx update?

    MeanWhile: in WiFi setting, under Advanced, configured Static IP & it fixed the WiFi problem
    can't obtain ip address from DHCP server :(
  13. chughgopal

    chughgopal Well-Known Member

    I hope I get my PC soon.
    Wanna root mmx fast
    Till then enjoying Optimus one
  14. ninadchaudhari

    ninadchaudhari What's up !

    @ karan
    Thanks i am replacing the link with JRummy's Busybox :)
    I just saw the number of comments :p

    Thanks !

    More over I just thought If All of us can use SHA512 also just few seconds are required then y not go for it :D :D :D
  15. kumar abhishek

    kumar abhishek Well-Known Member


    +1 same problem with me
    ninadchaudhari likes this.
  16. ninadchaudhari

    ninadchaudhari What's up !

    @ abhishek I think simple reboot should have solved the problem but as even u are facing it let me go in deep now !
    jus try simple reboot though i will start fixing that bug.
    more over the everwin confirmed abt wifi correction if he has fixed wifi ip

    TRY THESE THINGS
    after applying rooted zip


    TRY a factorty reset......
    also the BEST FIX : use static ip address it is no harm in it

    as if there is a problem in the ROM usually you see Error in starting up wifi
    refer

    http://forums.androidcentral.com/sprint-optimus-s/147015-wifi-wont-connect-after-root.html

    [Q] WiFi problem: stuck on "getting IP address" [Archive] - xda-developers


    I will be solving the problem soon .
  17. akhil A75

    akhil A75 Active Member

    Please ninad post a video how to root A75
  18. ninadchaudhari

    ninadchaudhari What's up !

    :) video coming soon ...
    the problem is that i do not actually own a A75 :eek:
    I have requested a member to do it for u guys though :)
    pkotenetwork likes this.
  19. ninadchaudhari

    ninadchaudhari What's up !

    @every one
    plz try factory reset , and use static Ip for solving problem
  20. kumar abhishek

    kumar abhishek Well-Known Member


    I cant do factory reset because I uninstalled default launcher and wt do u mean by static ip?
  21. ninadchaudhari

    ninadchaudhari What's up !

    No problem just go to titanium backup and convert ur default launcher to system app ! then even if u do a factory reset that launcher will not be lost and ya one more thing remember never ever remove any launcher from the system
    at-least keep any launcher (any one u love) will do but keep one in system

    2.) when u go to advanced options you will see manual entry of wifi details
    just add something like IP: 192.168.1.64
    subse :255:255:255:0
    note these are just the most general settings they may var according to ur installation if u need help do contact me via a pm.
    kumar abhishek likes this.
  22. akhil A75

    akhil A75 Active Member

    win hasher saying the hashes do not match
  23. akhil A75

    akhil A75 Active Member

    ninad plz help me out!!!!!!!!!!!!!!!!!!!!!!!
  24. 545himanshu

    545himanshu Active Member

    can you plz give instruction to flash micromax a75
  25. ninadchaudhari

    ninadchaudhari What's up !

    be sure that u only compare the SHA512 hashes with SHA512 ones .
    akhil A75 likes this.
Loading...

Share This Page